Hardware - Running Logitech Quickcam on a vintage Kanotix?

tuxedo - 05.03.2009, 18:36 Uhr
Titel: Running Logitech Quickcam on a vintage Kanotix?
I run a Kanotix 2005-04 and I am totally complacent to update until a next major release. Does anyone know how to run a Quickcam USB cam on this classic model?

I'd like to use the cam primarily for Skype video, but its not the hardware or the particular application that causes the problem as far as I understand, but video input in general, probably affecting more or less any camera hardware that I might try.

The cam I have is combined with a microphone and the microphone works, so at least the sound-in part of the hardware is OK. In fact, the cam-input worked once on an earlier Kanotix but I cannot remember how it was done. The camera works in Windows, meaning the cam part of the hardware should also be OK.

Although various relevant video libraries appears to be installed on the system, such as, linux-uvc-tools (version 0.1.0.svn120-2), qc-usb-source (version 0.6.6-2) etc., when running for example 'camorama', the result is:
Cold not connect to video device (/dev/video0). Please check connection

Or when trying to open the video device in the CamStream application, there are no devices to choose from.

Similar symptoms applies to the Skype: Video devices -> options -> selection menu [No devices Found].

For some reason the system does not see any video source in /dev/video0

Perhaps a special driver is needed, although I guess the existing qc-usb-source should be all I need? The particular cam is called QuickCam Logitech Deluxe, no model number exists as far as I can find.

Has anyone managed to get this particular cam working?

The output of uname and usb information are included below. The Logitech device is indeed found to be plugged in.

Are there any old Kanotix fix script that might help?

Thanks in advance for any tips.


uname -a
Linux tuxedo 2.6.14-kanotix-9 #1 PREEMPT Wed Dec 28 10:17:53 CET 2005 i686 GNU/Linux

/sbin/lsmod | grep -i usb
snd_usb_audio 70336 0
snd_usb_lib 13824 1 snd_usb_audio
snd_rawmidi 20128 1 snd_usb_lib
snd_hwdep 6816 1 snd_usb_audio
usbhid 45024 0
snd_pcm 76808 7 snd_usb_audio,snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd 45156 23 snd_usb_audio, snd_rawmidi, snd_seq_device, snd_hwdep, snd_intel8x0m, snd_intel8x0, snd_ac97_codec, snd_pcm_oss, snd_mixer_oss, snd_pcm, snd_timer
usbcore 102912 7 quickcam,snd_usb_audio,snd_usb_lib,usbhid,ehci_hcd,uhci_hcd

Bus 001 Device 010: ID 046d:08d8 Logitech, Inc.
Bus 001 Device 010: ID 046d:08d8 Logitech, Inc.
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Kano - 05.03.2009, 23:00 Uhr
Titel: Running Logitech Quickcam on a vintage Kanotix?
Please use a newer version with a 2.6.28 kernel.
tuxedo - 06.03.2009, 07:20 Uhr
I just tested 2007 RC7 and the live CD won't even boot on my notebook for some reason. I guess updating only the kernel is a complex procedure, so I think I'll wait for the next major Kanotix release before upgrading anything else.

Thanks for the info.

Alle Zeiten sind GMT + 1 Stunde
PNphpBB2 © 2003-2007