kanotix.com

Entwicklung - openjdk-8-jre für Buster

desin - 22.04.2019, 13:17 Uhr
Titel: openjdk-8-jre für Buster
Oracle hat die Nutzungsbedingungen geändert

nun bin schon mal hier gelandet

https://jdk.java.net

wie weiter ?
retabell - 23.04.2019, 20:43 Uhr
Titel: Re: openjdk-8-jre für Buster
Warum nimmst Du nicht das openjdk aus Debian? oder muss das die 8 sein?

Code:
apt install default-jdk


mit buster wird das: openjdk-11-jdk
desin - 24.04.2019, 09:58 Uhr
Titel:
ich hatte eigentlich gehofft dass 11-jre für alles reichen würde

meine Steuerärklärung will aber explizit openjdk-8-jre nachinstallieren

update-alternatives --config java

0 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 automatischer Modus
1 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 manueller Modus
* 2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 manueller Modus

stimmt der Pfad ?

danke im voraus
retabell - 24.04.2019, 20:50 Uhr
Titel:
das jdk brauchst Du dann wohl nicht
sondern das jre sollte reichen.

Code:
apt-install default-jre


andersrum gesehen ist java ja mit in den isos.

Wenn dein Programm partout die Version 8 haben will,
dann musst Dir was einfallen lassen, wie es aussieht hast ja die Version 8 installiert.
Alle Zeiten sind GMT + 1 Stunde
PNphpBB2 © 2003-2007