23.09.2014, 10:07 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
mzilikazi
Titel: Enlightenment 17 installation howto.  BeitragVerfasst am: 10.11.2005, 18:16 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Edit Updated and checked for accuracy & checked links on 11/14/06. Please post any problems you might have.

Latest news:
E17 now uses FDO .desktop files most of which are located in /usr/share/applications.

If you start E17 from command line e.g. no KDM or GDM or Entrance you must use
Code:
startx /usr/bin/enlightenment_start
.
DO NOT use:
Code:
startx /usr/bin/enlightenment


So we now have a new edevelop repository that is updated quite frequently for E17. How often is frequent? About 3 times weekly! Winken

I'll try to put together a bit of a howto here for those of you interested in installing E17 on your 32bit Debian boxen. Yes, E17 is still Alpha code but I've been happily using it for some time now on 3 different boxes as my work-a-day desktop w/ no worries. OK that's not entirely accurate. Let's just say that you should always keep another wm on hand just in case. Winken E17 is still alpha code afterall. Fear not!

OK let's make this clear.
A line that begins w/ # means "do this as root"
A line that begins w/ $ means "do this as user"
It might be best to copy/paste the following commands. Specifically the first one - you don't want to hose up /etc/apt/sources.list. Winken Yes, you can still edit sources.list with your favorite editor. I suggest using xedit but that's only because it's always installed and supports copy/paste. Use whatever editor you like.

Add the new repository:
Code:

$ su
# echo "deb http://www.edevelop.org/debian unstable main" >> /etc/apt/sources.list


Install the new key:
Code:
# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 03CA4243
# apt-key add /root/.gnupg/pubring.gpg


Update
Code:
# apt-get update


Install E17
Code:
# apt-get install e17 e17-extras emodule0*


Now you should be able to log out and back in choosing Enlightenment as your desktop. You can install entrance (e17 log in manager) but it has been buggy on occasion so unless you know how to deal with it perhaps it's best to stick w/ KDM or GDM or XDM or whatever you presently use.

*NOTE* If you install Entrance it will automatically select the last user for login. The only way to change users is to enter an incorrect password.
Yes it's a bug. Yes it's on the todo list.
----------------------------------------------------------------------------------------------------------

Well that's it. Congrats! You've got E17! Now you probably want to do some custom configuration! Go here:
http://get-e.org READ the user manual. This is the best resource for documentation related to E17 and it's actually updated quite frequently.

Customization




*TIPS*
Modules
If you don't have a module enabled you may as well unload it since it still consumes resources.

Enable some modules:
Menu>Configuration>Modules

Enable those you wish to keep and disable those you do not wish to use.
To use the modules they must be added to a Shelf.
Menu>Configurations>Shelves
-----------------------------------------------------------------------------------------------------------
Edit the menu
Left click>Configuration>Configuration panel>Applications
Also look at the .order files in all directories below ~/.e/e/ to edit manually.

*HINT* Drag & drop .desktop files from /usr/share/applications to add apps to the ibar.
------------------------------------------------------------------------------------------------------------
Get some themes:
http://get-e.org/Themes/E17/index.html

Put your themes in
Code:
~/.e/e/themes

Now you can change the theme w/
Left click>Configuration>Configuration panel>Theme Selector
------------------------------------------------------------------------------------------------------------

Backgrounds
You can use the E17 wallpaper app in the menu OR my favorite is the Ephoto module. Just point it to a directory of images and Update. Then add the ephoto module to a shelf. You can configure ephoto to browse and set wallpapers in 1 click.
--------------------------------------------------------------------------------------------------------
Icon themes
Now E17 has a friendly Icon theme selector in the config panel.
--------------------------------------------------------------------------------------------------------

*KNOWN PROBLEMS*

This is not really an issue any longer but just in case.
No Enlightenment option in my log in manager!
You should have enlightenment.desktop in /usr/share/xsessions
Code:
ls /usr/share/xsessions
enlightenment.desktop

-----------------------------------------------------------------------------------------------------------
*NOTE* Some of the apps made specifically for E17 don't (yet) work as well as they could. I still prefer rox-filer as my file manager and Archive or xarchive for (un)archving files.
-----------------------------------------------------------------------------------------------------------
*NOTE* ENGAGE IS BROKEN (yes still)
It exists as a standalone app for now but it does not appear on all desktops. You simply run it directly.

*NOTE* The rest of section is not relevant until engage is fixed or becomes a module again.

Engage
Engage is a tool bar w/ zoomable icons.
Code:
apt-get install engage

You must first load Engage since it is a module.
Code:
enlightenment_remote -module-load engage
enlightenment_remote -module-enable engage

Or just use the Configuration Panel>Modules

Now you should create the .order file for engage in
~/.e/e/applications/bar/engage/.order
This file will dictate what apps are listed in Engage.
--------------------------------------------------------------------------------------------------------

Handy links
E17 forums: http://www.edevelop.org/
e17genmenu forums: http://sourceforge.net/forum/?group_id=131470
E17 FAQ: http://get-e.org/Main/FAQs/index.html
E17 links: http://get-e.org/Main/Links/index.html
---------------------------------------------------------------------------------------------------------

More to come! Please leave feedback w/ problems and I'll help as best as I can. If somethings hosed in the howto let me know and I'll fix it. Join #get-e on IRC for some great help from knowledgeable peple but BE SURE to read the FAQ and user manual @ get-e.org. After all what's the point of writing it if no one reads it?

_________________
Ubuntu - An ancient African word for "Can't install Debian"


Zuletzt bearbeitet von mzilikazi am 14.11.2006, 16:41 Uhr, insgesamt 34 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
jackiebrown
Titel: RE: Enlightenment 17  BeitragVerfasst am: 11.11.2005, 00:29 Uhr



Anmeldung: 13. Mai 2005
Beiträge: 732
Wohnort: Texas
I tried it a week ago. I think I will revisit it using your guide. Thanks.

_________________
Always acknowledge a fault. This will throw those in authority off their guard and give you an opportunity to commit more.
Mark Twain
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ironwalker
Titel: RE: Enlightenment 17  BeitragVerfasst am: 11.11.2005, 02:32 Uhr



Anmeldung: 21. Jan 2005
Beiträge: 454
Wohnort: NYC/NJ Area
Nice job,thank you.I never really tried E before,I will now.Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Superrakete
Titel: Re: Enlightenment 17  BeitragVerfasst am: 15.11.2005, 18:11 Uhr



Anmeldung: 05. Jul 2004
Beiträge: 121
Wohnort: Hannover
mzilikazi hat folgendes geschrieben::


Install E17
Code:
# apt-get install engage eclair enlightenment-data emodules evidence evas0-bin embryo0-bin e17genmenu etk elicit eterm express epsilon0-bin epeg0-bin edje0-bin enterminus evfs examine
entice enlightenment edb-tools enscribe-efl eutils entropy




You have a carriage return behind "examine". So copy/paste will not install all packages by default for inattentive users.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
etorix
Titel: RE: Re: Enlightenment 17  BeitragVerfasst am: 15.11.2005, 18:29 Uhr
Team Member
Team Member


Anmeldung: 23. Dez 2003
Beiträge: 109

fine

_________________
namu amida butsu
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ironwalker
Titel: RE: Re: Enlightenment 17  BeitragVerfasst am: 15.11.2005, 21:31 Uhr



Anmeldung: 21. Jan 2005
Beiträge: 454
Wohnort: NYC/NJ Area
Ya,I caught that.Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: Enlightenment 17  BeitragVerfasst am: 15.11.2005, 22:23 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Superrakete hat folgendes geschrieben::
You have a carriage return behind "examine". So copy/paste will not install all packages by default for inattentive users.


Hmm how did that sneak in there? Oh well - fixed now!

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Mike Shepard
5 Titel: Toolbar???  BeitragVerfasst am: 21.11.2005, 14:34 Uhr



Anmeldung: 20. Mai 2005
Beiträge: 250

How do I install the toolbar (app bar, whatever its called at the bottom of the screen) from enlightenment 16 onto 17?? I prefer the way the app icons enlarge when your mouse scrolls over them. The install worked great by the way. I am just trying to get a desktop to look more like the one on the elite cd. Thanks for any help.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Mike Shepard
5 Titel: Toolbar???  BeitragVerfasst am: 21.11.2005, 14:35 Uhr



Anmeldung: 20. Mai 2005
Beiträge: 250

How do I install the toolbar (app bar, whatever its called at the bottom of the screen) from enlightenment 16 onto 17?? I prefer the way the app icons enlarge when your mouse scrolls over them. The install worked great by the way. I am just trying to get a desktop to look more like the one on the elite cd. Thanks for any help.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 14:52 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Mike Shepard hat folgendes geschrieben::
How do I install the toolbar (app bar, whatever its called at the bottom of the screen) from enlightenment 16 onto 17?? I prefer the way the app icons enlarge when your mouse scrolls over them. The install worked great by the way. I am just trying to get a desktop to look more like the one on the elite cd. Thanks for any help.


That's a common question. E17 has 2 'toolbars'. The default is called Ibar and is enabled by default. The one you'e looking for has zoomable icons and is called Engage. Please see the section of the above howto labled Engage. First you absolutely MUST get some icons and put them in
Code:
~/.e/e/applications/all
. Then run e17genmenu (also freshly updated btw). This creates the eap icons that E17 uses. You can then add icons to Engage, Favorites, Ibar, Startup menus w/ Entangle the E17 menu editor.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Mike Shepard
Titel: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 15:51 Uhr



Anmeldung: 20. Mai 2005
Beiträge: 250

Thankyou once again mzilikazi. I appriciate all your help, the enlightenment desktop is really getting my attention. The more I use it, the more I like it. Customizing is the problem which I am learning. I am also comparing with the elive cd (which won't install btw). But ne ways thanks for the quick response.

_________________
"It's 106 miles to Chicago, we've got a full tank of gas, half a pack of cigarettes, it's dark, and we're wearing sunglasses." -The Blues Brothers (1980)
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
ironwalker
Titel: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 17:28 Uhr



Anmeldung: 21. Jan 2005
Beiträge: 454
Wohnort: NYC/NJ Area
I am starting to like E,but,how do I get out of edit mode?I did it once but cannot find the option now.
Its probably right in front of me.Sehr glücklich
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 18:36 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
ironwalker hat folgendes geschrieben::
I am starting to like E,but,how do I get out of edit mode?I did it once but cannot find the option now.
Its probably right in front of me.Sehr glücklich


Right click any of the modules on the desktop and select 'End Edit Mode'

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
mzilikazi
Titel: New modules  BeitragVerfasst am: 21.11.2005, 21:01 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
There are some new modules that haven't yet made it into the Debian repository.
Eloquence, Screenshot, Slideshow & Mount.

No worries, you can easily build them yourself. No need to build them as root - they will install to your users home directory. Be certain to set the --build flag since the debs from our repo were compiled w/ i486, otherwise you'll get a 'module <blah> not found' when you attempt to load it.

For each module you want to build simply unpack the archive, cd into the directory and build:

Code:
$ wget http://get-e.org/Resources/Modules/_files/eloquence-0.4.2.tar.gz
$ unp eloquence-0.4.2.tar.gz
$ cd eloquence-0.4.2
$ ./autogen.sh  --build=i486-linux-gnu
$make
$make install


To load the module use enlightenmnet_remote or erme (see above)
Code:
enlightenment_remote -module-load eloquence


Note that you'll need xmms-dev (and/or bmp-dev) before eloquence will build. Currenly eloquence only supports bmp & xmms.

To use the screenshot module I would recommend installing scrot.

Evolume
Evolume is a little different in the build process.
Code:
$ ./configure
$ make
$ make install


Enjoy!

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 22:03 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Mike Shepard hat folgendes geschrieben::
Thankyou once again mzilikazi. I appriciate all your help, the enlightenment desktop is really getting my attention. The more I use it, the more I like it. Customizing is the problem which I am learning. I am also comparing with the elive cd (which won't install btw). But ne ways thanks for the quick response.


I'm kind of partial to it myself. Smilie Configuration gets easier all the time. Besure to get the icons and run e17genmenu. THen run entangle (both from command line). The E17 Configuration Panel is being worked on and changes in functionality on any given day but executing entangle (menu editor) & emblem (background selector) from commad line always works. Of course you could easily create an eap for entangle & emblem w/ e_util_eapp_edit and add them to your Favorites or Engage. I'll write a bit more about e_util_eapp_edit another time.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 22:10 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Mike Shepard hat folgendes geschrieben::
Thankyou once again mzilikazi. I appriciate all your help, the enlightenment desktop is really getting my attention. The more I use it, the more I like it. Customizing is the problem which I am learning. I am also comparing with the elive cd (which won't install btw). But ne ways thanks for the quick response.


I'm kind of partial to it myself. Smilie It does require a different way of thinking about the desktop since it doesn't resemble the win32 UI design at all (thankfully).

Configuration of E17 gets easier all the time. Tools to help you:

Enlightenment Remote Made Easy to help w/ enlightenment_remote & it's many many parameters.

e17genmenu Run e17genmenu after you get some icons.

Entangle Use it to edit your menus.

Emblem Background selector. Put some wallpapers (w/ .edj extension) in ~/.e/e/backgrounds then run emblem.

The E17 Configuration Panel is being worked on and changes in functionality on any given day but executing entangle (menu editor) & emblem (background selector) from commad line always works. Of course you could easily create an eap for entangle & emblem w/ e_util_eapp_edit and add them to your Favorites or Engage. I'll write a bit more about e_util_eapp_edit another time.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
mzilikazi
Titel: RE: Re: RE: Re: Toolbar???  BeitragVerfasst am: 21.11.2005, 22:36 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Many of the apps & themes & other E17 related stuff is scattered about the net and not necissarily linked to any one place. I just found these and they remain as of yet untested. :/ If you try any of these out please let us know if they work.

Calendar module:
http://student.dcu.ie/~cayeny2/linuxEn.html

Embrace - mail checker
http://code-monkey.de/projects/embrace

Some new themes and misc other stuff:
http://vandango.toenda.com/index.php/se ... emplate:vd

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Mike Shepard
5 Titel: Configuration Problems  BeitragVerfasst am: 28.11.2005, 11:01 Uhr



Anmeldung: 20. Mai 2005
Beiträge: 250

Using your installation guide and help, I've been playing with enlightenment for a while now on kanotix. I've got it running good, but am having major configuration problems. I know it's still in the development stage but I haven't seen much of these errors posted anywhere else. I know it's not my computer 'cause I've installed it on 2 different ones. Here are a few of the major ones to see if you have any ideas. For the record I also did a hd install of the elive cd and these aren't there.
1. I can't get evidence running. When I type it at the command line, I get the error
Code:
enlightenment: error while loading shared libraries: libdirectfb-0.9.so.20: cannot open shared object file: No such file or directory
I tried installing the libdirectfb-0.9-22_0.9.22-8_i386.deb but no-go. I then reverted back to a older version of evidence being 9.8-20050305 and that works but I don't get the info when my mouse rolls over the folders like in the elive version. I read somewhere about installing DirectFB22 but I dunno.
2. When I type entangle at the command line and then right click in the window I get the error of
Code:
*** glibc detected *** double free or corruption (!prev): 0x082322d8 ***
Aborted
Not a big deal, I figured out how to edit the menus throught Midnight Commander, but it would be nice to get working.
3. Loading the engage module the way you said adds it to the module menu but not in the entangle area. Had to manually edit it with mc. After creating a folder and .order file and copying the .eap.cache.cfg from the ibar, it then appeared in entangle.

K, 2 small things now, how do I get icons for use in creating .eap icons via EAP Editor? And more importantly how do I get the engage bar to not add window icons to its bar? I have assigned icons to it, but whenever I open a file it adds an icon while the files window is open. That gets annoying.
Thankyou so much for all your help Sehr glücklich
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel: Re: Configuration Problems  BeitragVerfasst am: 28.11.2005, 12:35 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Mike Shepard hat folgendes geschrieben::

1. I can't get evidence running. When I type it at the command line, I get the error
Code:
enlightenment: error while loading shared libraries: libdirectfb-0.9.so.20: cannot open shared object file: No such file or directory
I tried installing the libdirectfb-0.9-22_0.9.22-8_i386.deb but no-go. I then reverted back to a older version of evidence being 9.8-20050305 and that works but I don't get the info when my mouse rolls over the folders like in the elive version. I read somewhere about installing DirectFB22 but I dunno.


Well personally I find evidence to be too lacking in features and haven't really used it. Rox is still my file manager of choice. I do have these debs installed but I don't think you need the -dev debs unless you intend on building from source:
Code:
ii  libdirectfb-0.9-22                        0.9.22-8                             
ii  libdirectfb-bin                           0.9.22-8                 
ii  libdirectfb-dev                           0.9.22-8                     
ii  libdirectfb-udeb-dev                      0.9.20-5                             


Zitat:
2. When I type entangle at the command line and then right click in the window I get the error of
Code:
*** glibc detected *** double free or corruption (!prev): 0x082322d8 ***
Aborted
Not a big deal, I figured out how to edit the menus throught Midnight Commander, but it would be nice to get working.


No idea.

Zitat:
3. Loading the engage module the way you said adds it to the module menu but not in the entangle area. Had to manually edit it with mc. After creating a folder and .order file and copying the .eap.cache.cfg from the ibar, it then appeared in entangle.


Hmm wonder why .eap.cache.cfg was not created automatically?

Zitat:
K, 2 small things now, how do I get icons for use in creating .eap icons via EAP Editor?


I have yet to get the EAP Editor to work and experienced the same issues as you have. It simply does nothing but look nice at this point. Smilie

Zitat:
And more importantly how do I get the engage bar to not add window icons to its bar? I have assigned icons to it, but whenever I open a file it adds an icon while the files window is open. That gets annoying.
Thankyou so much for all your help Sehr glücklich


Disable the system tray:
Code:
Modules>Engage>Configuration>System Tray


Maybe try the e-users mailing list. They're a pretty helpful group.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Mike Shepard
Titel: Enlightenment  BeitragVerfasst am: 28.11.2005, 14:53 Uhr



Anmeldung: 20. Mai 2005
Beiträge: 250

Thanks again for your help. Unfortunently I already installed all the libdirectfb debs with no change, and have already disabled the system tray for engage. I guess I'll just play with it some more. I just don't understand why the old evidence works and the new one requires a file I can't find anywhere. Oh well, I give it a few more shots. Thanks
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Murdoc
Titel:   BeitragVerfasst am: 09.12.2005, 16:27 Uhr



Anmeldung: 25. Jan 2005
Beiträge: 93
Wohnort: Paderborn, Germany
Thank you for this great manual!
I have tried to install enlightenment, but I always get an error message:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
eclair: Hängt ab: libtag1c2 (>= 1.4) soll aber nicht installiert werden
enlightenment: Hängt ab: enlightenment-data (= 1:0.16.7.2-1) aber 0.16.999.022-0cvs20051209 soll installiert werden
enlightenment-data: Hängt ab: enlightenment (= 0.16.999.022-0cvs20051209) aber 1:0.16.7.2-1 soll installiert werden
E: Kaputte Pakete

Sorry that this is in german. It says that it can't be installed because of dependencies. What can I do to work with enlightenment?

Greetings,
Matthias
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel:   BeitragVerfasst am: 09.12.2005, 20:41 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
Murdoc hat folgendes geschrieben::
Thank you for this great manual!
I have tried to install enlightenment, but I always get an error message:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
eclair: Hängt ab: libtag1c2 (>= 1.4) soll aber nicht installiert werden
enlightenment: Hängt ab: enlightenment-data (= 1:0.16.7.2-1) aber 0.16.999.022-0cvs20051209 soll installiert werden
enlightenment-data: Hängt ab: enlightenment (= 0.16.999.022-0cvs20051209) aber 1:0.16.7.2-1 soll installiert werden
E: Kaputte Pakete

Sorry that this is in german. It says that it can't be installed because of dependencies. What can I do to work with enlightenment?

Greetings,
Matthias


Well my german isn't so great and it would be nice to see exactly what apt is telling you but I'll give it a go.

Looks like you need some packages:
Code:
apt-get install libtag1c2 libtagc0

Maybe that fixes the eclair error. BTW you don't need eclair to run E17 since eclair is a multimedia player and not part of ecore.

Make sure you're geting the right enlightenment. Looks like you're trying to install e16. (16.7) Yes the versioning can be a bit confusing. Smilie
Code:
$ apt-cache policy enlightenment
enlightenment:
  Installed: 0.16.999.022-0cvs20051209
  Candidate: 0.16.999.022-0cvs20051209
  Package pin: 0.16.999.022-0cvs20051209
  Version table:
     1:0.16.7.2-1 999
        990 http://ftp.debian.org unstable/main Packages
 *** 0.16.999.022-0cvs20051209 999
        990 http://gefechtsdienst.de unstable/main Packages
        100 /var/lib/dpkg/status


If you don't see candidate: 0.16.999.022-0cvs20051209 then I'd suspect you forgot to edit /etc/apt/preferences. It's entirely possible that you don't even have this file since it is not required for apt to work. Just create it, run apt-get update and try again. Also check to see if you have some of enlightenment already installed. If you have anything from e16 you should probably remove it.

FYI I just installed the latest build from 12/9/05 and it's working beautifully.

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Murdoc
Titel:   BeitragVerfasst am: 15.12.2005, 12:30 Uhr



Anmeldung: 25. Jan 2005
Beiträge: 93
Wohnort: Paderborn, Germany
Hallo,

now I got help from the german part of the forum and switched to english error messages:
Zitat:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
eclair: Depends: libtag1c2 (>= 1.4) but it is not going to be installed
enlightenment: Depends: enlightenment-data (= 1:0.16.7.2-1) but 0.16.999.022-0cvs20051212 is to be installed
enlightenment-data: Depends: enlightenment (= 0.16.999.022-0cvs20051212) but 1:0.16.7.2-1 is to be installed
E: Broken packages


It would be nice if anybody could help me, because Enlightenment seems to be the right software for me.

Thanks!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mzilikazi
Titel:   BeitragVerfasst am: 15.12.2005, 21:38 Uhr
Team Member
Team Member


Anmeldung: 17. Dez 2003
Beiträge: 1109
Wohnort: Ganymede
You're trying to install e16 not e17. Did you edit /etc/apt/preferences?

_________________
Ubuntu - An ancient African word for "Can't install Debian"
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Murdoc
Titel:   BeitragVerfasst am: 16.12.2005, 09:00 Uhr



Anmeldung: 25. Jan 2005
Beiträge: 93
Wohnort: Paderborn, Germany
Yes, I did. Does a apt-get remove enlightenment remove all stuff which belongs to enlightenment? Perhaps I could try to do everything from the beginning?

Thank you for your help!

/Edit

Now Enlightenment works. I love ist and hope to do all things I do with KDE. Does a taskbar exist for enlightenment?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.