26.12.2014, 06:34 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
shame
Titel: Printer stopped working after upgrade  BeitragVerfasst am: 10.06.2006, 12:22 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
After spending days trying to get my printer to work and finally succeeding, various printer related packages have been upgraded in the last couple of days and now the printer stopped working.
When I try to print it is added to the jobs but it says no printer is connected.
I've removed and re-added my printer and that appears to go ok but it still says not connected.
There's nothing wrong with the cables and it is still printing normally in suse.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
drb
Titel:   BeitragVerfasst am: 10.06.2006, 13:19 Uhr



Anmeldung: 03. Jul 2004
Beiträge: 525

Not sure what your problem is as my printers are working OK.

I removed the printers and readded after cups upgrades (this didn't appear to work with your set up). This initially worked until the second upgrade a day later. I then found I needed to delete/add the printers a second time, but this time the printer had to be switched on so it was recognised as a device before I can add the printer.

Try a second add printer - note whether the printer is recognised when it is switched on in the kde printer configurer.

drb

_________________
Kernel 2.6.21-slh-up-7
_____________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hubi
Titel:   BeitragVerfasst am: 10.06.2006, 14:05 Uhr



Anmeldung: 22. Jan 2006
Beiträge: 1296
Wohnort: Budapest
shame,
you might find the answer in this thread:
http://kanotix.com/PNphpBB2-viewtopic-t-18742.html

hubi

_________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 11.06.2006, 16:04 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
Yes it does seem to be the same problem. Some people have got their printers working but nothing in that thread got mine working unfortunately. Guess I'll just keep upgrading and wait for it to sort itself out.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ice
Titel:   BeitragVerfasst am: 13.06.2006, 00:51 Uhr



Anmeldung: 25. Feb 2005
Beiträge: 106

Cups support for parallel printing is currently broken. There are a million bug reports already floating around, even Debian bug tracking system couldn't cope with it:

http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=cupsys
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 22.06.2006, 09:36 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
Can anyone tell me if they are still having any problems printing? It's been almost 2 weeks since I started this thread, all the printing stuff was upgraded yesterday and I'm still unable to get printing working.
I get this error -
Code:
Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: the IPP request failed for an unknown reason.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
drb
Titel:   BeitragVerfasst am: 22.06.2006, 10:53 Uhr



Anmeldung: 03. Jul 2004
Beiträge: 525

I didn't have your CUPS connection error. Printers have worked fine except I've only been able to set up printerswith KDE Print Manager as local:host couldn't find my printer. After the upgrade today I can use localhost:631 to add my printer . . . but only as a parallel printer. I then went to KDE Print Manager to change the propertries to USB!

drb

_________________
Kernel 2.6.21-slh-up-7
_____________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 22.06.2006, 16:30 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
shame: If it's any consolation to you my printer stopped working AGAIN as well. I did manage to get it working following suggestions in the thread
http://kanotix.com/PNphpBB2-viewtopic-t-18742.html
but after I rebooted I'm back to square one with the same error message you posted. I guess we're supposed to sit around & twiddle our thumbs until this issue is resolved Traurig

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 23.06.2006, 10:51 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
I still haven't managed to get it working at all, even following that thread.
I've been searching google like mad for a workaround but still nothing.
It's strange that some people are having problems and others aren't.
This is the longest I have had a problem when using kanotix/debian sid.
The cups stuff has been updated 2 or 3 times since I started having these problems and the fact it's still not working tends to make me think just waiting around and upgrading isn't going to solve it for me.
I have noticed also that when I remove and try adding the printer, both in gnome and kde, the printer isn't actually being detected anymore since the last update.

<EDIT>
Well it's just getting wierd now. I ignored the server error message and tried adding the printer again. Although the printer wasn't named I just selected the parallel port it connects to normally. Tried printing a few test pages and some of them it printed ok and others it printed a few lines then just fed the paper out.
I've now tried printing various documents from different apps and it's doing the same, some things print ok and others just print a few lines, even when printing the same document from the same app several times.
Still, I suppose it's an improvement.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
wakarimasen
Titel:   BeitragVerfasst am: 23.06.2006, 12:28 Uhr



Anmeldung: 09. Jun 2005
Beiträge: 120
Wohnort: Bromsgrove, UK
I have the same problem - only the first page of any document prints correctly. Each subsequent page comes out blank. This means that a 10 page document needs to be printed out one page at a time.... Weinen

_________________
tap tap tap....
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 23.06.2006, 16:44 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
I can't even use the Control Center add printer wizard cause the backend options were greyed out. It's the same wether I'm in administrator mode or not. I went through all the steps I had taken before, purging & re-installing, & noticed that my /etc/cups/printer.conf file had somehow disappeared. I created a new one with nano using what I had posted earlier, and this time I was able to select a backend with the wizard, but could not finish installation because "unable to create temporary printer" and "client-error-bad-request" This sucks.

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
drb
Titel:   BeitragVerfasst am: 23.06.2006, 17:16 Uhr



Anmeldung: 03. Jul 2004
Beiträge: 525

This printing issue gets stranger by the day. I don't have any printing problems but printer administration issues changes by the day. I don't have any parallel port printers. I can add USB printers via kde print manager or localhost:631 as long as the printer is switched on. (this is a stage further than a few days ago when localhost:631 wouldn't allow USB pribnters to be added). When I go into kde print manager I get the error message with CUPS listed above if I try to enter administrator mode . . . but I can add a printer or take any other action by providing login / password when asked. I think things are improving!

drb

_________________
Kernel 2.6.21-slh-up-7
_____________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 23.06.2006, 17:30 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
Try

modprobe lp
echo lp >> /etc/modules
apt-get remove --purge cupsys
apt-get install cupsys or apt-get install cupsys cupsys-driver-gutenprint hplip

in webbrowser : localhost:631

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
hubi
Titel:   BeitragVerfasst am: 23.06.2006, 17:33 Uhr



Anmeldung: 22. Jan 2006
Beiträge: 1296
Wohnort: Budapest
With cupsys-1.2.1-3 (came in June 21st) I had to edit /etc/cups/cupsd.conf and comment the following line:
Code:
# Listen /var/run/cups/cups.sock
to run USB plugged HP Deskjet printers through kprinter.

hubi

_________________
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 23.06.2006, 18:20 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
I also had printer problems, but have been too lazy the past couple of days to try and fix it, this worked great for me and things are working again. I run a network USB printer to the router. Thanks Master Smilie

piper hat folgendes geschrieben::
Try

modprobe lp
echo lp >> /etc/modules
apt-get remove --purge cupsys
apt-get install cupsys or apt-get install cupsys cupsys-driver-gutenprint hplip

in webbrowser : localhost:631

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 23.06.2006, 19:00 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
I tried
modprobe lp
echo lp >> /etc/modules
apt-get remove --purge cupsys
apt-get install cupsys or apt-get install cupsys cupsys-driver-gutenprint hplip

in webbrowser : localhost:631

tried added a printer but when asked for a username & password I get a blank screen at http//localhost:631/admin

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 23.06.2006, 20:16 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
Hmm, sorry that didn't work for you, this was the only thing that worked for me, did you try rebooting after doing

apt-get install cupsys or apt-get install cupsys cupsys-driver-gutenprint hplip

and then going to localhost:631

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 23.06.2006, 20:39 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
yes I did reboot & still get redirected to http://localhost:631/admin with nothing but a blank page. A printer doesn't get added. Does it matter what gets entered in the username & password boxes? Is there something specific that must be entered there? I tried using "root" as password as well as other things, but the same thing happens.

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 23.06.2006, 20:44 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
Use your normal user login & password and go to Administration -> New Printers Found

Is yours listed ?

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 23.06.2006, 22:30 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
Administration shows 2 printers--canon (parallel Port # 1) which I don't have and epson (parallel Port #1) which I do have. If I try to add the epson I still get redirected to the blank screen. There wasn't an option to remove the canon.

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 23.06.2006, 22:40 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
2radical, sorry but I am stumped Traurig

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 23.06.2006, 23:40 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Try add a generic printer, parser missmatch with cupssys front and backend for windowsbased PPD's
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 24.06.2006, 18:24 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
At this point it appears as though I no longer have a printer for all intents & purpose due to some mysterious bug in KDE, cupsys or something. Yeah, it's a free OS, but I don't think it's too much to expect that such a basic function as printing should work. What's next? No keyboard or CD drives? I'll try dist-upgrading today to see if that helps.

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel:   BeitragVerfasst am: 24.06.2006, 18:35 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
I am sorry you are having so much trouble with this Traurig

I am out of idea's

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
2radical
Titel:   BeitragVerfasst am: 24.06.2006, 18:56 Uhr



Anmeldung: 07. Dez 2005
Beiträge: 369
Wohnort: Port Angeles, Wa. USA
I finished DU-ing & just as suspected when I try to install my printer

Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: host not found.

Cupsys-bsd & cupsys-client were upgraded. I had to do apt-get -f install as several pkgs wouldn't completely install. dpkg-multicd wouldn't install. (error code 1) but that's ok. I may have to switch distributions if a fix can't be found.

_________________
illegitimati non carborundum
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.