22.07.2018, 19:50 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
ted
15 Titel: Ksynaptic Treiber Installation?  BeitragVerfasst am: 10.07.2006, 19:07 Uhr



Anmeldung: 04. Jul 2006
Beiträge: 192
Wohnort: Merchweiler
Hallo an alle

Wenn ich Ksynaptic starten will meckert es rum:

No usable driver has been found!
Either your driver is not correctly installed or you are using a wrong version.
You need at least driver version 0.14.4!

Hab hier natürlich schon im Forum gesucht und auch einige infos dazu gefunden aber
komme jetzt nicht weiter.

In der Konsole ein "apt-get install xserver-xorg-input-synaptics/testing"
gibt mir folgendes aus:

Gewählte Version 0.14.5-1 (Debian:unstable) für xserver-xorg-input-synaptics
xserver-xorg-input-synaptics ist schon die neueste Version

Ich hab ja anscheinend einen zu neuen Treiber. Müßte also doch eigentlich funktionieren.
Wie installiere ich den zur Not einen alten?

Qsynaptic funktioniert übrigens, das muss ich aber nach jedem Neustart aufrufen und
einstellen weil es die Einstellungen nicht behält

Hoffe ihr könnt mir (wie schon öfters Smilie) helfen.

gruß, ted


Zuletzt bearbeitet von ted am 31.07.2006, 18:23 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
leberwurst
Titel:   BeitragVerfasst am: 12.07.2006, 09:50 Uhr



Anmeldung: 01. Apr 2004
Beiträge: 17

Ich wollte selber zu dieser Problematik schon ein Thread aufmachen, da bei mir genau die gleichen Symptome in Zusammenhang mit Ksynaptics 0.3.1 und xserver-xorg-input-synaptics 0.14.5-1 auftauchen bzw. über Qsynaptics keine fehlenden oder falschen Treiber bemängelt werden.
Übrigens hatte ich das Problem, mit den angeblich nicht vorhandenen Treiber, auch schon mit Ksynaptics 0.2.3 u. 0.2.4.

Gibt es evt. Ksynaptics-User, die in der V. 0.3.1 keinen fehlenden Treiber gemeldet bekommen, wenn ja, welche Treiberversion ist dort installiert?

Außerdem haben anscheinend besonders die User, die ein Alps-Tochpad benutzen größere Schwierigkeiten. Auch hier wäre es interessant zu wissen, ob auch Benutzer eines "reinrassigen" Synaptics-Pads mit den gleichen Unwegsamkeiten zu kämpfen haben.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ted
Titel:   BeitragVerfasst am: 12.07.2006, 11:19 Uhr



Anmeldung: 04. Jul 2006
Beiträge: 192
Wohnort: Merchweiler
@leberwurst

Bei mir ist's ein Synaptic

_________________
gruß, ted

--
Fujitsu-Siemens Amilo A1630 / Amd Athlon 64 3700+
Kernel 2.6.18.5-slh-smp-1

NoName Desktop / Amd Athlon XP 2000+
Kernel 2.6.18.4-slh-up-1
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
zulu9
Titel:   BeitragVerfasst am: 12.07.2006, 15:00 Uhr



Anmeldung: 31. Jul 2004
Beiträge: 249

hatte mit ksynaptics immer schon probleme.
hab mir qsynaptics einfach innen autostart gelegt.

_________________
http://kanotix.wordpress.com/ inoffizielles Kanotix-Blog
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ted
Titel:   BeitragVerfasst am: 12.07.2006, 16:26 Uhr



Anmeldung: 04. Jul 2006
Beiträge: 192
Wohnort: Merchweiler
EES555 hat folgendes geschrieben::
hatte mit ksynaptics immer schon probleme.
hab mir qsynaptics einfach innen autostart gelegt.


qsynaptics ist bei mir aber vergesslich.
Muss meine Einstellungen jedesmal neu machen

_________________
gruß, ted

--
Fujitsu-Siemens Amilo A1630 / Amd Athlon 64 3700+
Kernel 2.6.18.5-slh-smp-1

NoName Desktop / Amd Athlon XP 2000+
Kernel 2.6.18.4-slh-up-1
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 12.07.2006, 20:09 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1720

Nicht jedes Touchpat wird von snapitc oder Ksynapti unterstüztz. Einige laufen auch mit einem PS/2_Mausprotokol, und hier hilft Synapitc nicht.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
leberwurst
Titel:   BeitragVerfasst am: 18.07.2006, 11:11 Uhr



Anmeldung: 01. Apr 2004
Beiträge: 17

Nach Rückfrage bei Stefan Kombrink (Autor Ksynaptics und Qsynaptics) muß bei Ksynaptics die eingesetzte libsynaptics immer mindestens auf der gleichen Versionhöhe stehen, wie der Synaptics-Treiber. Im aktuellen Fall (libsy. 0.14.4d + synap. Treiber 0.14.5-1) ist die libsynaptic nicht UpToDate.
Für Abhilfe gibt es 2 Möglichkeiten:

1.) Anpassung der libsynaptics auf Version 0.14.5.a, muß aufgrund eines bisher nicht erhältlichen Paketes zu Fuß installiert werden.

http://qsynaptics.sourceforge.net/libsynaptics-0.14.5a-debug.tar.bz2

Aufgrund von Fehlermeldungen beim Compilern, kam ich hier nicht weiter.

2.) Downgrade des Synaptics-Treiber auf irgendeine Version zwischen 0.14.4-1 und 0.14.4-5. Danach funktionierte Ksynaptics wieder bei mir, hatte dann aber das Problem, daß beim Druck auf die Alps-Touchpadfläche der Mauszeiger von der oberen linken Bildhälfte zur unteren rechten Bildhälfte wanderte. Laut Aussage von S. Kombrink ist ihn ein Treiber- bzw. libsynaptics-Bug in diese Richtung nicht bekannt. Natürlich kann das auch interne Ursachen bei mir haben.

Fakt ist, daß man immer bei einen Treiber Versionswechsel einer aktuellen Anpassung der libsynatics hinterher laufen muß. Daher sollte man bei einer funktionierenden Ksynaptics mit einen Treiber-Update solange warten bis sichergestellt ist, daß eine ensprechende libsynaptic-Version vorliegt. So gibt es für den aktuellsten Synaptics-Treiber (0.14.6-1) noch keine passende libsynaptics.

Da Qsynaptics übrigens keinen Gebrauch von der libsynaptis macht, sind hier die oben beschriebenen Komplikationen nicht zu erwarten.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ted
15 Titel:   BeitragVerfasst am: 31.07.2006, 18:22 Uhr



Anmeldung: 04. Jul 2006
Beiträge: 192
Wohnort: Merchweiler
Nur zur Info

Nachdem ich heute ein "dist-upgrade" ausgeführt habe und anschließend "ksynaptics" neu installiert habe
läuft es ohne Probleme bei mir und ist außerdem sehr gut zu konfigurieren. Sehr glücklich

_________________
gruß, ted

--
Fujitsu-Siemens Amilo A1630 / Amd Athlon 64 3700+
Kernel 2.6.18.5-slh-smp-1

NoName Desktop / Amd Athlon XP 2000+
Kernel 2.6.18.4-slh-up-1
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
leberwurst
Titel:   BeitragVerfasst am: 31.07.2006, 18:47 Uhr



Anmeldung: 01. Apr 2004
Beiträge: 17

Ich hatte auch gerade die neuesten Pakete angeschaut. Synaptics-Treiber und libsynaptics liegen in der aktuellsten Version vor. Daher sollte es jetzt auch keine Probleme mehr geben.
Ich hatte übrigens zwischenzeitlich die Treiber manuell installiert bekommen. Läuft nun auch mit meinen Alps-Touchpad wie geschmiert.
Wäre schön, wenn auch die zukünftigen libsynaptics-Anpassungen zeitnah zu den Treiber-Updates in Paketform erscheinen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.