23.10.2017, 18:44 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Lina
Titel: ACPI/DMA problems  BeitragVerfasst am: 12.07.2006, 17:46 Uhr



Anmeldung: 12. Jul 2006
Beiträge: 2

Hi,

I've just started using Linux and was recommended Knoppix as a good Distro. I've burnt a boot disc and it works brilliantly (faster than my current windows install) but for some reason if I boot from the CD with ACPI and DMA on GRUB fails to find any of my hardware (USB ports, sound card, Ethernet adapter). All is fine when I turn them off on startup but I was wondering if anyone could tell me why, and if theres a way to fix it. I'm assuming its something to do with my laptop (3 years old, Pentium 4 processor 2.4 GHz )

More importantly I wanted to check this won't matter when I do an install onto a partition of my HD, again I'm assuming I can turn it off relatively easily.

Thanks for any help in advance, I'm definitely up for learning more about the system

Lina
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: ACPI/DMA problems  BeitragVerfasst am: 12.07.2006, 17:56 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16571

Well you can try:

acpi=off

or

nodma

options to find the real problem. Both options are bad somehow, but as a P4 Cpu has no Speedstep disabling ACPI does not really matter. When you need to disalbe DMA it is worse.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Lina
Titel:   BeitragVerfasst am: 12.07.2006, 18:24 Uhr



Anmeldung: 12. Jul 2006
Beiträge: 2

Cool, it looks like APCI is the problem,

the default path in GRUB for no APCI says noacpi instead of acpi=off which is what was confusing me

when I do a system install is there a way to set this as default or will I need to edit the command line each time?

Many thanks
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 12.07.2006, 19:36 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16571

No, after hd install acpi=off is permanent.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.