01.09.2014, 23:32 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
eltho
Titel: USB-Schnittstellen werden unter LINUX nicht erkannt!  BeitragVerfasst am: 21.07.2006, 14:05 Uhr



Anmeldung: 21. Jul 2006
Beiträge: 3

Hallo,

habe auf meinem Thinkpad T30 mittlerweile so gut wie alles installieren können, nur das für mich Wichtigste funktioniert bis jetzt immer noch nicht: Meine USB-Schnittstellen......

Um das Problem weiter einzukreisen habe ich versucht unter Windows meine USB-Geräte zu erkennen. Dies funktioniert dort auch ohne Probleme und ohne Einschränkungen.

Bei Linux funktioniert leider gar nichts. Er erkennt nicht einmal irgendwas, was mit USB zu tun hat.

Habe 'lsusb' in der Konsole ausgeführt und es gibt keine Rückmeldung!!! Auch usbview führt nur zur Meldung: "Can not open the file /proc/bus/usb/devices"

Vielleicht kann mir ja einer weiterhelfen!

Vielen Dank im voraus!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel: USB-Schnittstellen werden unter LINUX nicht erkannt!  BeitragVerfasst am: 21.07.2006, 18:11 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Wenn unter dem Damaligen OS oder im Bios USB abgeschaltet ist, hilft nur das Konfig-Tool von IBM.(leider nur für WIN)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eltho
Titel: RE: USB-Schnittstellen werden unter LINUX nicht erkannt!  BeitragVerfasst am: 22.07.2006, 09:53 Uhr



Anmeldung: 21. Jul 2006
Beiträge: 3

Naja, bei WIndows läuft ja USB, also kanns am BIOS ja nicht liegen.

ALso, den obigen Post hat mein Vater gestern geschrieben, der sich mit Linux zwar besser auskennt, aber nicht wusste, wie weit ich schon kam.

Also, mit dem Befehl lspci habe ich schon herausgefunden, um welchen USB-Chip es sich handelt. Danach habe ich modconf aufgerufen, um bei ~/usb/storage/ das einzig vorhandene Modul in den Kernel zu laden. Dies half leider auch nicht weiter.

Wenn ich einen USB-Stick in den Lappi stecke und lsusb ausführe kommt auch keine Nachricht.

Daher ist alles etwas wirr.

Jann
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eltho
Titel: RE: USB-Schnittstellen werden unter LINUX nicht erkannt!  BeitragVerfasst am: 22.07.2006, 10:31 Uhr



Anmeldung: 21. Jul 2006
Beiträge: 3

Ich glaube ich habe das Problem fast gelöst!

Nach einem Kernel-Update wird endlich etwas unter 'lsview' und auch unter 'usbview' angezeigt.

Bloß wie kann ich den USB-Stick einbinden? Ein 'mount -a' bindet alles ein! Aber wo finde ich denn nun den USB-Stick?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
arlekin
Titel: Re: RE: USB-Schnittstellen werden unter LINUX nicht erkannt!  BeitragVerfasst am: 22.07.2006, 10:46 Uhr



Anmeldung: 21. Jun 2006
Beiträge: 193
Wohnort: Switzerland
eltho hat folgendes geschrieben::

Bloß wie kann ich den USB-Stick einbinden? Ein 'mount -a' bindet alles ein! Aber wo finde ich denn nun den USB-Stick?

Wenn Du im Konqueror in der Adresszeile <media:/> eingibst, solltest Du auch den Stick zu sehen bekommen (der eingesteckt, aber nicht eingebunden sein muss). Mit einem Rechtsklick und der Auswahl <Eigenschaften> bekommst Du dann auch die gewünschten Detailinformationen.

Ansonsten gibt's dafür auch ein Applet, das aber nach meiner Erfahrung eher schlecht als recht funktioniert ... sollte <Speichermedien> oder so ähnlich heissen.

Nach dem entsprechenden Befehl für die Konsole suche ich noch Winken

_________________
Arlekin's Dream Ltd. | http://www.arlekin.ch/
- Bernd Villiger et al. | http://www.penguin.ch/
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Hack-o-Master
Titel:   BeitragVerfasst am: 22.07.2006, 10:59 Uhr



Anmeldung: 05. Apr 2005
Beiträge: 499
Wohnort: Bielefeld <:-P
@arlekin

Wie wärs mit diesem Befehl für die Konsole
    pmount /dev/NAME_VOM_USBGERÄT
    z.b. pmount /dev/sda1 (oder pmount /dev/usb_stick1 wenn in eigenen udev-rules definiert)
dann müsste er unter /media eingebunden werden.
Das Gegenstück zum unmounten wäre
    pumount /dev/NAME_VOM_USBGERÄT bzw.
    pumount /media/NAME_VOM_USBGERÄT
siehe auch man pmount, man pumount

mfg. Hack-o-Master

_________________
sidux2007-02 64Bit, Kernel 2.6.23rc..(Crypto-root), X.org 7.3, KDE 3.5.7
http://bernd-das-brot.de.be | Gästebuch , certified B.O.F.H.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
arlekin
Titel:   BeitragVerfasst am: 22.07.2006, 11:36 Uhr



Anmeldung: 21. Jun 2006
Beiträge: 193
Wohnort: Switzerland
@hack-o-master:

Du verstehst mich miss. Meine Frage wäre gewesen, wie ich via Konsole herausfinden kann, an welchem Device Node ein neu angeschlossenes USB-Gerät hängt, will sagen: wie bekomme ich (via Konsole) die Information </dev/blabla>, die Du als bekannt voraussetzt. (Ist bei mir via udev rules und fstab "geregelt", wäre aber für neue / fremde Systeme interessant zu wissen ...)

_________________
Arlekin's Dream Ltd. | http://www.arlekin.ch/
- Bernd Villiger et al. | http://www.penguin.ch/
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
captagon
Titel:   BeitragVerfasst am: 22.07.2006, 11:48 Uhr



Anmeldung: 06. Feb 2005
Beiträge: 1194
Wohnort: Mecklenburg
arlekin hat folgendes geschrieben::
@hack-o-master:

Du verstehst mich miss. Meine Frage wäre gewesen, wie ich via Konsole herausfinden kann, an welchem Device Node ein neu angeschlossenes USB-Gerät hängt, will sagen: wie bekomme ich (via Konsole) die Information </dev/blabla>, die Du als bekannt voraussetzt. (Ist bei mir via udev rules und fstab "geregelt", wäre aber für neue / fremde Systeme interessant zu wissen ...)


-> hwinfo | grep /dev/sd

MfG T.

_________________
Notebook: Kanotix2006-1-rc1, Kernel 2.6.17.13-kanotix-2, ECS A531,Transmeta-Crusoe 1GHz,256MB, IceWM,
PC: Kanotix2006-1-rc1, Kernel 2.6.17.13-kanotix-2, VIA-Ezra 933MHz, 256MB, XFCE4
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
arlekin
Titel:   BeitragVerfasst am: 22.07.2006, 16:06 Uhr



Anmeldung: 21. Jun 2006
Beiträge: 193
Wohnort: Switzerland
captagon hat folgendes geschrieben::

hwinfo | grep /dev/sd

Wusste ich doch, dass das einer von euch weiss, und, dass es an sich ganz einfach ist - wenn man weiss, wie's geht Winken Danke ...!

_________________
Arlekin's Dream Ltd. | http://www.arlekin.ch/
- Bernd Villiger et al. | http://www.penguin.ch/
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Cool J.
Titel:   BeitragVerfasst am: 24.07.2006, 09:01 Uhr



Anmeldung: 13. Jul 2005
Beiträge: 73

Hi, also ich schau wenn die USB's funken, in die '/var/log/messages' da bekommt man auch die Info über das device.
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.