16.12.2017, 01:55 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
granate15
Titel: grub-install  BeitragVerfasst am: 17.10.2006, 21:50 Uhr



Anmeldung: 21. Mar 2005
Beiträge: 89

Hallo, da bin ich wieder, ich habe versucht mit der Ur-Installations CD den Grub neu zu installieren, bekomme aber immer die Fehlermeldung:

mkdir: kann Verzeichnis "/boot/boot" nicht anlegen: das Dateisystem ist nur lesbar

Habe mit Live CD gebootet,
su
mount -a,
grub-install --root-directory=/boot /dev/hda

hir noch mal meine fstab:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda4 / ext3 defaults,errors=remount,rw 0 1

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
usbdevfs /proc/bus/usb usbdevfs defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdrom1 /cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/dvd /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/cdaudio /cdaudio iso9660 defaults,ro,user,noexec,noauto 0 0
# Added by KNOPPIX
/dev/hda1 /mnt/hda1 vfat auto,users,exec,umask=000,quiet 0 0
# Added by KNOPPIX
/dev/hda2 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda5 /mnt/hda5 vfat auto,users,exec,umask=000,quiet 0 0
# Added by KNOPPIX
#/dev/hdb1 /mnt/hdb1 vfat auto,users,exec,umask=000,quiet 0 0
# Added by KNOPPIX
#/dev/hdb2 /mnt/hdb2 auto,users,exec,umask=000,quiet 0 2
#/dev/hdb2 /mnt/hdb2 auto defaults 0 2
#/dev/hdb2 /Platte_zwei auto,users defaults 0 2
#/dev/hdb2 /Daten auto, defaults 1 2
/dev/hdb2 /mnt/hdb2 auto defaults,rw,user,noexec,umask=000,quiet 0 0
/dev/hdb5 /mnt/hdb5 ext defaults,rw, 0 0
/dev/hdb6 /mnt/hdb6 ext defaults,rw, 0 0
/dev/hdb1 /mnt/hdb1 auto defaults,rw, 0 0

Leo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ockham23
Titel: RE: grub-install  BeitragVerfasst am: 17.10.2006, 22:37 Uhr



Anmeldung: 25. Mar 2005
Beiträge: 2124

Zitat:
grub-install --root-directory=/boot /dev/hda

Du versuchst anscheinend grub auf die LiveCD zu installieren, was natürlich nicht funktionieren kann. Bitte mal die Ausgabe von
Code:
sudo fdisk -l
posten, damit wir die richtige Partition finden können.

_________________
And I ain't got no worries 'cause I ain't in no hurry at all (Doobie Brothers, "Black Water").
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
granate15
Titel: RE: grub-install  BeitragVerfasst am: 18.10.2006, 13:10 Uhr



Anmeldung: 21. Mar 2005
Beiträge: 89

Hi,

root@Box:/home/leo# fdisk -l

Platte /dev/hda: 80.0 GByte, 80026361856 Byte
16 Köpfe, 63 Sektoren/Spuren, 155061 Zylinder
Einheiten = Zylinder von 1008 × 512 = 516096 Bytes

Gerät boot. Anfang Ende Blöcke Id System
/dev/hda1 * 1 32513 16386268+ c W95 FAT32 (LBA)
Partition 1 endet nicht an einer Zylindergrenze.
/dev/hda2 32514 34561 1032192 82 Linux Swap / Solaris
/dev/hda3 93458 155056 31045612+ f W95 Erw. (LBA)
/dev/hda4 34562 93457 29683584 83 Linux
/dev/hda5 93458 155056 31045581 b W95 FAT32

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/hdb: 20.0 GByte, 20020396032 Byte
255 Köpfe, 63 Sektoren/Spuren, 2434 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

Gerät boot. Anfang Ende Blöcke Id System
/dev/hdb1 383 2434 16482658+ 83 Linux
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ockham23
Titel: RE: grub-install  BeitragVerfasst am: 18.10.2006, 16:30 Uhr



Anmeldung: 25. Mar 2005
Beiträge: 2124

Du hast zwei Linux-Partitionen, hda4 und hdb1. Auf welcher Partition befindet sich die Kanotix-Installation, die du wiederherstellen möchtest? Der Befehl lautet dementsprechend
Code:
grub-install --recheck --no-floppy --root-directory=/media/hda4 /dev/hda
oder
Code:
grub-install --recheck --no-floppy --root-directory=/media/hdb1 /dev/hda

_________________
And I ain't got no worries 'cause I ain't in no hurry at all (Doobie Brothers, "Black Water").
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
devil
Titel: RE: grub-install  BeitragVerfasst am: 18.10.2006, 16:59 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
granate,
deine partitionierung ist vollkommen unbrauchbar, auf dauer wirst du damit wenig spass haben.
Partition 1 endet nicht an einer Zylindergrenze.
hda3 & hda4 sind vertauscht.
ich persönlich würde die platte vollkommen neu partitionieren.
so gibts nur ärger.

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
granate15
Titel:   BeitragVerfasst am: 22.10.2006, 16:07 Uhr



Anmeldung: 21. Mar 2005
Beiträge: 89

hi devil, Du hast natürlich recht, das Problem ist, daß ich die Partition nicht zum laufen kriege um sie zu spiegeln.
Nach dem grub-install endet der Boot Vorgang mit:

starting system log daemon: syslogdchmod: changing permissons of "/dev/xconsole": read-only file system.

Kann man mir da weiterhelfen?

Leo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
devil
Titel:   BeitragVerfasst am: 22.10.2006, 18:18 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
mach doch das backup von der Live-Cd und dann ne saubere partitionierung.

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
granate15
Titel:   BeitragVerfasst am: 23.10.2006, 09:59 Uhr



Anmeldung: 21. Mar 2005
Beiträge: 89

hat nix gebracht.

Leo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.