25.12.2014, 08:00 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
shame
Titel: Connection problems in certain situations... <SOLVED>  BeitragVerfasst am: 23.10.2006, 14:31 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
I did a clean install of RC4 on my old computer a couple of weeks ago and I had problems connecting to the internet in certain situations, particularly when doing apt-get update.
I've now done a fresh install on my new computer and I'm having the same problems.
There are only a few apt sources I can connect to, kanotix.com kanotixguide.com and ftp.de.debain.org and that's about all. I haven't found any other sources that will update properly. Others seem to be working but they stop at the "99% [Waiting for headers]" line and it stays like that forever.
Another particularly notable one is nvidia. I cannot run install-nvidia-debian.sh because it stalls when trying to download the file and if I try to download it from the nvidia site it won't connect either (only when trying to download, the rest of the site is ok).
I can download the file in suse and then copy it to kanotix and install manually but it's not ideal.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit


Zuletzt bearbeitet von shame am 27.10.2006, 01:06 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
bluewater
Titel:   BeitragVerfasst am: 23.10.2006, 14:43 Uhr
Team Member
Team Member


Anmeldung: 04. Apr 2006
Beiträge: 153
Wohnort: Melbourne, Australia
perhaps adjust your sources lists.. my local ftp act up too, here is how mine looks at he moment
(sources.list are in /etc/apt right click it "edit as root"


# Unstable
deb http://ftp.uk.debian.org/debian unstable main contrib non-free
deb-src http://ftp.uk.debian.org/debian unstable main contrib non-free

# Testing
deb http://ftp.uk.debian.org/debian testing main contrib non-free
deb-src http://ftp.uk.debian.org/debian testing main contrib non-free

# Experimental
#deb http://ftp.au.debian.org/debian experimental main contrib non-free
#deb-src http://ftp.au.debian.org/debian experimental main contrib non-free

# Kanotix
deb http://kanotix.com/files/debian sid main contrib non-free
deb-src http://kanotix.com/files/debian sid main contrib non-free

Also be sure you have the correct keys:
apt-get install kanotix-keyrings

_________________
Kanotix Easter RC4 on a dual boot P4 and a production box Desktop KDE::
Kanotix 2006 Easter RC4 on a P2 and Production Box , Desktop KDE::
Kanotix EasterRC4 on a MMX 199Mhz lappy
and a Production Box, Desktop ICEWM::
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 23.10.2006, 22:57 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
It turns out it was one particular repo that was causing the error and I was misreading the output. I don't think I'm allowed to mention which repo on this forum but I found a mirror of that source and apt-get update is working ok now.
However, the nvidia one is still strange. I can boot into suse and download from
there then boot straight into kanotix and it won't download and boot straight back into suse or sabayon and it's downloading again. It's definately related to my kanotix install only, which is a shame cos now I've got beryl working this is the only one single issue I have with kanotix on my new comp, everything else seems to be working well.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 25.10.2006, 01:42 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
I tried booting the livecd and ran the nvidia installer and it still refused to download it. How can it download from everywhere except kanotix?

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 27.10.2006, 01:05 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
I found the source of the problem. By default, the nameserver in /etc/resolv.conf is set to my router and though this works fine for most internet activity, in kanotix it causes problems with apt and a few other things.
To get around this I have to edit /etc/dhclient.conf to prepend my isp nameservers so they are added to resolv.conf before the router nameserver.
I did do this when I installed kanotix this time but I just noticed another resolv.conf in /etc/dhcpc. After replacing this with my /etc/resolv.conf all internet activity is now working, including the install-nvidia-debian script.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DeepDayze
Titel:   BeitragVerfasst am: 27.10.2006, 02:50 Uhr



Anmeldung: 08. Dez 2005
Beiträge: 299

resolv.conf should only contain the IP's for the ISP's nameservers, not the router's IP. Most routers are poor nameservers anyhow.


Zuletzt bearbeitet von DeepDayze am 27.10.2006, 14:10 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 27.10.2006, 03:34 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
The router fetches (or is supposed to) the nameservers from the isp. It works fully on other distros and for the most part on kanotix. It's the default way it was setup, I've tried changing the behaviour but from what I've read there is a bug affecting this particular router.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DeepDayze
Titel:   BeitragVerfasst am: 27.10.2006, 14:13 Uhr



Anmeldung: 08. Dez 2005
Beiträge: 299

Perhaps try looking for a firmware update for your router, shame.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 27.10.2006, 15:07 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
Firmware is upgraded to latest version.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DeepDayze
Titel:   BeitragVerfasst am: 28.10.2006, 04:40 Uhr



Anmeldung: 08. Dez 2005
Beiträge: 299

or look for a new router. What brand is your router? Linksys ones work well and they do forward the correct ISP nameservers to the machine without the bogus ones.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 28.10.2006, 05:12 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
It's a Netgear DG632. I couldn't take all the hassle with my old BT Voyager any longer so after being advised to do so in many forum threads ("any router will work on linux"), I got a router. And I'm still having problems.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
wegface
Titel:   BeitragVerfasst am: 29.10.2006, 08:35 Uhr



Anmeldung: 02. Nov 2005
Beiträge: 127

I had similar problems with my old router- and then happened again with my new one. As it turns out my isp dns servers suck, so i changed the setting in my router to use custom nameservers, and internet been fine ever since.... Thats tiscali for you tho Mit den Augen rollen

_________________
Linux user 403389 and Herbaholic Trichopath
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
shame
Titel:   BeitragVerfasst am: 29.10.2006, 21:56 Uhr



Anmeldung: 16. Apr 2006
Beiträge: 207
Wohnort: England
Well once I change dhcpclient.conf to make resolv.conf use my isp's nameservers instead of the router things were much better. Funny you should mention tiscali, my isp is still using it's own nameservers but I believe tiscali now provide the lines and stuff for them.

_________________
sidux 32 & 64 | PCLinuxOS | PC-BSD
repository of shame - compiz fusion & beryl repo for debian Sid/Lenny/Etch | 32-bit | 64-bit
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
LtWorf
Titel: DNS  BeitragVerfasst am: 09.12.2006, 12:01 Uhr



Anmeldung: 15. Jul 2006
Beiträge: 20
Wohnort: Italy
Try OpenDNS.
www.opendns.com

_________________
Perhaps today is a good day to die!
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.