20.04.2014, 18:36 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Wolfgang-HD
7 Titel: Gigaset USB Stick 108  BeitragVerfasst am: 27.06.2006, 12:22 Uhr



Anmeldung: 06. Mai 2005
Beiträge: 74

Hallo "Funker",

nachdem ich das Spiel mit der Gigaset PC Card 54 erfolgreich durchhabe, habe ich jetzt auch einen Gigaset USB Stick 108, der unter XP und Win98 funktioniert.

Die Installation des mitgelieferten Treibers (für Win2000XP) ergibt mit ndiswrapper zunächst keine Fehlermeldung, scheinbar alles ok (die Treiber für Win98 und WinME geben hier schon auf). Freilich, nach "modprob ndiswarpper" ist laut dmesg nichts geladen, keine "wireless extensions".

Mit "lspci" und "lspci -n" wollte ich mir den Chipsatz besorgen. Doch die Ausgabe liefert nicht, was entfernt nach USB & WLAN aussieht (Anzahl der Ausgabezeilen ist mit und ohne Stick identisch).

Gibt es noch einen anderen Befehl, um an den Chipsatz zu kommen?
Oder kennt jemand einen - vielleicht - richtigen treiber zum ausprobieren?

(Ups: Kann man unter WinXP/ Win98) den Chipsatz auslesen?)

Danke

_________________
Wolfgang
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Gigaset USB Stick 108  BeitragVerfasst am: 27.06.2006, 12:23 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16176

Für USB WLAN musste praktsich immer ndiswrapper nehmen. Ist vorinstalliert, aber Win Treiber musste selbst hinzufügen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ockham23
Titel:   BeitragVerfasst am: 27.06.2006, 12:33 Uhr



Anmeldung: 25. Mar 2005
Beiträge: 2099

Schau mal im Infozentrum unter USB-Geräte nach.

_________________
And I ain't got no worries 'cause I ain't in no hurry at all (Doobie Brothers, "Black Water").
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
horo
Titel:   BeitragVerfasst am: 27.06.2006, 14:29 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 700
Wohnort: Berlin
Zitat:

Mit "lspci" und "lspci -n" wollte ich mir den Chipsatz besorgen. Doch die Ausgabe liefert nicht, was entfernt nach USB & WLAN aussieht (Anzahl der Ausgabezeilen ist mit und ohne Stick identisch).

Gibt es noch einen anderen Befehl, um an den Chipsatz zu kommen?


lspci zeigt Dir PCI-Geräte.
lsusb bzw. lsusb -v sind für USB zuständig.

Ciao Martin

_________________
omnia vincit pecunia
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Wolfgang-HD
Titel: Heureka  BeitragVerfasst am: 27.06.2006, 21:59 Uhr



Anmeldung: 06. Mai 2005
Beiträge: 74

lsusb -v, das spricht für sich.
Dann ist klar, das es sich um den Atheros 5523 Chipsatz handelt (129b:160c), s.


http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation
und
http://ndiswrapper.sourceforge.net/mediawiki/index.php/List

Das ist der gleiche Treiber wie beim Gigaset USB 108 Adapter. Geladen bei Siemens direkt (da unshield + cabextrakt bei mir nicht funktionierten, entpacken unter WinXP)

Allerdings, bei meinem Kanotix (2005-4 + dist-upgrades) werden die beiden angebotenen Treiber nicht sauber geladen (Fehlermeldungen in dmesg). Der Test mit Kanotix-vdr war dagegen erfolgreich (WinXP-Version). Wireless-extensions sind da, das Ding blinkt!

Allerdings heißt es auch hier wieder die Parameter drehen (nach Spiralnebelverdrehers Hinweisen). Morgen ist auch noch ein Tag.

_________________
Wolfgang
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Wolfgang-HD
Titel: Fast perfekt  BeitragVerfasst am: 02.07.2006, 06:16 Uhr



Anmeldung: 06. Mai 2005
Beiträge: 74

Hallo,
es sieht jetzt so aus:

(Nur) unter Kanotix VDR funkt die Karte, wenn ich den o.g. XP-Treiber (nicht Win98, NT, 2000) vom Gigaset 108 Adapter nehmen; alle Versionen des Gigaset 108 Stick (den ich eigentlich habe) funktionieren nicht.

Reibungslos geht allerdings auch das nicht.
So funktioniert es, nachdem der Treiber mit ndiswrapper geladen ist:

depmod -a
modprobe ndiswrapper
iwconfig wlan0 key s:a***6
iwconfig wlan0 ap auto
iwconfig wlan0 key open
iwconfig wlan0 commit
pump -i wlan0

Netcardconfig funktioniert wie gehabt nicht.
Leider geht auch
ndiswrapper -m
nicht (die Fehlermedlungen poste ich später), damit es vom Boot an funktioniert. Auch die "übersetzung" in pre-up und Eintrag in /etc/network/interfaces führt nur zu Fehlermedlungen (wireless extensions nicht gefunden).

Habe jetzt dieses kleine Skript kurzerhand in /etc/init.d kopiert und mit KSysV in den runlevel 5 geschrieben. Wohl nicht elegant, aber praktikabel.

Wenn ich die Fehlermeldungen hier rein stelle, läßt sich vielleicht noch ein wenig Ursachensuche betreiben und den Schönheitsfehler beheben (nach Kernel Update vielleicht auch überflüssig?)

Danke für die Hilfe

_________________
Wolfgang
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Wolfgang-HD
22 Titel:   BeitragVerfasst am: 02.07.2006, 09:04 Uhr



Anmeldung: 06. Mai 2005
Beiträge: 74

Das ist die Meldung nach ndiswrapper -m:


root@sonne:/home/wolfgang# ndiswrapper -m
module configuration contains directive install pci:v00001260d00003890sv00001113sd00008301bc*sc*i* /sbin/modprobe ndiswrapper
;you should delete thatmodule configuration contains directive install pci:v00001260d00003890sv00001113sd0000EE03bc*sc*i* /sbin/modprobe ndiswrapper
;you should delete thatmodule configuration contains directive install usb:v057Cp5601d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
;you should delete thatmodule configuration contains directive install usb:v057Cp6201d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
;you should delete thatmodprobe config already contains alias directive

_________________
Wolfgang
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
H-U-P-Y
Titel:   BeitragVerfasst am: 01.11.2006, 21:48 Uhr



Anmeldung: 08. Nov 2004
Beiträge: 3
Wohnort: Rhauderfehn/ Oldenburg
hi .. hab auch den Siemens Gigaset Usb Stick 108 ...

läuft ganz gut mit ndiswrapper. leider kann ich das Modul nicht beim booten laden . is da schon wer weiter als ich ???

Achja TIPP ! :
Da ich oft zwischen verschiedenen Wlan Netzen switsche
(Uni- Eltern - Wg ) nutze ich seit neustem das Tool " WiFi-Radar ".
das Teil ist der Hit .
Es scannt nach Netzwerken in Reichweite ..merkt sich zu jeder ESSID das Profil
(ob Managed , Open , WEP,WPA,DHCP oder static ...) einmal auf connect geklickt und
bums.... ONLINE!
Wie ein Uhrwerk.... wenn ich da an die Frickeleien in der /etc/network/interfaces denke ist das
ein Meilensprung. Auch Kanos script funktioniert super, jedoch fehlt dort der Scan und die Profilspeicherung.

Daumen hoch für " WIFI-Radar " ...würd mich interessieren ob es bei euch auch klappt ! bitte um feedback

liegt im apt- repository
homepage : http://wifi-radar.systemimager.org/
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
slh
Titel:   BeitragVerfasst am: 01.11.2006, 23:46 Uhr



Anmeldung: 16. Aug 2004
Beiträge: 1905

WPA roaming funktioniert auch mit wpasupplicant allein sehr gut und zuverlässig.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.