18.04.2014, 19:12 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
cotegr
Titel: Kanotix-installer problems  BeitragVerfasst am: 22.11.2006, 19:21 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
Hello all,
A while back I used apt-get to upgrade my system and x window
messed up the upgrade. Now, after a reboot, X window will not start.
Grub works fine.
I should try to restore X window to its previous version.
So, I used the Kanotix disc, selected kanotix-installer(GUI),
and selected "recover an existing Kanotix-HD installation"
After selecting "next", it brings me to "Recovery Tools" to recover Kanotix -Bootmanager. Grub is OK so,I want to skip this part and get on to the next recovery phase.
But when I hesitantly press "begin recovery" it gives me the message
"root partion" already mounted" What gives!!
Am I going about it the right way?
Or is there another way to restore Xwindow?
Someone out there must have had this problem before.
I did some googling but no help there.

Help PLEASE.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
analogtek
Titel: RE: Kanotix-installer problems  BeitragVerfasst am: 22.11.2006, 20:30 Uhr



Anmeldung: 07. Jun 2006
Beiträge: 31
Wohnort: planet earth
I a nOOb myself. But please say you did a home back-up to cd or dvd (nicer+morespace). There is a install option to wipe HD and install. But in as the beginning back-up the back-up first. Don't use that option unless all fails.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
devil
Titel: RE: Kanotix-installer problems  BeitragVerfasst am: 22.11.2006, 20:41 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
thecrecovery will only fix a broken grub.
for your problem run the h2 script:
http://techpatterns.com/forums/about736.html
that should fix probs with x

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: Re: RE: Kanotix-installer problems  BeitragVerfasst am: 23.11.2006, 03:24 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
devil hat folgendes geschrieben::
thecrecovery will only fix a broken grub.
for your problem run the h2 script:
http://techpatterns.com/forums/about736.html
that should fix probs with x

greetz
devil


I ran the H2 script, went into init 5, xsession tried to start
displaying STARTING X11... then , no further response
for many minutes.
I guess X-window is really broken?
I have some other ideas but I'll wait to hear from you or others first.

Cheers

Gilles
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
devil
Titel: Re: RE: Kanotix-installer problems  BeitragVerfasst am: 23.11.2006, 07:30 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
after doing so, you should have a xorg.0.log in /var/log.
can you post that here?

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jiro
Titel: RE: Re: RE: Kanotix-installer problems  BeitragVerfasst am: 23.11.2006, 08:04 Uhr



Anmeldung: 27. Jun 2005
Beiträge: 258

i had a similar problem. fixed it by reinstalling the nvidia driver
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: Re: RE: Kanotix-installer problems  BeitragVerfasst am: 24.11.2006, 03:33 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
devil hat folgendes geschrieben::
after doing so, you should have a xorg.0.log in /var/log.
can you post that here?

greetz
devil


Hi Devil,

Fron your answer to my posting on Problem starting X-Window,
I read the available information,used the H2 script and BINGO
the broken X-Window problem is now FIXED.
It now boots up properly and everything seems OK so far.

This forum is wonderful for the support and H2 has done a
wonderful service to the Kanotix community with his H2 script.
I'll keep it handy for future use.
Many thanks to you too for hanging in there in solving this problem
and preventing a complete reinstall.
What a relief!!

All the best

Gilles
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.