24.10.2014, 14:27 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
cotegr
Titel: Problems starting Xwindow  BeitragVerfasst am: 21.11.2006, 17:31 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
Hello all,

This morning my power bar was accidentally powered off while moving cables.
So, when I went to restart my desktop with Kanotix AMD64 I got a series of messages indicating that Xwindow will not restart because of a fatal server error. I 'm writing this from my backup laptop and am attaching a digital
photo of the screen display of the affected desktop.
I also have a DVD copy of the Kanotix 64 package in case I need to repair/update or reinstall.
Please advise how to repair.
Many thanks



PB210002.JPG
 Beschreibung:
 Dateigröße:  468.93 KB
 Angeschaut:  2211 mal

PB210002.JPG


 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
piper
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 21.11.2006, 18:42 Uhr
Team Member
Team Member


Anmeldung: 03. Mai 2005
Beiträge: 1544
Wohnort: out there somewhere
Do you have beryl or compiz booting on start ?

It looks like AILGX is the problem to me (not an expert and might not be the problem)

Might want to check your xorg

Code:
mcedit  /etc/X11/xorg.conf


or stop beryl or compiz from starting up with KDE

This might not be your problem at all, I would also wait for others opinions Winken

_________________
h2's d-u script
h2's rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
slh
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 21.11.2006, 19:05 Uhr



Anmeldung: 16. Aug 2004
Beiträge: 1905

Take a look at /etc/X11/xorg.conf, namely at this section:
Code:
Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection
which should look pretty similar (at least the font location).
Furthermore your systems seems to be fairly up to date, but running an ancient kernel it might help to upgrade it to 2.6.18 as well; perhaps a file system check (fsck, please read the manpages - the options depend on you chosen file system) by using the live CD is recommended as well.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 21.11.2006, 21:39 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
piper hat folgendes geschrieben::
Do you have beryl or compiz booting on start ?

It looks like AILGX is the problem to me (not an expert and might not be the problem)

Might want to check your xorg

Code:
mcedit  /etc/X11/xorg.conf


or stop beryl or compiz from starting up with KDE

This might not be your problem at all, I would also wait for others opinions Winken


Hi Piper( or others),

I checked the Xorg.conf and there's no sign of beryl or compiz.
Everything looks normal.

Also,The screenshot I included above was from an another kernel which I selected in Grub.
The comment about having an ancient kernel made me realize I also had a new kernel 2.6.14
which I booted up today and when I startx the fonts error and AILGX messages are still there.
As well in the boot log, there's something about xdm not being the default display manager. and notice the bootlogd message.
I'm including a caption of this display. I did startx after this photo so it doesn't show but the X messages are identical!!

As well, about a week ago I was doing some updating and the process included Xwindow as well. There was a message that some file being installed might cause a server problem. I was not planning on rebooting
so the old settings presently in use were not causing any problems. I chose to disregard the message.
But now this has come back to haunt me.
Is there any way I can restore/revert back to the previous system configuration before the upgrade as you can do in other non-linux OS's.
Maybe I getting too far ahead of myself here, and if so, disregard this last bit. Sorry for being long winded!!



PB210002.JPG
 Beschreibung:
 Dateigröße:  459 KB
 Angeschaut:  2172 mal

PB210002.JPG




Zuletzt bearbeitet von cotegr am 21.11.2006, 21:59 Uhr, insgesamt 2 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 21.11.2006, 21:40 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

2005-04 has no support for AIGLX.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 22.11.2006, 19:45 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
slh hat folgendes geschrieben::
Take a look at /etc/X11/xorg.conf, namely at this section:
Code:
Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection
which should look pretty similar (at least the font location).
Furthermore your systems seems to be fairly up to date, but running an ancient kernel it might help to upgrade it to 2.6.18 as well; perhaps a file system check (fsck, please read the manpages - the options depend on you chosen file system) by using the live CD is recommended as well.


Hi SLH,

I checked according to your suggestion and the fonts look OK.
I'm also running a 2.6.14 kernel.
I also checked in a FAQ at x org- this is THE MOST COMMON problem.
So I followed their suggestion and additionally commented out the DRI section. I also commented out the "unscaled" font lines and still after a retry to start X I get the same message about the
DRI problem and fixed font.
I read in a posting that someone else who had upgraded had the same problem. It seems I should try to restore to my previous X window version. I've already put this into a new posting about
using the Kanotix- installer from the LiveCD and had problems.
Have a look please at the new posting.
Any ideas??
Thanks for your response.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
h2
Titel: RE: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 22.11.2006, 20:15 Uhr



Anmeldung: 12. Mar 2005
Beiträge: 1005

2.6.14 kernel is not compatible with parts of hal, you need to upgrade it, and do all the fixes for your old install.

With these old installs, it's easier to keep them up to date in most regards than to leave one component alone for too long, including the kernel.

du-fixes-h2.sh may help restore your system, it's hard to say.

_________________
Read more on dist-upgrades using du-fixes-h2.sh script.
New: rdiff-backup script
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 02:19 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
h2 hat folgendes geschrieben::
2.6.14 kernel is not compatible with parts of hal, you need to upgrade it, and do all the fixes for your old install.

With these old installs, it's easier to keep them up to date in most regards than to leave one component alone for too long, including the kernel.

du-fixes-h2.sh may help restore your system, it's hard to say.


H2,
Thanks for the suggestion. I read up the dist-upgrades postings
and discovered that I made all the same mistakes and answered the wrong questions when upgrading from the base package of 2005-04.
I've used shell scripts before a little, but for some unknown reason(maybe elementary) can't run this one.

I downloaded, while using the LiveCD, your script file to an H2 directory off /Home, used chmod to change the attributes to +x for all, Cd'd to H2, typed in "du-fixes-h2" and get "command not found"( in bash).
It may be elementary, so I searched my references and am dumfounded.
What am I doing wrong.
I'm including a screenshot.



PB220002.JPG
 Beschreibung:
 Dateigröße:  466.85 KB
 Angeschaut:  2099 mal

PB220002.JPG


 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 02:28 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
You need to start it that way: ./du-fixes-h2.sh (you must be root to execute this script and you need a running inet connection)
The "./" is needed for every program or script which you want to execute when you are inside the directory where the program is stored.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
cotegr
Titel: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 03:02 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
Crest hat folgendes geschrieben::
You need to start it that way: ./du-fixes-h2.sh (you must be root to execute this script and you need a running inet connection)
The "./" is needed for every program or script which you want to execute when you are inside the directory where the program is stored.


Thanks Crest,

It's been a while since I ran a shell script.
It WORKED, that is ,H2 started, got my OK for going to init5,
then it displayed:

INIT: Entering runlevel: 5
Executing /etc/init.d/xsession start:

Starting single X-Window session for User knoppix.
Please stand by a few seconds while the optimal configuration is being determined.

After this session terminates, the system will automatically shutdown.

Starting X11....(waiting for 10 mins with no further response)



Should I power down and reboot??
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel: RE: Re: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 03:33 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
I don't know if the script did a dist-upgrade or not. And imo the script needs to be started in runlevel 3 (no X running). Have you started the script from your running HD installation (makes probably not much sense to start it from a running LiveCD)? Even when the X system doesn't start actually you can boot to runlevel 3 (just append a '3' on the GRUB command line) and then run the script as root. With your old Kanotix version you'll have to run the script probably several times until everything is OK (no promises though, especially not for an instantly working X system)
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
cotegr
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 04:51 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
Crest hat folgendes geschrieben::
I don't know if the script did a dist-upgrade or not. And imo the script needs to be started in runlevel 3 (no X running). Have you started the script from your running HD installation (makes probably not much sense to start it from a running LiveCD)? Even when the X system doesn't start actually you can boot to runlevel 3 (just append a '3' on the GRUB command line) and then run the script as root. With your old Kanotix version you'll have to run the script probably several times until everything is OK (no promises though, especially not for an instantly working X system)

Hi Crest,

No the script did not do a dist-upgrade. In fact , when the script started,
it asks for a yes or no to go to init level 3, then the system displayed:
INIT: Entering runlevel 5.
I must pass this on to H2, the author of this script. This is not right!!

I started the script from the LiveCD as my X-Window is broken after an upgrade which messed things up. But as you say, with the X system broken, I could boot to level 3 thru GRUB and as root run the script.
I can't use the broken system to download the script but I have a standby laptop which has already downloaded it to a USB stick.
Could I run the script from this stick after I get in run level 3 and how??
It's getting late, so back to you.
I'll continue working on this in 24 hrs from now.

Cheers

Gilles
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 05:33 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
It would be good when you can store the script on your HD installation or atleast on some other partition of that machine so that you can simply copy it to your Kanotix partition after booting it. And you must be able to start an inet connection so that the script can download the needed stuff (newer kernel, newer packages for nearly everything).
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
devil
Titel: RE: Problems starting Xwindow  BeitragVerfasst am: 23.11.2006, 07:21 Uhr
Team Member
Team Member


Anmeldung: 06. Mai 2005
Beiträge: 3087
Wohnort: berlin
dont start the script from live, thats useless.
start your install, enter a '3' at the grub bootline and wget the script from there and run it from here:
http://techpatterns.com/forums/about736.html
please read the page before starting.
if anything is unclear, come back here.

greetz
devil

_________________
<<We are Xorg - resistance is futile - you will be axximilated>>

Host/Kernel/OS "devilsbox" running[2.6.19-rc1-git5-kanotix-1KANOTIX-2006-01-RC4 ]
CPU Info AMD Athlon 64 3000+ clocked at [ 803.744 MHz ]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
cotegr
Titel: : RE: Problems starting Xwindow  BeitragVerfasst am: 24.11.2006, 03:44 Uhr



Anmeldung: 27. Okt 2006
Beiträge: 22
Wohnort: Ottawa,Ontario, Canada
devil hat folgendes geschrieben::
dont start the script from live, thats useless.
start your install, enter a '3' at the grub bootline and wget the script from there and run it from here:
http://techpatterns.com/forums/about736.html
please read the page before starting.
if anything is unclear, come back here.

greetz
devil


Hi Devil,

I did just as you suggested and BINGO the H2 script has FIXED the
broken X-window problem. Everything seems OK so far but I may
run the script again just to be sure.
Thanks to your persistence with me and helping me learn new skills with Kanotix.
H2 has done a wonderful service to the Kanotix community with his H2 script. That was a lot of work but saving a lot of people a lot of grief.
It feels GOOD to have my Kanotix system back!!

Thanks to all

Cheers

Gilles
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.