22.09.2014, 22:05 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Kano
Titel:   BeitragVerfasst am: 02.02.2007, 18:43 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

Wenn du nen Debian Kernel unter Kanotix einsetzt, musste manuell

m-a prepare

nutzen, bei purem Debian oder Ubuntu wird das automatisch gemacht, bei Kanotix wars nicht nötig bislang. Evtl. bau ich den Kanotixcheck an der Stelle aus und lass es auch da aufrufen. Heute hab ich das Script spasseshalber mal mit SuSE getestet. Nach "yast2 -i gcc kernel-source" musste man nur ein paar Checks deaktivieren,dann gings. So schreibt man halt "generische" Scripte Winken Diese Anpassung hab ich aber nicht weiter optimiert, nur so zum Spass und ist auch nicht im offiziellem Script drin.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 02.02.2007, 20:10 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Zitat:
Heute hab ich das Script spasseshalber mal mit SuSE getestet. Nach "yast2 -i gcc kernel-source" musste man nur ein paar Checks deaktivieren,dann gings. So schreibt man halt "generische" Scripte Winken Diese Anpassung hab ich aber nicht weiter optimiert, nur so zum Spass und ist auch nicht im offiziellem Script drin.


schade habe mir nämlich gerade os10.2 zum testen installiert

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
AchtungHupe
Titel:   BeitragVerfasst am: 04.02.2007, 15:59 Uhr



Anmeldung: 12. Apr 2006
Beiträge: 26
Wohnort: Guntramsdorf / AT
Ich wollte jetzt auch auf Etch umstellen (wozu sonst sind sonnige Sonntagnachmittage da ;-) habe aber ein Problem mit einer Signatur

Zuerst sources.list und preferences nach Hinweisen in diesem Thread angepaßt. Beim apt-get update kamen Meldungen NO_PUBKEY zu Opera und Multimedia sourcen, die ich lösen konnte
Code:
# keyid=lange_nummer_die_kanotix_anmeckert
# gpg --keyserver subkeys.pgp.net --recv-key $keyid
# gpg --armor --export $keyid | apt-key add -


Danach erhielt ich bei apt-get update aber folgende Meldung:
Code:
W: GPG error: http://ftp.de.debian.org etch Release: Die folgenden Signaturen waren ungültig: BADSIG A70DAF536070D3A1 Debian Archive Automatic Signing Key (4.0/etch) <ftpmaster@debian.org>

Die Keys mit o.a. Methode zu importieren brachte nur eine neue Fehlermeldung. Daher Kontrolle und dann die Signatur entfernt:
Code:
# apt-key list
# apt-key del A70DAF536070D3A1

Beim apt-get update kommt jetzt diese Meldung
Code:
W: Es gibt keine öffentlichen Schlüssel für die folgenden Schlüssel-IDs:
A70DAF536070D3A1

Meine nächsten Versuche laufen beide mit der selben Meldung gleich schief
Code:
# gpg --keyserver subkeys.pgp.net --recv-key $keyid
# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys A70DAF536070D3A1
gpg: requesting key 6070D3A1 from hkp server wwwkeys.eu.pgp.net
gpg: key 6070D3A1: no valid user IDs
gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:                            ohne User-ID: 1

Und auch das bringt mich nicht weiter:
Code:
# apt-get install debian-archive-keyring
Paketlisten werden gelesen... Fertig
E: Ungültiger Eintrag in Einstellungs-Datei, kein »Package«-Header

Hier noch meine /etc/apt/sources.list und /etc/apt/preferences
Code:
# See sources.list(5) for more information, especialy
# Remember that you can only use http, ftp or file URIs
# CDROMs are managed through the apt-cdrom tool.

# Etch
deb http://ftp.de.debian.org/debian etch main contrib non-free
deb-src http://ftp.de.debian.org/debian etch main contrib non-free

# Etch-up
deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main

# Diverse
deb http://deb.opera.com/opera unstable non-free
deb http://www.**censored**.org etch main


Code:
# 2007.02.04 Umstellung auf Kanotix/Etch
Package: *
Pin: release a=testing
Pin-Priority: 500

Wo ist mein Knoten?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel:   BeitragVerfasst am: 04.02.2007, 16:12 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1411

dieser pubkey Schlammassel hat mich am nebligen Vormittag auf meiner Kanotix-etch auch genervt.
Hab nur kurz was geguckt; dann d-u trotzdem gemacht, normalerweise mach ich kein d-u bei Fehlermeldungen aber das ist echt nervig..
Jetzt nach dem d-u ist es Gott sei Dank weg Sehr glücklich

_________________
Kanotix-Hellfire on Medion Akoya
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel:   BeitragVerfasst am: 04.02.2007, 16:15 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1039
Wohnort: Schleswig-Holstein
moin

hast du mal gegoogelt? ich glaub das hier:
....Signaturen waren ungültig: BADSIG A70DAF536070D3A1 Debian Archive ...
löst sich von alleine beim dist-upgrade (bin mir aber nicht mehr sicher)

und bei der datei preference:
hast du mal probiert, die erste zeile zu entfernen oder eine leerzeile zum schluß ein zu fügen?

rolo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
AchtungHupe
Titel:   BeitragVerfasst am: 04.02.2007, 16:41 Uhr



Anmeldung: 12. Apr 2006
Beiträge: 26
Wohnort: Guntramsdorf / AT
@rolo48
Gegoogelt habe ich auch, hauptsächlich aber die Forumssuche bemüht, komme damit aber nicht weiter und deswegen die Frage hier.
Das BADSIG A70DAF.... ist ja auch weggegangen, nachdem ich den Key manuell gelöscht habe. Nur krieg ich ihn jetzt nicht mehr rein wegen
Code:
# gpg --keyserver subkeys.pgp.net --recv-key $keyid
# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys A70DAF536070D3A1
gpg: requesting key 6070D3A1 from hkp server wwwkeys.eu.pgp.net
gpg: key 6070D3A1: no valid user IDs
gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:                            ohne User-ID: 1

Traurig
Und weil der Key fehlt bricht schon das apt-get update ab.

@ beide
Ich denke ein dist-upgrade zu probieren ohne die Paketliste vorher aktualisiert zu haben ist eine wenig gute Idee. Oder?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel:   BeitragVerfasst am: 04.02.2007, 16:46 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1039
Wohnort: Schleswig-Holstein
@achtunghupe (wie kommst du auf den nick?)

mit dem key weiß ich auch nicht weiter, wenn du sonst nichts findest mit google....

muß da wohl der meister mal nen guten tip abgeben.

rolo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hschn
Titel:   BeitragVerfasst am: 04.02.2007, 16:53 Uhr



Anmeldung: 10. Mai 2006
Beiträge: 163
Wohnort: Nürnberg
Im debian-forum war da mal was:

http://debianforum.de/forum/viewtopic.p ... 57a55bec95

Gruß
hschn
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
rolo48
Titel:   BeitragVerfasst am: 04.02.2007, 17:02 Uhr



Anmeldung: 31. Aug 2004
Beiträge: 1039
Wohnort: Schleswig-Holstein
@hschn
das hätte wahrscheinlich vorher funktioniert, aber jetzt hat er drin rumgefummelt....

aber soll hupe selbst berichten

rolo
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
AchtungHupe
Titel:   BeitragVerfasst am: 04.02.2007, 22:43 Uhr



Anmeldung: 12. Apr 2006
Beiträge: 26
Wohnort: Guntramsdorf / AT
Rumgefummelt, naja. Key löschen und importieren ist ja eigentlich nichts ungewöhnliches.
Die Hinweise im Link von hschn und den darin enthaltenen weiteren Links haben das Problem leider auch nicht lösen können.
Ein genauer Blick auf den Output von apt-key list bringt
Code:
# apt-key list
/etc/apt/trusted.gpg
--------------------
pub   1024R/1DB114E0 2004-01-15 [expired: 2005-01-27]
uid                  Debian Archive Automatic Signing Key (2004) <ftpmaster@debian.org>

pub   1024D/4F368D5D 2005-01-31 [expired: 2006-01-31]
uid                  Debian Archive Automatic Signing Key (2005) <ftpmaster@debian.org>

pub   1024D/38C6029A 2002-12-20 [expired: 2004-01-24]
uid                  Debian Archive Automatic Signing Key (2003) <ftpmaster@debian.org>
Also habe ich die abgelaufenen Keys auch noch gelöscht. Beim Hinzufügen nach o.a. Methode aber immer den Fehler mit "...fehlende Eingabebeglaubigung..." erhalten.

Weiter im Google gesucht und
Code:
# rm -rf /root/.gnupg
# wget http://ftp-master.debian.org/ziyi_key_2006.asc
# apt-key add ziyi_key_2006.asc
ausgeführt. Alles ohne Problem.

Aber der Import gelingt noch immer nicht, hier ein leicht abgewandelte Variante die Mutter Google kennt:
Code:
 # gpg --keyserver wwwkeys.eu.pgp.net --recv-keys 6070D3A1 && apt-key add /root/.gnupg/pubring.gpg
gpg: requesting key 6070D3A1 from hkp server wwwkeys.eu.pgp.net
gpg: key 6070D3A1: no valid user IDs
gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:                            ohne User-ID: 1

Und ein apt-key update drückt mir wieder die alten, abgelaufenen Keys rein inkl. 2 Fehlermeldungen bei den Problemsignaturen.
Code:
# apt-key update
gpg: key 1DB114E0: public key "Debian Archive Automatic Signing Key (2004) <ftpmaster@debian.org>" imported
gpg: key 4F368D5D: public key "Debian Archive Automatic Signing Key (2005) <ftpmaster@debian.org>" imported
gpg: key B5F5BBED: public key "Debian AMD64 Archive Key <debian-amd64@lists.debian.org>" imported
gpg: key 2D230C5F: no valid user IDs
gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
gpg: key 6070D3A1: no valid user IDs
gpg: dies könnte durch fehlende Eigenbeglaubigung verursacht worden sein
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 5
gpg:                            ohne User-ID: 2
gpg:                              importiert: 3  (RSA: 1)
gpg: keine uneingeschränkt vertrauenswürdige Schlüssel gefunden

# apt-key list
/etc/apt/trusted.gpg
--------------------
pub   1024D/1F41B907 1999-10-03
uid                  Christian **censored** <**censored**@debian.org>

pub   1024D/2D230C5F 2006-01-03 [expires: 2007-02-07]
uid                  Debian Archive Automatic Signing Key (2006) <ftpmaster@debian.org>

pub   1024R/1DB114E0 2004-01-15 [expired: 2005-01-27]
uid                  Debian Archive Automatic Signing Key (2004) <ftpmaster@debian.org>

pub   1024D/4F368D5D 2005-01-31 [expired: 2006-01-31]
uid                  Debian Archive Automatic Signing Key (2005) <ftpmaster@debian.org>

Ich habe dann noch gelesen, dass die Debianpakete 1x pro Jahr neu signiert werden und dass die Fehlermeldung damit zusammen hängen könnte weil noch nicht alle signiert sind.
Die englische Version der Meldung lautet übrigens "gpg: this may be caused by missing self-signature". Darunter kann "man" sich ev. mehr vorstellen als unter "... fehlende Eingabebeglaubigung...", ich kann's jedenfalls nicht und steig bei den Googletreffern auch nicht durch.

Genug Stunden damit versch...en! Ich probiere es in ein paar Tagen nochmal, wenn es dann nicht geht bleibt Kanotix wie es ist und wenn es sein muss gibt es halt kein d-u sondern eine andere Distri :-/
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 05.02.2007, 01:35 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Man sollte vielleicht immer bedenken, das es in erster Linie ein Schönheitsfehler ist. Die Pakete werden deshalb genauso einwandfrei installiert wie mit funktionierendem Key. Und das der Debian-Server schon mal von bösen Mächten gekapert wurde und einem dann irgendwelcher Müll als Upgrade untergejubelt wurde, wäre mir neu.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
AchtungHupe
Titel:   BeitragVerfasst am: 05.02.2007, 06:42 Uhr



Anmeldung: 12. Apr 2006
Beiträge: 26
Wohnort: Guntramsdorf / AT
Crest hat folgendes geschrieben::
Man sollte vielleicht immer bedenken, das es in erster Linie ein Schönheitsfehler ist. Die Pakete werden deshalb genauso einwandfrei installiert wie mit funktionierendem Key.
Jetzt bitte nochmal langsam, für mich ;-)

Ich wollte Kanotix auf Etchbasis stellen, daher sources.list und preferences angepaßt, Einstellungen s. weiter oben
apt-get update soll/muss die aktuelle Paketliste holen, bringt aber irgendwann den Fehler wegen dem Key.
---> Habe ich die aktuelle Liste trotzdem schon am System?
---> Kann ich prüfen ob eine aktuelle Etchliste vorhanden ist?

Ich möchte nämlich nicht, dass diese Installation wieder mal so verreckt wie bisher alle Debian basierten Installationen in den letzten Jahren - System nach irgendeinem d-u komplett zerschossen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel:   BeitragVerfasst am: 05.02.2007, 08:38 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1411

Allein wegen der key-Geschichte würde ich kein funktionierendes Kanotix wieder runterholen.
Ich würde das davon abhängig machen ob Kanotix ansonsten sauber läuft. Stimme Crest da voll zu.
Meist muss ich auch 3-4 Versuche statten bis ich das weg hab.

Wenn du apt-get update machst müsstest du sehen was neues bei D-U kommt. In synaptic sehr übersichtlich zu sehen. (d-u aber nicht mit synaptic sondern wie oben beschrieben machen).

_________________
Kanotix-Hellfire on Medion Akoya
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
harry4bo
Titel:   BeitragVerfasst am: 12.02.2007, 11:54 Uhr



Anmeldung: 08. Jun 2004
Beiträge: 179
Wohnort: Nürnberg
Mahlzeit,

das verregnete Wochenende habe ich nun auch dazu genutzt mein Kanotix 2005-01 auf Etch upzudaten. Nachdem ein HD-Install von 2006-01-RC4 bei meiner D-Link 510 auf Widerstände stößt bzgl. WLAN (Auf Deutsch es läuft ums Verrecken nicht, im Live Modus aber schon, grübel?) war ich gezwungen diesen Umweg zu gehen. Auch ein Update mit Script von 2005-01 auf RC4 führte letzendlich WLAN-mäßig zu keinem Erfolg. Liegt wahrscheinlich am SMP Kernel. Aber warum es auf der Live CD läuft und nach HD Install nicht mehr ist mir ein Rätsel. Die alte 2005-01 im Live Modus mit modifiziertem .inf File und ndiswrapper über WLAN ans Net gebracht läuft bei reboot nach HD-install beim rebooten sofort wieder über WLAN ans Net wenn man vorher die Essid, Kanal etc. in /etc/network/interfaces einfügt.
Also kurzerhand wie beschrieben die repositories auf etch umgestellt und in gewohnter Weise d-u gemacht. War allerdings nicht ganz trivial mit dem Xorg server, obwohl ich vorher schon mal /etc/X11/bin geleert hatte.
Aber mit ein paar konsequenten --force-overwrite und etlichen apt-get -f install hat es letztendlich doch hingehauen. Wichtig beim Umstellen auf den xorg server war vor allem das neue Setzen der font-links und auch das Durchführen von Kanos Fix-org7 script wie weiter oben schon mal beschrieben.
Wenn ich jetzt das Wochenende so Revue passieren lasse habe ich wieder ein Menge gelernt, ein wunderbares Kanotix-etch und fühle mich zu Dank verpflichtet allen die in diesem Forum etwas beigetragen haben und vor allem Kano ohne dessen Kanotix ich wahrscheinlich nie, oder jedenfalls nicht so schnell und einfach, ein lauffähiges OS auf debian Basis hätte installieren können. Auf dem Rechner meiner Frau läuft noch ein Bughunter und solange sie nicht meckert bleibt der auch Smilie.

Schlußendlich möchte ich damit zum Ausdruck bringen, daß mich Kanotix zu Linux und Spaß an der Sache gebracht hat. Danke.
Wie immer es auch weitergeht und totgesagte leben bekanntlich länger, ein Kanotix wird mich immer im Grub Boot Menü begrüßen.

harry4bo

_________________
Man sollte beim Wandern immer eine kleine Flasche Whiskey dabei haben wegen der Schlangen. Und man sollte immer eine kleine Schlange dabeihaben.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Ludwig
Titel:   BeitragVerfasst am: 06.12.2008, 17:37 Uhr



Anmeldung: 06. Dez 2008
Beiträge: 3
Wohnort: Offenburg Baden-W.
Hallo,

herzlichen Dank erstmal für die Anleitungen hier, womit ich ( Linuxneuling ) die nun alte Version updaten und auf etch umstellen konnte. Läuft alles wunderbar und stabil bis auf einige Pakete , welche nicht gefunden werden.

Host/Kernel/OS "KanotixBox" running Linux 2.6.18-kanotix-1 i686 [ KANOTIX 2006-01 ]
CPU Info AMD Athlon 64 3000+ 512 KB cache flags( nx lm ) clocked at [ 1000.000 MHz ]
Videocard Silicon Integrated Systems [SiS] 661/741/760/761 PCI/AGP VGA Display Adapter X.Org 7.1.1 [ 1024x768 @71hz ]
Network cards Silicon Integrated Systems [SiS] 190 Gigabit Ethernet Adapter, at port: d000
Processes 105 | Uptime 3min | Memory 271.367/946.566MB | HDD WDC WD2000JB-00DUA3,IC35L020AVER07-0,WDC WD200BB-75CAA0 Size 240GB (37%used) | Client Shell wrapper | Infobash v2.50rc21

Eigentlich kann man auch heute noch ganz gut damit arbeiten, jedoch wären die neuen Distris natürlich sehr interessant, bekomme aber ab Thorhammer keine Stabilität mehr. Irgendwann fangen dann geöffnete Anwendungen an, schnell senkrecht zu flackern und nichts geht mehr.

Falls Jemand hierzu eine Lösung weiß, wäre das sehr hilfreich

Grüße
Ludwig
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 06.12.2008, 18:20 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

Nun das grösste Problem ist deine Grafikkarte, besorg dir halt für ein Paar Euro mal was besseres.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Ludwig
Titel:   BeitragVerfasst am: 07.12.2008, 21:45 Uhr



Anmeldung: 06. Dez 2008
Beiträge: 3
Wohnort: Offenburg Baden-W.
Danke für den Tip,
werde das bei Gelegenheit machen, muß aber noch sehen ob das Netzteil reicht.
Habe nun RC6 auf eine neue Partition installiert, geupdatet,

Host/Kernel/OS "KanotixBox" running Linux 2.6.28-2-generic i686 [ KANOTIX 2007 Thorhammer ]
CPU Info AMD Athlon 64 3000+ 512 KB cache flags( sse sse2 nx lm pni svm ) clocked at [ 1800.000 MHz ]
Videocard Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter X.Org 7.1.1 [ 1024x768 @71hz ]
Network cards Silicon Integrated Systems [SiS] 190 Gigabit Ethernet Adapter, at port: d000
Processes 107 | Uptime 2:56 | Memory 175.1/941.2MB | HDD ATA IC35L020AVER07-0,ATA WDC WD2000JB-00D,ATA WDC WD200BB-75CA Size 240GB (38%used) | Client Shell wrapper | Infobash v2.67.1


anstatt sis den Vesa-Treiber eingestellt und habe mit dem bisher nicht wieder die Probleme bekommen.Werde aber trotzdem die 2.6.18-kanotix-1 Installation behalten

Juhu, es geht!!!
Ludwig
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.