29.08.2014, 07:36 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
tuxedo
Titel: Startup not booting into graphical (kde) interface  BeitragVerfasst am: 30.12.2006, 09:19 Uhr



Anmeldung: 07. Mai 2005
Beiträge: 153

When booting up a newly installed Kanotix 2006-01-RC4 system with an up-to-minute dist-upgrade, the graphical interface "sometimes" does not fire up, but instead a non-graphical log-in prompt appears, at which point I can naturally log in and continue a session in a non-graphical mode.

How can I try to make KDE or the graphical log-in screen start from that point? In other words, after login, what is or are the commands to start an x-session?

The tail end of my start-up screenful appears as follows: ...
Zitat:

Setting up X server socket directory /tmp/.X11-unix
Setting up ICE socket directory /tmp/.ICE-unix

Debian GNU/Linux 4.0 kanotix tty1

kanotix login:_

In case I don't log in at this point and after a couple of minutes, the system enters runlevel 5 and attempts to start various services, such as printing, battery stuff, fan processor etc., with the last being the following:
Zitat:
... Starting K Display Manager: xdm.
Not starting X display manager (xdm): it is not the default dissplay manager.

Debian GNU/Linux 4.0 kanotix tty2

kanotix login:_
My system is set to automatically log in to a user account and perhaps this is partly the cause of the kde startup failure, although this has never been a problem with my previous Kanotix installs.

As I mentioned, the start-up mysteriously fails only sometimes, as in most instances the graphical interface fires up as normal.

Also, in KDE I cannot click "K" => "End current session" and expect a GUI log-in screen. There will either be a non-graphical login prompt or just a black screen with a blinking cursor in the top-left corner, which I can't type anything into. Only rebooting by hitting the Strg+Alt+Entf keys are possible here.

Does anyone have any idea what could be the cause of this occasional kdm/kde login failure?

Maybe some services did not exit cleanly in a previous session, however, I usually always switch the system off as it should. No hitting reset etc.

Could perhaps reinstalling the log-in manager parts (xdm or kdm?) work?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
vilde
Titel:   BeitragVerfasst am: 30.12.2006, 15:14 Uhr



Anmeldung: 02. Apr 2006
Beiträge: 121

Try this, I got this advice and it worked for me

Change CHVT_TTY value in file /etc/default/splashy to auto, 7 or to the right session for your PC.

So, this

Code:
# Splashy will switch to this TTY after finishing at boot
# note that if X is running, tty7 will be used automatically
CHVT_TTY=1


should be:


Code:
# Splashy will switch to this TTY after finishing at boot
# note that if X is running, tty7 will be used automatically
CHVT_TTY=7
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Dud
Titel:   BeitragVerfasst am: 30.12.2006, 15:46 Uhr



Anmeldung: 06. Sep 2006
Beiträge: 1

I was having the same problem. This fixed it.
Thanks a bunch. Auf den Arm nehmen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
tuxedo
Titel:   BeitragVerfasst am: 30.12.2006, 15:59 Uhr



Anmeldung: 07. Mai 2005
Beiträge: 153

Thanks for that insider tip! Instead I set this line to: ...

ENABLE=0

... which desplashed it completely! Result: No boot image or log-in/kdm failure after having tested rebooting for a tenth time. It should be the same as setting CHVT_TTY=7 minus the image (in my case a glowy pinguin). It makes me wonder what useful purpose Splashy serves, other than displaying the image and a progress bar during start-up and shut-down?

When in KDE on 2006-01-RC4 the following does not work from me either:
"K" => "Switch User" => "Start New Session" (as root)
OR
"K" => "Log Out..." to reach the (kdm or xdm?) log-in manager again.

Although the 2006-01-RC4+dist-upgrade must be as new as new can be I think I might revert to 2005-04, which in any case is probably more feature packed than most other Linux distros.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
satpute_sagar
Titel: How to edit the file "splashy"?  BeitragVerfasst am: 09.12.2010, 05:17 Uhr



Anmeldung: 09. Dez 2010
Beiträge: 2

I am also having the same problem,
I am new to this so dont know how to edit the file "/etc/default/splashy"
Could you please tell how to edit the file "/etc/default/splashy" ?


vilde hat folgendes geschrieben::
Try this, I got this advice and it worked for me

Change CHVT_TTY value in file /etc/default/splashy to auto, 7 or to the right session for your PC.

So, this

Code:
# Splashy will switch to this TTY after finishing at boot
# note that if X is running, tty7 will be used automatically
CHVT_TTY=1


should be:


Code:
# Splashy will switch to this TTY after finishing at boot
# note that if X is running, tty7 will be used automatically
CHVT_TTY=7
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
thebluesman
Titel: How to edit the file "splashy"?  BeitragVerfasst am: 09.12.2010, 06:43 Uhr



Anmeldung: 06. Okt 2007
Beiträge: 355
Wohnort: Leipzig
Boot from a Live-CD

<ALT>+<F2>
type "kdesu konqueror"

copy+paste "/etc/default/" into the URL
then you`ll find the file "splashy"
open it with "kwrite" (right-click - open with)
now you can edit it.
After editing: File->save

But a better advice:
Download a newer Kanotix-version...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
satpute_sagar
Titel: RE: How to edit the file "splashy"?  BeitragVerfasst am: 10.12.2010, 05:10 Uhr



Anmeldung: 09. Dez 2010
Beiträge: 2

I have installed the latest Kanotix Excalibur, but when I boot, it does not boot into a Graphical Interface, but instead a non-graphical log-in prompt appears, at which point I can naturally log in and continue a session in a non-graphical mode.

How can I try to make KDE or the graphical log-in screen start from that point? In other words, after login, what is or are the commands to start an x-session?

The tail end of my start-up screenful appears as follows: ...
Zitat:


Setting up X server socket directory /tmp/.X11-unix
Setting up ICE socket directory /tmp/.ICE-unix

Debian GNU/Linux 4.0 kanotix tty1

kanotix login:_



So I wanted to try this:
Zitat:

Change CHVT_TTY value in file /etc/default/splashy to auto, 7 or to the right session for your PC.


For this I have to edit the file "etc/default/splashy" from the installation on my hard-disk, but when I try to do it after booting from a Live-CD, it shows "No Write Access"

So is it possible to start the Graphical Interface from the non-graphical one?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: How to edit the file "splashy"?  BeitragVerfasst am: 10.12.2010, 11:18 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16236

Best visit IRC.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.