18.04.2014, 22:48 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
giaur
Titel: Writing to ntfs  BeitragVerfasst am: 20.03.2007, 21:30 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Hello,

How to enable ntfs writing? I have Ntfs-3g and libntfs9 installed, but I can't write to ntfs partition, even if I set rw mode in my fstab file.

While botting system, always this messages appears:

Zitat:
NTFS-fs warning (device hda1): load_system_files(): Unsupported volume flags 0x4000 encountered.
NTFS-fs warning (device hda1): load_system_files(): Volume has unsupported flags set. Will not be able to remount read-write. Run chkdsk and mount in Windows.


... and writing to ntfs is disabled. What can I do?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Writing to ntfs  BeitragVerfasst am: 20.03.2007, 21:35 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

I hope you can read: run chkdsk first!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel: RE: Writing to ntfs  BeitragVerfasst am: 20.03.2007, 22:53 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Be sure to shutdown Windows the correct way. If you had a crash (bsod) while running Windows then you must first reboot. This forces chkdsk to run and solve possible problems with the ntfs partition. r/w access to ntfs partitions under Linux is only possible when the clean flag for the partition is found (set by Windows when shutting down).
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 21.03.2007, 06:31 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Nope... Real problem is, that Windows is closed correctly, but this message still appears... chkdsk doesn't report any errors, so I assume that my ntfs partitions are clear.

I have 3 NTFS partitions on 2 hard discs, but writing doesn't work at all and messages about unsuppoerted flags always appears.

Note, that writing to the same partitions from Knoppix live CD works fine, but I don't want to install knoppix now, I want to enable this feature in Kanotix I have installed.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 21.03.2007, 15:07 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Well, I have never used/tried the r/w feature of the driver since I don't really need it. Maybe it makes also a difference if you are using Kernel 2.6.18 or Kano's test Kernel 2.6.20. In fact I have never played with any ntfs-3g related settings.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 21.03.2007, 17:33 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

With the 2.6.20 kernel you get ntfs-3g updates to 1.3x.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 21.03.2007, 18:36 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Hmm newest (experimental) ntfs-3g version available now is 1:0.0.0+20070207 and I have installed 1:0.0.0+20061031-9.

Should I install experimental version ? I don't want to recompile my kernel.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 21.03.2007, 20:18 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

My kernel update packs haven even newer code.

http://kanotix.com/files/kernel/kernel- ... ide.tar.gz

Currently: 1.320 RC.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 23.03.2007, 20:39 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

No changes. First, I installed ntfs-3g and libntfs-3g from updates directory - but this didn't help.
and then I decided to run install.sh and update kernel, but it doesn't work, error messages:

Code:
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  initramfs-tools: Depends: klibc-utils (>= 1.4.19-2) but it is not going to be installed
                   Depends: busybox (>= 1:1.01-3) but it is not going to be installed or
                            busybox-cvs-static (>= 20040623-1) but it is not installable
  libntfs-3g-dev: Depends: libntfs-3g0 (= 1:0.0.0+20061031-9) but 1:1.320~rc-0 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Error: update-initramfs not found!


But I dont think, that kernel update to 2.6.20 is necessary - Knoppix has 2.6.19 and writing to ntfs works great.

Any ideas?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.03.2007, 22:44 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

You think too much, for best use of ntfs-3g you need the fuse kernel module from 2.6.20!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 24.03.2007, 21:41 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Ok, I 've installed your patches, but still writing to ntfs is unavailable. I changed "ro" to "rw" in /etc/fstab.

And another question: how to enable verbose mode now? Pressing Esc causes stop animation only, but verbose mode doesn't work (bug?)

I don't need splash screen, I prefer verbose mode

[edit]
Something is really wrong, I can't switch to text mode to reinstall nVidia drivers!

init 3 causes black screen and system not response, console login in boot menu - colored screen. It seems that text mode doesn't work at all, but X works fine...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.03.2007, 22:39 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

You need "ntfs-3g defaults" instead of "nfts <some options>" .
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 24.03.2007, 23:07 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Yes, now it works as should, but if ntfs partition isn't clean, I can't acces it in linux at all, how to change this? I mean if I can read only access in this case.

And, what about my another questions?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.03.2007, 23:50 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

For ntfs

a) use force instead of default
b) use chkdsk within win

For nvidia:

Simply within X:

su
update-scripts-kanotix.sh
DISPLAY= nohup install-nvidia-debian.sh
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 25.03.2007, 20:29 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Nvidia works now, but something is really wrong - I can't run system without X.

Both console login option in login menu and init 3 in console doesn't work - colored or black screen is displayed and system is halted.

Any sugeestions?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jackiebrown
Titel:   BeitragVerfasst am: 25.03.2007, 21:11 Uhr



Anmeldung: 13. Mai 2005
Beiträge: 732
Wohnort: Texas
I used to have that problem with spashy. Try consol 2

_________________
Always acknowledge a fault. This will throw those in authority off their guard and give you an opportunity to commit more.
Mark Twain
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 26.03.2007, 06:30 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Zitat:
Try consol 2


What do you mean?

Another problem occurs after kernel upgrading. I can't turn off my computer - it's always restarts, even if I use "Turn off computer" from KDE menu, and I can't see what's wrong because verbose mode doesn't work.
I'm going to check logs and post it here, but can you tell me if anyone has similar problem after update?

[edit]
One more thing about NTFS - it should be easy question. After ntfs-3g and kernel update, I can't access files and directiories containing non-ascii (national) characters - for example names with ą, ę, ć, ś, ź are invisible. How to fix this?

My /etc/fstab:

Zitat:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hdc1
UUID=12e3ace6-647d-45a1-82fd-8e76e76bdf39 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1
/dev/disk/by-uuid/60B80C31B80C086C /media/hda1 ntfs-3g defaults,umask=000,nls=utf8 0 0
# /dev/hda5
/dev/disk/by-uuid/38B4EA33B4E9F2F4 /media/hda5 ntfs-3g defaults,umask=000,nls=utf8 0 0
# /dev/hda6
UUID=d56300f3-f894-4d25-9dad-4e07df7ee910 /media/hda6 ext3 defaults 0 0
# /dev/hdb1
/dev/disk/by-uuid/C090244B90244A6C /media/hdb1 ntfs-3g defaults,umask=000,nls=utf8 0 0
# /dev/hda7
UUID=6af4910a-ba16-4a9d-addd-ccd0f1639c43 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 27.03.2007, 06:39 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Just for the records: I have changed to ntfs-3g now and enabled write access. I have encountered no errors when copying to and deleting a file on a ntfs (Win2000) partition.

My ntfs partitions reads like this in fstab (one of two ntfs partitions):
# /dev/sdb5
/dev/disk/by-uuid/FA0804120803CD17 /media/hdb5 ntfs-3g rw,umask=000 0 0
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 27.03.2007, 12:13 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Yes, I have no errors too. But, as I wrote - I have no access to directories and files with no ascii national characters in names.

What's the reason of this? No NLS support in kernel? What can I do?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 27.03.2007, 13:44 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

nls is wrong option, i told you to remove all. That works for me, if not use something like

locale=de_DE.utf8

where this should be the same as the output of

locale -a
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 27.03.2007, 19:18 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Both doesn't work - still can't see folders/files with national letters.

locale - a output:

Zitat:

C
da_DK
da_DK.iso88591
da_DK.iso885915
da_DK.utf8
danish
dansk
de_AT
de_AT@euro
de_AT.iso88591
de_AT.iso885915@euro
de_AT.utf8
de_AT.utf8@euro
de_BE
de_BE@euro
de_BE.iso88591
de_BE.iso885915@euro
de_BE.utf8
de_BE.utf8@euro
de_CH
de_CH.iso88591
de_CH.utf8
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
de_DE.utf8@euro
de_LU
de_LU@euro
de_LU.iso88591
de_LU.iso885915@euro
de_LU.utf8
de_LU.utf8@euro
deutsch
dutch
el_GR
el_GR.iso88597
el_GR.utf8
en_AU
en_AU.iso88591
en_AU.utf8
en_BW
en_BW.iso88591
en_BW.utf8
en_CA
en_CA.iso88591
en_CA.utf8
en_DK
en_DK.iso88591
en_DK.utf8
en_GB
en_GB.iso88591
en_GB.iso885915
en_GB.utf8
en_HK
en_HK.iso88591
en_HK.utf8
en_IE
en_IE@euro
en_IE.iso88591
en_IE.iso885915@euro
en_IE.utf8
en_IE.utf8@euro
en_IN
en_IN.utf8
en_NZ
en_NZ.iso88591
en_NZ.utf8
en_PH
en_PH.iso88591
en_PH.utf8
en_SG
en_SG.iso88591
en_SG.utf8
en_US
en_US.iso88591
en_US.iso885915
en_US.utf8
en_ZA
en_ZA.iso88591
en_ZA.utf8
en_ZW
en_ZW.iso88591
en_ZW.utf8
fran�is
fr_BE
fr_BE@euro
fr_BE.iso88591
fr_BE.iso885915@euro
fr_BE.utf8
fr_BE.utf8@euro
fr_CA
fr_CA.iso88591
fr_CA.utf8
fr_CH
fr_CH.iso88591
fr_CH.utf8
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
fr_FR.utf8@euro
fr_LU
fr_LU@euro
fr_LU.iso88591
fr_LU.iso885915@euro
fr_LU.utf8
fr_LU.utf8@euro
german
greek
italian
it_CH
it_CH.iso88591
it_CH.utf8
it_IT
it_IT@euro
it_IT.iso88591
it_IT.iso885915@euro
it_IT.utf8
it_IT.utf8@euro
nl_BE
nl_BE@euro
nl_BE.iso88591
nl_BE.iso885915@euro
nl_BE.utf8
nl_BE.utf8@euro
nl_NL
nl_NL@euro
nl_NL.iso88591
nl_NL.iso885915@euro
nl_NL.utf8
nl_NL.utf8@euro
pl_PL
pl_PL.iso88592
pl_PL.utf8
polish
POSIX
sk_SK
sk_SK.iso88592
sk_SK.utf8
slovak


I want polish nls, so I tried locale=pl_PL.utf8 but desn't work. Without nls doesn't work too. What else can I try?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 27.03.2007, 19:29 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Show me your fstab and output of mount. Also echo $LANG .
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 27.03.2007, 19:54 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

fstab entry for ntfs:
Zitat:
/dev/disk/by-uuid/60B80C31B80C086C /media/hda1 ntfs-3g rw,umask=000,nls=pl_PL.utf8 0 0


$LANG : en_US.UTF-8, this can't be? I don't care about locale, polish version of KDE is enough. And I had all folders visible before updating system

Mount output: How to check this? I can do nothing about mount/unmount partitions - already mounted and when try unmount, unmounting message like: "Can't unmount, not mounted by HAL"
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 27.03.2007, 20:18 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Told you to use something different! Can't you read?

/dev/disk/by-uuid/60B80C31B80C086C /media/hda1 ntfs-3g defaults 0 0

OR

/dev/disk/by-uuid/60B80C31B80C086C /media/hda1 ntfs-3g locale=en_US.utf8 0 0
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
giaur
Titel:   BeitragVerfasst am: 27.03.2007, 20:47 Uhr



Anmeldung: 16. Mar 2007
Beiträge: 25

Second command works fine.

So, now I'm waiting for responses to other problems I posted... If you have any ideas or tips, you are welcome (or maybe I should create another thread for this)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.