22.12.2014, 17:52 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
bertl2
Titel: Umlautproblem mit ext. Festplatte  BeitragVerfasst am: 29.08.2008, 09:51 Uhr



Anmeldung: 29. Aug 2008
Beiträge: 16

Hallo, bin neu hier.

Ich tausche Daten z.B. mit Freunden oder sichere Daten hauptsächlich über USB-Festplatten, die sind häufig mit NTFS-Dateisystem formatiert. Machen vermutlich auch viele Leute so.
Weil das Microsoftformat halt doch am meisten verbreitet ist, wäre eine
Problemlösung vieleicht für viele interessant, die gerne Kanotix verwenden
wollen.

Das Problem:
Dateien mit Umlaut im Dateinamen werden gar nicht angezeigt und lassen sich auch nicht anlegen.
-das Problem tritt anscheinend nur bei Partitionen auf, die mit NTFS formatiert sind
-das Problem tritt bei internen Festplatten nicht auf
-wird die externe USB-Platte beim Livesystem vor dem Hochfahren angesteckt,tritt
kein Problem auf.
-habe Kanotix RC7 auf Festplatte installiert, da ist das Problem immer da.

Habe verschiedene Betriebsysteme getestet und festgestellt, dass das Problem beim
aktuellen Ubuntu nicht auftritt, vieleicht gibts für Kanotix auch eine Problemlösung.

Ich war nicht faul und habe eine kleine Testreihe mit drei aktuellen Livesystemen
durchgeführt, damit es auch für andere Interessierte Leute nachvollziehbar ist.

verwendete Livesysteme:

Kanotix RC7
Ubuntu Hardy Heron 8.04
Kubuntu Hardy Heron 8.04

einfacher Test:

Kanotix Livesystem starten, externe USB-Festplatte
mit NTFS-Dateisystem nachträglich anstecken(500MByte-Partition reicht zum Experiment), einbinden, öffnen, Rechtsklick
"Ordner anlegen", Ordnernahme "Ü,Ö,Ä" eingeben, Eingabetaste führt zur
Fehlermeldung (Ordner kann nicht angelegt werden).
Dateien mit Umlaut im Namen werden nicht angezeigt.
Mit Dateinahmen ohne Umlaut habe ich keine Probleme.
Bei NTFS-Dateisystem auf der im Computer fest eingebauten Festplatte tritt
keinerlei Problem auf, nur bei der angesteckten USB-Festplatte.
Wird die Festplatte vor dem Hochfahren angesteckt, tritt kein Problem auf.
Ich war nicht faul und habe die Festplatten über USB-Adapter vertauscht,
also USB-Platte in den Computer eingebaut und die eingebaute Platte an den
USB-Adapter.
Ergebniss: USB-NTFS mit Umlautproblem, eingebaute Platte (die ja vor dem Tausch die USB-Platte war) problemlos, es liegt also nicht an der Platte.
Macht auch keinen Unteschied, ob NTFS mit Windows oder Gparted formatiert
wurde, habe es probiert.


gleicher Test mit Ubuntu:

es tritt kein Problem mit Umlauten auf, weshalb ich mir denke, dass es eine
Lösung geben muß.

Bei dem KubuntuLivesystem ist das Umlautproblem immer da, egal ob die Platte
beim Hochfahren angesteckt war oder nicht.

Habe mir die Mühe gemacht, und für jedes der o.g. drei Livesysteme zwei
Dateien herauszukopieren (fstab,mtab).
USB-Platte mit NTFS-Dateisystem war dabei angesteckt, eine Partition mit NTFS auf interner Platte vorhanden.
Vieleicht kann jemand etwas damit anfangen.

Kanotix ohne Umlautproblem (USB vor dem Hochfahren angesteckt):

fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
# Added by KANOTIX
/dev/sda2 /media/sda2 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0
# Added by KANOTIX
/dev/sda5 /media/sda5 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda6 /media/sda6 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda7 /media/sda7 reiserfs noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda8 /media/sda8 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda9 none swap sw 0 0
# Added by KANOTIX
/dev/sda10 /media/sda10 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0
# Added by KANOTIX
/dev/sdb1 /media/sdb1 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0
# Added by KANOTIX
/dev/sdb2 /media/sdb2 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0
# Added by KANOTIX
/dev/sdb3 /media/sdb3 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0

mtab
/dev/root / ext2 rw 0 0
/ramdisk /ramdisk tmpfs rw,size=385576k,mode=755 0 0
/ramdisk/home /home none rw,bind 0 0
/dev/sr0 /cdrom iso9660 ro 0 0
/dev/loop0 /KANOTIX squashfs ro 0 0
/dev/pts /dev/pts devpts rw,mode=0622 0 0
/proc/bus/usb /proc/bus/usb usbfs rw,devmode=0666 0 0
/dev/sdb2 /media/sdb2 fuseblk rw,nosuid,nodev,allow_other,blksize=4096,user=kanotix 0 0




Kanotix mit Umlautproblem (USB erst nach dem Hochfahren angesteckt):

fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
# Added by KANOTIX
/dev/sda2 /media/sda2 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0
# Added by KANOTIX
/dev/sda5 /media/sda5 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda6 /media/sda6 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda7 /media/sda7 reiserfs noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda8 /media/sda8 ext3 noauto,users,exec 0 0
# Added by KANOTIX
/dev/sda9 none swap sw 0 0
# Added by KANOTIX
/dev/sda10 /media/sda10 ntfs-3g noauto,users,exec,locale=de_DE.UTF-8 0 0

mtab
/dev/root / ext2 rw 0 0
/ramdisk /ramdisk tmpfs rw,size=385576k,mode=755 0 0
/ramdisk/home /home none rw,bind 0 0
/dev/sr0 /cdrom iso9660 ro 0 0
/dev/loop0 /KANOTIX squashfs ro 0 0
/dev/pts /dev/pts devpts rw,mode=0622 0 0
/proc/bus/usb /proc/bus/usb usbfs rw,devmode=0666 0 0
/dev/sdb2 /media/PACKARD\0401 fuseblk rw,nosuid,nodev,sync,allow_other,blksize=4096 0 0

sdb2 ist eine USB-NTFS Partition,sda10 ist eine NTFS-Partition bei der internen Platte.

anders sehen die entsprechenden Dateien unter sonst gleichen
Bedingungen bei den Ubuntus aus:


Ubuntu ohne Umlautproblem:

fstab
unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda9 swap swap defaults 0 0

mtab
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /lib/modules/2.6.24-16-generic/volatile tmpfs rw,mode=0755 0 0
tmpfs /lib/modules/2.6.24-16-generic/volatile tmpfs rw,mode=0755 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev 0 0
gvfs-fuse-daemon /home/ubuntu/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=ubuntu 0 0
/dev/sdb3 /media/System fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sdb2 /media/PACKARD\0401 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sdb1 /media/System_ fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sda10 /media/disk fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0



Kubuntu mit Umlautproblem:

fstab
unionfs / unionfs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda9 swap swap defaults 0 0


mtab
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
tmpfs /lib/modules/2.6.24-16-generic/volatile tmpfs rw,mode=0755 0 0
tmpfs /lib/modules/2.6.24-16-generic/volatile tmpfs rw,mode=0755 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev 0 0
/dev/sdb2 /media/PACKARD\0401 fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0
/dev/sda10 /media/disk fuseblk rw,nosuid,nodev,noatime,allow_other,blksize=4096 0 0

Grüße aus Burghausen an den Salzach
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Umlautproblem mit ext. Festplatte  BeitragVerfasst am: 29.08.2008, 14:49 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16313

Als Hack könntest du statt einem Symlink

/sbin/mount.ntfs-3g

auch ein MiniScript machen:

#!/bin/sh
mount -o locale=de_DE@UTF8 "$@"
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
bertl2
Titel: Umlautproblem mit ext. Festplatte  BeitragVerfasst am: 31.08.2008, 09:03 Uhr



Anmeldung: 29. Aug 2008
Beiträge: 16

Vielen Dank für die schnelle Antwort

werde noch ein bisschen experimentieren

Grüße aus Burghausen an den Salzach
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
bertl2
Titel: Umlautproblem mit ext. Festplatte  BeitragVerfasst am: 05.09.2008, 10:39 Uhr



Anmeldung: 29. Aug 2008
Beiträge: 16

Hallo,

habe experimentiert
es ist mir durch manuelle Einträge in fstab und "mount" auch schon gelungen, die NTFS-Partitionen so einzubinden, dass kein Umlautproblem mehr auftritt.

Wesentlich ist hier immer der Zusatz UTF8.

Ist jedoch umständlich, nach dem Einstecken eines USB-Laufwerks mit
NTFS-Partitionen diese manuell einbinden zu müssen.

Habe in Sys.log nachgeschaut, was beim Einstecken des USB-Laufwerks
protokolliert worden ist und habe zur Problem-Ursachenforschung die
entsprechenden Einträge mit denen von Ubuntu verglichen, bei dem
der automatishce Vorgang ohne Problem abläuft.

Der relevante Eintrag scheint dieser zu sein:

Sep 5 10:24:33 KanotixBox ntfs-3g[5153]: Cmdline options: rw,nosuid,nodev,sync


der entsprechende Eintrag beim Ubuntu sieht so aus:

Aug 27 13:08:55 bertl-laptop ntfs-3g[5613]: Cmdline options: rw,nosuid,nodev,uhelper=hal,locale=de_DE.UTF-8


der entsprechende Eintrag beim Kubuntu, beim dem das Problem immer
da ist sieht so aus:

Sep 1 00:07:26 Ubu ntfs-3g[5832]: Cmdline options: rw,nosuid,nodev,uhelper=hal


Es sieht so aus, als mache nur der Eintrag locale=de_DE.UTF-8 den
Unterschied aus, ob es automatisch mit oder ohne Umlautproblem
funktioniert.

Jetzt habe ich versucht, im Hauptverzeichniss Dateien zu suchen und
zu konfigurieren, komme aber auf keinen grünen Zweig.

Ist es überhaupt möglich, an die Cmdline options den locale=de_DE.UTF-8
Eintrag anzuhängen oder zu konfigurieren, so dass der Mountvorgang
automatisch und ohne Umlautproblem abläuft?
Was muß ich tun?

Gr. von Bertl aus Burghausen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
bertl2
Titel:   BeitragVerfasst am: 24.05.2009, 13:25 Uhr



Anmeldung: 29. Aug 2008
Beiträge: 16

Servus,

gibt neuen ntfs Treiber, der das Umlautproblem löst.

libntfs-3g54.deb installieren,
ntfs3g4.4.1.deb installieren,

funktioniert bei mir einwandfrei.

Gr. Bertl aus Burghausen an der Alz
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.05.2009, 13:37 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16313

In Excalibur ist das, in Thorhammer update ich das nicht mehr.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.