20.08.2014, 18:52 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
soeki25
Titel: Keine Mausreaktion nach d-u  BeitragVerfasst am: 23.09.2008, 20:19 Uhr



Anmeldung: 08. Mar 2008
Beiträge: 3

Hallo,

nach dem letzten dist-upgrade steht der Mauszeiger in Bildschirmmitte und bewegt sich von dort kein Stück. Hardwareprobleme sind ausgeschlossen, da gleicher Rechner unter Windows einwandfrei läuft. Vorher gab es keinerlei Probleme. ATI-Graphiktreiber habe ich aktualisiert, was mir auffiel: Unter /dev gibt es keine Datei mouse. Foren und Literatur halfen nicht, weiß jemand Rat? Es läuft Kanotix RC 6 mit Kernel 2.6.22-10.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
ernst_blofeld
Titel:   BeitragVerfasst am: 23.09.2008, 22:54 Uhr



Anmeldung: 06. Jan 2008
Beiträge: 15

Spontan würde ich auf einen Fehler in der /etc/X11/xorg.conf tippen.
Sieh mal nach, ob die Einträge für die Maus da richtig sind, oder konfigurier den XServer durch "dpkg-reconfigure xserver-xorg" einfach neu.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.09.2008, 22:59 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Unter /dev gibts eh nie mouse, weil das default device wenn dann scho /dev/psaux wäre (im kompatiblen mode) bzw. normal /dev/input/mouse. Update mal den kernel.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
soeki25
Titel:   BeitragVerfasst am: 26.09.2008, 11:51 Uhr



Anmeldung: 08. Mar 2008
Beiträge: 3

Vielen Dank für die schnellen Antworten, kam leider erst gestern Abend dazu, mich mit dem Thema zu befassen. Da Alice-dsl mich vorübergehend verlassen hatte, ging nichts in Richtung update. Habe deshalb ein wenig in den Dateien geschnüffelt. In etc/x11/xf86config-4 gibt es drei input-Sektionen für die Maus, seriell, PS2 und USB, auch in der Server-Layout Sektion sind alle drei aufgeführt. Auskommentieren der falschen und Umstellung des Protokolls auf "ExplorerPS2" (ich benutze eine PS2 Maus mit zwei Tasten und einem Scrollrad) führten nicht zum Erfolg. In der xorg.conf.lst erscheint die Meldung "PS2 Mouse not detected", da Windows sie findet, muss sie aber wohl funktionieren.
/dev/psaux ist übrigens vorhanden, ich hatte mich da auf das Debian-Anwenderhandbuch 2008 verlassen. Ich werde heute Abend noch einiges probieren und berichten.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.09.2008, 12:21 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Es ist eh egal, ob ne USB oder PS2 Maus drinsteht, bis auf die Emulation der 3. Taste unterscheidet sich die Konfig eh nicht. Das Configfile, wo benützt wird ist /etc/X11/xorg.conf .
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
soeki25
Titel:   BeitragVerfasst am: 26.09.2008, 20:41 Uhr



Anmeldung: 08. Mar 2008
Beiträge: 3

Ja, nun, Problem gelöst: Switch rausgeschmissen und Maus direkt an die Kiste, und siehe da, die Maus ist (wieder) da. Warum allerdings auf dem gleichen Rechner die Maus mit Switch von Windows erkannt wird, von Linux aber nicht, kann ich mir nicht erklären...
Auf jeden Fall danke ich für viel neues Wissen hinsichtlich x-Konfiguration!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.