21.12.2014, 05:40 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
knegges
Titel: USB-Platte automatisch einbinden  BeitragVerfasst am: 20.01.2009, 20:55 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Hallo,
habe ein kleines Problem.

Ich habe eine USB2-Festplatte, auf die ich mit rsnapshot meine Daten sichere.

Wenn ich vergessen habe, sie nach dem Systemstart einzubinden, speichert rsnapshot alle Daten in einen neu angelegten Ordner, was dann alles blockiert, bis ich den Prozess unterbrochen habe.

Also meine Frage:
Kann man die Platte beim Hochfahren automatisch einbinden?
Das Kreuzchen unter 'Eigenschaften>Einbinden>Automatisch einbinden' bewirkt leider nichts.

Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel: USB-Platte automatisch einbinden  BeitragVerfasst am: 20.01.2009, 21:28 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

da gibts sonen tool "usbmount" , welches Platten automatisch einbindet (soll funktionieren wie unter windows)
aber obs die Platte beim booten einbindet weiß ich net
Sonst kannste ja nen script schreiben, welches beim booten überprüft ob die Platte angeschlossen ist (test -e /dev/deineplatte)

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
jokobau
Titel: USB-Platte automatisch einbinden  BeitragVerfasst am: 22.01.2009, 14:56 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 941
Wohnort: Stuttgart
Du musst sie in die /etc/fstab eintragen.
Brauchst du dazu nähere Erklärung?
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 24.01.2009, 10:43 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Hallo,
vielen Dank für die Hinweise.

@DerangedGonzo
Mit usbmount hat es leider nicht geklappt, evtl. habe ich auch etwas falsch gemacht.

@jokobau
fstab ist ziemlich selbsterklärend.
Nur wo finde ich die UUID-Nr. für mein Laufwerk?

Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dosenfleisch
Titel:   BeitragVerfasst am: 24.01.2009, 11:17 Uhr



Anmeldung: 11. Jul 2006
Beiträge: 164
Wohnort: westerwald
Code:

su
blkid
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
merlin
Titel:   BeitragVerfasst am: 24.01.2009, 11:28 Uhr



Anmeldung: 28. Feb 2005
Beiträge: 1112
Wohnort: Camelot
Eher das hier
http://kanotix.com/PNphpBB2-viewtopic-t-25308.html
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel:   BeitragVerfasst am: 24.01.2009, 11:56 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

also usb platten sollte man eher net in die fstab eintragen. Die kannst du dann als user net mehr mounten, wenn du sie erst nach dem booten anschliesst.
Ich sag ja: entweder nen script bauen, oder was vllt auch noch ne idee wäre: deinen rsnapshotstarter so zu verändern, dass er die Platte mountet wenn se vorhanden ist, und nur startet, wenn se gemountet ist.

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
jokobau
Titel:   BeitragVerfasst am: 24.01.2009, 19:02 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 941
Wohnort: Stuttgart
Geht scho Bsp bei mir:

LABEL=ISO2 /media/ISO2 ext3 defaults,noauto,user,noatime

Kann man natürlich auch über die uuid. Wichtig ist: "user" Im konkreten noauto weg lassen,

ungefähr so:

UUID=b2968fda-f321-4953-96f3-e5b0e9674d6f /media/<mountpoint> ext3 defaults,user

unter der Bedingung, dass es ext3 ist und nicht was anderes.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 25.01.2009, 10:01 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Hallo,

Ich habe jetzt bei rsnapshot eine Einstellung gefunden und auskommentiert, dass nur gespeichert wird, wenn das USB-Laufwerk angeschlossen ist.
Das klappt schon mal super.

Die UUID für die Festplatte habe ich gefunden.

In fstab habe ich folgendes eingetragen:
# <file system> <mount point> <type> <options> <dump> <pass>
# /dev/sdc1
UUID= /media/disk ext3 defaults 0 0

Beim laden wird sie nun automatisch gemountet.

Wenn ich sie später anschliesse wird sie erkannt, aber beim Versuch sie zu mounten kommt die Meldung: "Berechtigung verweigert".

Muss ich mich bei <dump> oder bei <pass> als user eintragen?

Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel:   BeitragVerfasst am: 25.01.2009, 11:20 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

ich sagte ja, dass man USB Platten NICHT in die fstab einträgt gerde WEIL du die dann net mehr als user mounten kannst.
Sagt Kano auch immer wieder.

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
blauweiss
Titel:   BeitragVerfasst am: 25.01.2009, 12:50 Uhr



Anmeldung: 12. Mar 2005
Beiträge: 366

Könnte aber klappen, wenn anstelle von 'user' 'users' eingetragen wird,
ohne Gewähr...

_________________
Gruss an alle Kanotix-Fans, blauweiss
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 26.01.2009, 16:21 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Hallo,
irgendwie klappt jetzt gar nix mehr.

Einmal hatte ich vergessen den USB-Stick raus zu machen.
Der wurde dann als sbc1 benannt (wie vorher die USB-Festplatte).

Seitdem wird beim Hochfahren der mountpoint der Festplatte nicht mehr erkannt, obwohl alles richtig in fstab eingetragen ist.

Was war das mit:
LABEL=ISO2 /media/ISO2 ext3 defaults,noauto,user,noatime ???

Ein Script wäre evtl. wohl doch besser, aber ich habe noch nie eines geschrieben (nur mal angepasst).

Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jokobau
Titel:   BeitragVerfasst am: 26.01.2009, 23:00 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 941
Wohnort: Stuttgart
knegges hat folgendes geschrieben::
Hallo,

Was war das mit:
LABEL=ISO2 /media/ISO2 ext3 defaults,noauto,user,noatime ???

Gruss
k


Das ist ein Beispiel, wie ich eine Festplattenpartition, der ich den Namen (Label) "ISO2" gegeben habe einbinde. Das Beispiel ist aber nur bedingt für dich geeignet. Weil: noauto eben nicht automatisch einbindet, beim Start.

Aber schreibe uns doch, was du gemacht hast. Kannst du uns deine /etc/fstab posten. Mit "jetzt klappt gar nichts mehr" können wir halt herzlich wenig anfangen.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 28.01.2009, 14:14 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Also so sieht mein fstab aus:
wobei sda1 eine Festplatte im Wechselrahmen ist. sdb1 eine interne und sdc1 eben die USB-Festplatte.

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=f98dd1cd-4e15-4482-bd13-1f9f4402d393 /               ext3    errors=remount-ro 0       1
# /dev/sdb1
UUID=735645a3-1db6-4cbc-8ef1-e44984a921f3 /media/sdb1     ext3    defaults          0       0
# /dev/sdc1
UUID=ae363ffb-4876-4445-879b-71fc09477277 /media/disk     ext3    defaults          0       0
# /dev/sda5
UUID=ffc51646-de09-4ebb-a002-6c266ac583c2 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   auto    user,noauto     0       0
/dev/sr1        /media/cdrom1   auto    user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0


Beim Hochfahren kommt nun regelmässig die Meldung:
"mountpoint /media/disk does not exist".
Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
blauweiss
Titel:   BeitragVerfasst am: 28.01.2009, 17:21 Uhr



Anmeldung: 12. Mar 2005
Beiträge: 366

knegges hat folgendes geschrieben::
"mountpoint /media/disk does not exist"

Das Verzeichnis (/media/disk) muß natürlich vorhanden sein,
wenn du das über die fstab regeln willst!

_________________
Gruss an alle Kanotix-Fans, blauweiss
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jokobau
Titel:   BeitragVerfasst am: 28.01.2009, 18:01 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 941
Wohnort: Stuttgart
Würde sie auch nicht unter /media/disk mounten, weil hal das mit einem USB-Gerät macht, das kein Label hat. Machen tuts nix. Wird dann halt unter disk-1, disk-2 .. gemountet.
Schicker wäre aber einfach z.B. sie und bak oder so zu mounten, dann wäre es auch klar welchen Job sie hat.
Wenn du, den Mountpoint erstellst, achte darauf, dass auch die Schreibrechte geklärt sind.
Der Einfachheit halber nimmst den /K-Menü/System/Krusader - root-Modus.
Legst das Verzeichnis /media/<mountpoint> an. Klickst dann auf Eigenschaften. Dann auf Berechtigungen, und gibts dem Verzeichnis ordentliche Schreib / Leserechte.

und wenn du noch in die fstab schreibst ".... defaults,users" kannst sie dann doch aushängen.
Habe auch zuerst gedacht die Bedenken wären richtig. Der Versuch hat aber bewiesen, dass es klappt.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 29.01.2009, 21:24 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Hallo,
danke für die Tipps.

Jetzt klappt es also so weit, auch mit dem Aushängen.
Einhängen geht dann aber nicht mehr: "Berechtigungen verweigert".

Ist dass normal so, oder hapert es noch irgendwo?
Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
jokobau
Titel:   BeitragVerfasst am: 30.01.2009, 13:20 Uhr



Anmeldung: 08. Jul 2006
Beiträge: 941
Wohnort: Stuttgart
DerangedGonzo hat folgendes geschrieben::
ich sagte ja, dass man USB Platten NICHT in die fstab einträgt gerde WEIL du die dann net mehr als user mounten kannst.
Sagt Kano auch immer wieder.


Hatt er halt recht.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
klausmerger
Titel:   BeitragVerfasst am: 30.01.2009, 13:47 Uhr



Anmeldung: 30. Nov 2004
Beiträge: 112
Wohnort: Germany > Wuppertal
Darf ich mich zu Euch gesellen? Ich habe grade Thorhammer samt kernel und d-u frisch 'geputzt' und bin jetzt beim Nacharbeiten. Alle usb-Teile werden beim user 1000 bestens erkannt. ABER: Die usb-Platte kann ich nur als root beschreiben. Ich zeige mal was mount -l zur Platte Passport und zum Stick Kingston sagt:
Code:
root@KanotixBox:~# mount -l
..........................................
/dev/sdc1 on /media/WD Passport type vfat (rw,nosuid,nodev,noatime,flush,utf8,shortname=lower) [WD Passport]
/dev/sdd1 on /media/KINGSTON type vfat (rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower) [KINGSTON]
root@KanotixBox:~#

DAU-Frage 1: Eigentümer von Passport ist root, beim Stick bin ich es!! WIESO??
DAU-Frage 2: Wieso kann der user 500 keine Sticks einhängen? Es öffnet sich zwar das Formular, was getan werden soll, das öffnet sich aber ZUGLEICH beim user 1000. Der user 500 bekommt die Meldung: siehe Anhang!
Ziele:
Die Platte soll ruhig immer angeschlossen sein, und allen usern (mit root drei) zum Lesen zur Verfügung stehen. Aber wenn ich als user mit uid=1000 sie einhänge, möchte ich auch schreiben können.
Der user uid=500 soll natürlich selber auch Sticks einhängen können.
Bevor ich nun den Tipp mit der fstab übernehme, wüßte ich gerne, was hier los ist.



kingston-start.png
 Beschreibung:
 Dateigröße:  45.68 KB
 Angeschaut:  9478 mal

kingston-start.png



_________________
Kanotix Hellfire 3.2.0-030200rc7-generic i686
Quad AMD Phenom II Galliu 0.4 on
ATI Cedar PRO [Radeon HD 5450] X.Org 1.7.7
'Nur zögerndes Wissen zählt' (Canetti)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel:   BeitragVerfasst am: 30.01.2009, 15:27 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

user, die usbsticks einbinden können sollen, müssen der gruppe "plugdev" angehören
wenn du die mountpoints selber erstellt hast,musst du die rechte entsprechend setzen.
bitte externe usb platten NICHT in die fstab eintragen.
wenn du deine Platte eingesteckt hast, und dein system ok ist, sollte sich ein feńster öffnen, mit dem du deinen stick öffnen kannst. dann wird das automatisch von HAL eingebunden.
Ansonsten eben mit dem symbol auf dem desktop einhängen (anklicken, so dass sich die platte öffnet, oder rechtsklick und "Platte einbinden")

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
knegges
Titel:   BeitragVerfasst am: 30.01.2009, 18:16 Uhr



Anmeldung: 22. Jul 2008
Beiträge: 72

Also für mich ist das im Moment mit fstab o.k.

Aber wenn man das nicht tun soll:
Wie soll denn z.B. ein Script aussehen, das beim Hochfahren erkennt, ob die USB-Platte eingehängt ist und diese, falls nicht mountet?

Ich probier's gerne aus.

Gruss
k
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
klausmerger
Titel:   BeitragVerfasst am: 31.01.2009, 15:07 Uhr



Anmeldung: 30. Nov 2004
Beiträge: 112
Wohnort: Germany > Wuppertal
Also erstmal danke. Das Rechteproblem habe ich GELÖST durch Eigenschaften>Einbinden und ein Häkchen bei 'als user einbinden'. Das überlebt dann einen Neustart! Und der andere user hat jedenfalls Leserecht.

@knegges: Wenn ich meine usb-Platte öffne und beim Runterfahren geöffnet lasse, wird sie beim Neustart automatisch eingebunden - und wie gesagt: 'als user' - mit Schreibrechten dann.

@gonzo
Zitat:
user, die usbsticks einbinden können sollen, müssen der gruppe "plugdev" angehören
Gut zu wissen, war aber wohl durch die Installation bereits erledigt.
Zitat:
wenn du die mountpoints selber erstellt hast
Wie macht man das denn bei usb-Geräten (ohne Eintrag in die fstab)? Hört sich spannend an.

_________________
Kanotix Hellfire 3.2.0-030200rc7-generic i686
Quad AMD Phenom II Galliu 0.4 on
ATI Cedar PRO [Radeon HD 5450] X.Org 1.7.7
'Nur zögerndes Wissen zählt' (Canetti)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel:   BeitragVerfasst am: 31.01.2009, 18:53 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

[quote="klausmerger" ]
Zitat:
wenn du die mountpoints selber erstellt hast
Wie macht man das denn bei usb-Geräten (ohne Eintrag in die fstab)? Hört sich spannend an.[/quote]

öhm ... mkdir <mountpoint> Winken
Sind doch auch blos verzeichnisse Winken

mach doch einfach nen einfaches script, welches beim bootvorgang ausgeführt ist, und mit test überprüft, ob die platte vorhanden ist und wenn ja soll se gemountet werden. daran denken, dass überprüft werden sollte, ob der mountpoint vorhanden ist.
muss ja kein professionelles script sein

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.