20.04.2014, 05:50 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
hawidiere
Titel: WLAN USB Stick wird nicht erkannt  BeitragVerfasst am: 22.06.2010, 15:34 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Hallo als Linux Neuling habe ich Probleme damit meinen WLAN-Stick zum laufen zu bringen.
Verwende Kanotix auf einem Fujitsu Amilo K 7600, der Stick ist von Belkin Modell F6D4050v1

Bitte Antworten mit Details da ich noch Neuling auf Linux bin.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: WLAN USB Stick wird nicht erkannt  BeitragVerfasst am: 22.06.2010, 16:50 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16175

bist sicher, dass der nicht geht und nicht nur das device nicht in wicd eintragen ist?

su
iwconfig
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 22.06.2010, 19:10 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Danke für den Hinweis und wie trage ich den dort ein?

Noch die Meldung von iwconfig
Code:
mia1:/home/mia# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 22.06.2010, 20:58 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16175

Zeig mal

lsusb

es langt die Zeile mit dem Stick.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 22.06.2010, 22:04 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

So das kommt bei lsusb

Code:

Bus 001 Device 002: ID 050d:935a Belkin Components
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.06.2010, 00:02 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16175

In Kanotix ist der Treiber dafür nicht dabei, ist ein Ralink RT3572USB

http://www.ralinktech.com/support.php?s=2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 23.06.2010, 00:55 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

drittes Paket von oben runterladen
Code:

bunzip2 2009_1222_RT3572_LinuxSTA_V2[1].3.0.0.tar.bz2
tar -xf 2009_1222_RT3572_LinuxSTA_V2[1].3.0.0.tar
cd 2009_1214_RT3572_LinuxSTA_V2.3.0.0
make
su
make install
echo rt3572sta >> /etc/modules


Am Besten neustarten.

su
iwconfig

korrekte Bezeichnung fürs Wlan (wlan0 oder ra0) in wicd eintragen. Rechts unten Wicd-Symbol in der Taskleiste. Draufklicken - Preferences.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.06.2010, 09:05 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16175

Also dass man ein Modul in die /etc/modules schreibt ist purer schwachsinn, alle module werden per pci oder usb id von udev geladen!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 23.06.2010, 09:36 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Sorry, bin kein Experte (Ich hatte es wohl von ndiswrapper unterschwellig im Hirn Smilie ). Würde aber zumindest keinen Schaden anrichten. Ich hatte es nur so Schritt für Schritt aufgeschrieben, da der Threadersteller um eine Anleitung für Linuxanfänger bat.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 23.06.2010, 10:18 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Danke Felis für die ausführliche Beschreibung, was soll ich jetzt machen?
Kano wenn du weißt wies geht kannst du mir beschreiben was ich machen soll?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 23.06.2010, 10:22 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Genauso, wie ich es geschrieben habe. Paket von der Seite, die Kano schrieb runterladen und wie beschrieben installieren. Nur die letzte Zeile (echo rt3572sta >> /etc/modules ) kannst halt weglassen. Ist unnötig (wäre aber nicht schädlich gewesen.)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 10:01 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

So hab wie angegeben alles durchgeführt, leider ohne positives Ergebnis.
Die Meldung von iwconfig hat sich nicht verändert.
Wie kann ich überprüfen ob die Treiberistallation geklappt hat?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 10:05 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

hawidiere hat folgendes geschrieben::
Wie kann ich überprüfen ob die Treiberistallation geklappt hat?


Poste mal den Output von
lsmod | grep rt3572

und von
iwlist scanning
da musst aber vorher mit "su" Root werden.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 15:52 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Hallo Felis, auf lsmod | grep rt3572, kommt keine Meldung. Die Meldung bei iwlist scanning lautet:

Code:
iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 16:11 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Wenn auf lsmod keine Meldung kommt heisst es, dass der Treiber entweder nicht installiert, oder zumindest nicht geladen ist. Melde dich mit "su" als Root an und gib

modprobe rt3572sta

ein, und schau, ob eine Fehlermeldung kommt. Wenn nicht, nochmal

lsmod | grep rt3572
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 16:20 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Auf modprobe rt3572sta, kommt keine Meldung. Scheinbar hat da was nicht geklappt, nur was mach ich jetzt?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 16:26 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Keine Fehlermeldung ist gut. Gib jetzt
lsmod | grep rt3572
ein
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 16:38 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Da kommt aber auch keine Meldung.

Edit :
Meldung:
Code:
rt3572sta             580441  0


Zuletzt bearbeitet von hawidiere am 24.06.2010, 16:47 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 16:46 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Hm, auf "modprobe rt3572sta" müsste - wenns nicht installiert ist -
"Fatal, modul not found" kommen. Wenn gar keine Meldung kommt, heisst es, das Modul wurde geladen. Bloss müsste dann lsmod was ausgeben. Tut es das sicher nicht? Müsste so aussehen

lsmod | grep rt3572
rt3572sta
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 17:18 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Habs oben schon editiert, war ein Fehler von mir, die Meldung auf lsmod | grep rt3572 lautet:
rt3572sta ............ 580441 0
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 17:19 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Super, dann ist der Treiber ja geladen. Was sagt
iwconfig
bzw.
iwlist scanning (als Root)?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 18:00 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

Meldung von iwconfig:
lo no wireless extensions.

eth0 no wireless extensions.

iwlist scanning:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 18:04 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Als Root:

ifconfig ra0 up (hatte ich vergessen)
iwlist scanning

oder, wenn wieder nix kommt

ifconfig wlan0 up
iwlist scanning
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
hawidiere
Titel:   BeitragVerfasst am: 24.06.2010, 18:11 Uhr



Anmeldung: 22. Jun 2010
Beiträge: 14

ifconfig ra0 birngt folgende Meldung:
ra0: Fehler beim Auslesen der Schnittstelleninformation: Gerät nicht gefunden

ifconfig wlan0 up:
bash: wlan0: command not found
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 24.06.2010, 18:19 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

hawidiere hat folgendes geschrieben::
ifconfig ra0 birngt folgende Meldung:
ra0: Fehler beim Auslesen der Schnittstelleninformation: Gerät nicht gefunden

Eigenartig. Laut Kano ist das ja der Treiber für deinen Stick. Letzte Idee:

Neustart
lsmod | grep rt3572

Wenn der Treiber geladen ist,

iwconfig
iwlist scanning

Wenn der Treiber NICHT geladen ist:
Auch wenn mich jetzt Kano eine Idioten nennt:

als Root:

echo rt3572sta >> /etc/modules

damit wird sichergestellt, dass der Treiber nach Neustart geladen wird. Dann nochmal Neustart und schauen obs scannen kannst.

iwlist scanning

Und wenn das alles nicht funktioniert, gibt's noch die die Möglichkeit das Wlan mit dem Windowstreiber zu betreiben. Ganz einfach, aber das ist wieder eine andere Geschichte. Smilie
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.