29.07.2014, 06:10 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
dirkmitt
23 Titel: Frage wegen .ini anstatt .inf -Dateien-Namen.  BeitragVerfasst am: 23.10.2010, 13:29 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Ich habe gerade einen Acer Aspire 5024 erhalten, mit 1.8GHz AMD Turion CPU, der zwar ein 64-Bit CPU ist, der jedoch von mir mit 32-Bit Excalibur installiert wurde, Kernel Version 2.6.32-21-generic .

Dieser Laptop hätte für Windows Broadcom und Foxconn-Treiber, dessen Exakte Wirkung ich nicht zu unterscheiden kenne.

Wenn ich jedoch den Foxconn-Treiber per 'ndiswrapper' installieren will, erfahre ich dass ich für den in seinem Ordner nur eine Windows .INI-Datei habe, keine .INF-Datei die ndiswrapper normalerweise erfordert.

Meine Frage wäre, darf ich diese zuständige .INI-Datei einfach auf ....INF umnennen, für ndiswrapper?

Dirk


Zuletzt bearbeitet von dirkmitt am 01.01.2011, 19:41 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
towo2099
Titel:   BeitragVerfasst am: 23.10.2010, 14:24 Uhr



Anmeldung: 23. Sep 2004
Beiträge: 578

Zitat:
Meine Frage wäre, darf ich diese zuständige .INI-Datei einfach auf ....INF umnennen, für ndiswrapper?

Dürfen darfst du Alles, nur bringen tut das genau NULL.
Eine *.inf ist was völlig Anderes, als eine *.ini.

_________________
Ich bin nicht die Signatur, ich Putz' hier nur Winken
Nach Diktat spazieren gegangen Auf den Arm nehmen
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 23.10.2010, 20:46 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Vielen Dank!

Ich empfinde nur, dass der Kano diese Frage nicht persönlich beantwortet hat, weil er persönlich gegen 'ndiswrapper' ist, was bei mir gerade gut läuft...

Ironisch hatte ich auch irgendwo schon gehört, dass man bei den meisten Broadcom Chipsets direkt Linux Treiber verwenden kann. Und in dieser Hinsicht schätze ich den Computer, den ich erst neulich unter den Fingern habe, auf einen möglichen Ausnahmefall, weil ich meinte doch ndiswrapper zu brauchen. Wie ich mir das im Moment noch vorstelle, ist so dass bei dem hier der Broadcom Chipsatz außerdem für Ethernet gilt, und nicht ausschließlich für WiFi. Also könnte es zu einer Situation führen, wo man absolut die Linux-Treiber verwenden sollte, wozu ich den ndiswrapper ausdrücklich und erfolgreich einschalte (mit 'modprobe ndiswrapper' innerhalb der Sitzung), weil mir die Linux-Treiber alleine kein 'wlan' anzeigen, das jedoch in der Konfigurationsdatei eingerichtet bleibt. Mit den Augen rollen

Wenn jedoch sonnst jemand einen Acer Aspire 5024 unter Linux zum laufen hat, darf der mir das ruhig besser erklären, denn den hier habe ich selber erst ein paar Tage lang. Dazu kenne ich auch noch nicht, wieso's für den gleichzeitig Windows-Treiber von Foxconn gibt. Das war jetzt als eine rein theoretische Frage gemeint.

Ich verstehe auch, das sich der Kano viele Jahre lang Mühe gegeben hat, die Bedienungsflächen zu programmieren, damit das einzelne Benützer nicht tun brauchen. Und dann könnte ich schon etwas wie ein Ketzer vorkommen, wenn ich in den Konfigurationsdateien selber so herum fummele.

Dabei verwende ich Kanotix gerade selber so gerne, weil es mir in jeder Richtung die Auswahl gibt! Smilie

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.10.2010, 21:46 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Ich bin nicht gegen ndiswrapper, hab dem entwickler min. 100$ schon gespendet. aber es ist sinnlos wenn es einen binary treiber gibt der definitiv bei korrekter nutzung auch funktioniert!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 24.10.2010, 03:55 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

@Kano:

Was Sie ja meinten, weil ich schrieb das sich das dkms-Kernelmodul, von Ihnen vorgeschlagen, beim Neustart erfolgreich ladet, jedoch nur ein 'eth0' zu sehen ist, kein 'wlan0', war dass es möglich sei dass der WiFi-Anschluss nur umbenannt sein könnte. Was ja schließlich hätte sein können.

Weil ich der Sache korrekt nachgehen wollte, habe ich heute früh mal den Versuch gemacht ein Ethernet-Kabel quer durch das Büro von meinem Vater zu ziehen, und 'eth0' auch echt als Ethernet zu aktivieren.

Das klappte erfolgreich. Ich gab also (ohne ndiswrapper) den Befehl

ifup eth0

und war laut meinem "gkrellm" Desktop-Applet sofort vernetzt, was ja für 'wlan0' ohne ndis... vorher nicht ging. Weiterhin zog ich den Ethernet-Stecker wieder raus, ohne Befehle an den Computer zu geben als Überraschung, weil es ja irgendwie hätte sein können, der verbindet sich trotzdem mit WiFi an den selben Router.

Als ich das Ethernet-Kabel auch physisch raus zog, verschwand die Netzwerk-Verbindung sichtbar sofort wieder.

Ich habe jetzt also Ihre These vollständig getestet, was ich zuerst nicht tat, und bewiesen das 'eth0' von mir in der '/etc/network/interfaces' Datei außerdem richtig eingerichtet war, und tatsächlich dem (verdrahtetem) Ethernet-Port entspricht.

Außerdem meine ich mich schwach zu erinnern, das ich Ihrem Ratschlag gefolgt habe, indem ich das dkms-Kernelmodul auch installierte (beim zweiten Anlauf am Internet verbunden), wovor ich meinte keinen Interface per Name 'eth0' gesehen zu haben. Dazu könnte ich mich aber auch wieder an meinem Gedächtnis irren...

Jetzt erzählen Sie mir doch bitteschön, wo ich zu einer unlogischen Schlussfolgerung gekommen sei, und auf das ganze inkompetent regiert hätte. Ich habe jetzt einen neu-eingerichteten Laptop, bei dem 'eth0' und 'wlan0' beide anstandslos funktionieren.

Nur meine ich, ich sollte an Suspend To Disk weiter arbeiten, was bei vielen unter Linux gar nicht klappt, und was in sich nie echt ein Netzwerk-Thema war.

Steht es denn irgendwo geschrieben, dass man nicht ein Interface per Kernelmodul, plus ein anderes Interface per ndiswrapper gleichzeitig einrichten darf, um daraus nur eins zu einer Zeit zu verwenden?

Weiterhin, um jede Möglichkeit zu prüfen, habe ich auch gestern schon ausprobiert, spezifisch den ndiswrapper für 'wlan0' zu entfernen, durch die Befehlszeile

ndiswrapper -r bcmwl5

was ohne Fehlermeldung geschieh. Ich wollte wissen ob dadurch bei dem Neustart, rein durch das erfolgreich-installierte Kernelmodul endlich 'wlan0' erscheinen würde. Denn ich habe ja 'ndiswrapper' schon nicht in der Datei '/etc/modules' drinnen. Aber 'wlan0' erschien dann trotzdem nicht, weswegen ich den ndiswrapper auch wieder anfing zu verwenden.

Dirk

P.S. Übrigens staunt mein Vater ziemlich über mein Verhalten zum frühen Morgen-grau.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.10.2010, 15:02 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Wenn man eine GUI installiert hat, dann verwendet man diese! wicd geht optimal mit 2 netzwerkkarten, warum sollte mal die interfaces verwenden. Warum bootest du nicht mal ne Live version (idealerweise Hellfire) und startest das script während du per kabel im netz bist und checkst ob ein wireless device da ist? (kann auch per default down sein, also ifconfig -a sollte man auch angucken). Dein System ist mir zu sehr auf ndiswrapper umgestellt und die Anleitung wie man ndiswrapper deaktiviert hast wohl auch nicht gemacht. Mit dir zu diskutieren ist echt vergedeudete Zeit.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 26.10.2010, 08:58 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

@Kano:

Ich habe Ihnen jetzt etwas genauer zugehört. Daraufhin habe ich die Datei '/etc/network/interfaces' genau so zurück gesetzt, wie Sie mir das empfohlen haben. 'modpobe ndiswrapper' läuft bei mir ja so wie so nicht [automatisch]; ist in '/etc/modules' nicht drinnen. Und dann habe ich einen Neustart gemacht.

Daraufhin habe ich das "wicd" Ikon, wozu ich "wicd" niemals runter-schmeißen würde, mal ausprobiert. Aber es zeigte mir dann nach wie vor keine Netzwerke an, obwohl das dkms-Modul mit Ihrem Skript erfolgreich installiert war, und obwohl ich beim Neustart auch immer die Meldung bekomme, dass sich das [...] dkms-Kernelmodul erfolgreich ladet. ["broadcom-wl" wird ausdrücklich erwähnt.]

Das habe ich alles getan, weil mir aufgefallen war, dass Ihr Skript eine Python-Skript ist, und deswegen nicht selber Befehle wie 'ifconfig' verwendet, sondern unabhängige Python-Module für Networking. Das hätten Sie mir aber ruhig sagen dürfen! Smilie

Per 'ifconfig -a' gab es dann aber genau wie vorher keinerlei 'wlan' zu sehen. 'ifconfig' zeigt jedoch immerhin 'vboxnet0' an.

Wenn ich jetzt umständlicher den ndiswrapper ausbauen sollte, sagen Sie mir das noch mal. Aber meine Meinung dazu blieb bis jetzt zumindest, das ndiswraper schließlich ein Emulator ist. Das bedeutet, dass wen der Emulator nicht läuft, auch die entsprechende Windows-Treiber nicht mehr installiert sein können. Es sollte also gar nicht nötig sein, die ndiswrapper weiter aus zu bauen, um sie zu entfernen. Sollte ich 'modprobe ndiswrapper' bereits manuell gegeben haben, dürfte auch 'modpobe -r ndiswrapper' dazu ausreichen.

Ich verstehe auch, dass das Kernelmodul "ndiswrapper" den Windows-Treiber vielleicht nur startet, und der nach 'modprobe -r ndiswrapper' vielleicht als Bruchstück irgendwo noch weiter läuft. Das tut dieses Bruchstück dann aber nach einem Neustart nicht mehr, und nach einem weiteren '/etc/init.d/networking restart' ebenso nicht.

Danach muss ich aber ndiswrapper in der Praxis wieder einschalten, um Ihnen auf dem Internet berichten zu können, was die Ergebnisse waren. Genau deshalb meinte ich, das es im Moment auch per IRC nicht ginge.

Eine LiveCD mit "Hellfire" kann ich jederzeit ausprobieren, auch in zwei Wochen noch. Was mich jetzt bloß ein bisschen gestört hat, ist dass ich das alles sofort ausprobieren sollte, während ich bei meinem Vater als Gast zu Besuch in Deutschland bin. Weil es also nicht warten kann, bis ich wieder bei mir zu hause wäre, ist es wohl vergeudete Zeit mit mir darüber zu sprechen. Mir ist sowas sogar egal, vom Charakter her, aber meinem Vater ist das nicht egal.

Ich habe mir jetzt aber eine Meinung gebildet, über 'wicd', einfach dem Anschauen der Skripts nach. Das sieht nach einem guten System aus; schade das Sie 'ndiswrpper' blacklistet haben. Denn, wäre 'ndiswrapper' geradezu nicht blacklistet, dann würde ich "wicd" sofort anfangen zu benützen.

Aber basteln können Wir auch in drei Monaten noch...

Dirk

N.B.: Kano hatte im anderen Thread empfohlen, ich gäbe

rm -f /etc/udev/rules.d/70-persistent-*

Das hätte also nur als Erfolg, dass der Name 'wlan0' nicht mehr belegt wäre. So fern ich das noch nicht ausprobiert habe, dürfte das Ergebnis bis jetzt nur sein, dass ein zusätzlicher Interface eben fortlaufend auf 'wlan1' benannt werden würde. Angenommen es entstehe erst mal, durch das gute dkms-Kernelmodul, ein zusätzlicher Interface.

Dagegen befinden sich unter /etc/ndiswrapper nur spezifische sub-Ordner, die 'ndiswrapper' für sich verwendet, wenn 'ndiswrapper' ein Mal läuft.


Zuletzt bearbeitet von dirkmitt am 26.10.2010, 11:21 Uhr, insgesamt 3 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 26.10.2010, 10:44 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Kano hat folgendes geschrieben::
Ich bin nicht gegen ndiswrapper, hab dem entwickler min. 100$ schon gespendet. aber es ist sinnlos wenn es einen binary treiber gibt der definitiv bei korrekter nutzung auch funktioniert!

@Kano OT: Hast du eine Idee, wieso mein Netbook sich in ein offenes Wlan beim Nachbarn mit Ndiswrapper einloggen kann, mit dem Linux-Ralinktreiber aber nicht? Frage ist akademischer Natur. Winken
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.10.2010, 11:47 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Vermutlich wegen Kanal 12 oder 13.

echo options cfg80211 ieee80211_regdom=EU > /etc/modprobe.d/wlan.conf
update-initramfs -u
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 26.10.2010, 12:09 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Ich bin jetzt vollständiger dem Ratschlag vom Kano nachgegangen.

Zuerst gab ich

cat /etc/udev/rules.d/70-persistent-net.rules

wozu ich erfuhr dass 'wlan0' nicht nur belegt war, sondern zusätzlich dem einzelnen Adapter zugestellt. Es hätte also immer noch stimmen können, dass das gesunde Kernelmodul den selben Device nicht hätte weiter bedienen können. Also gab ich danach genau

/etc/init.d/networking stop
modprobe -r ndiswrapper
rm /etc/udev/rules.d/70-persistent-net.rules

Und ich gab einen Neustart.
Nach so einem Neustart bin ich ja grundsätzlich nicht auf dem Internet, also lohnte es sich schon mal zunächst

cat /etc/udev/rules.d/70-persistent-net.rules

noch mal zu geben, was im anderen Fenster noch angezeigt ist, von bevor ich wieder den ndiswrapper aktivierte, um das Ergebnis hier auf dem Forum einzufügen:


dirk@Aphrodite:~$ cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x10ec:0x8169 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0a:e4:ea:11:6f", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
dirk@Aphrodite:~$


Und weiter:


Aphrodite:/home/dirk# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0a:e4:ea:11:6f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:102 errors:0 dropped:0 overruns:0 frame:0
TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6604 (6.4 KiB) TX bytes:6604 (6.4 KiB)

vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Ich hatte jetzt also den Computer eindeutig nach einem Neustart, nach dem 'erfolgreichen' laden des Kernelmoduls, und ohne 'wlan'. Vorher war dort aber vor dem Versuch noch ein Eintrag wegen 'wlan0'. Und jetzt wo ich per ndiswrapper wieder auf dem Kanotix-Forum bin, entstand wieder:


dirk@Aphrodite:~$ cat /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x10ec:0x8169 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0a:e4:ea:11:6f", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x14e4:0x4318 (ndiswrapper)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:14:a4:4f:92:04", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
dirk@Aphrodite:~$


Und dementsprechend:


Aphrodite:/home/dirk# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0a:e4:ea:11:6f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:104 errors:0 dropped:0 overruns:0 frame:0
TX packets:104 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6704 (6.5 KiB) TX bytes:6704 (6.5 KiB)

vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 00:14:a4:4f:92:04
inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::214:a4ff:fe4f:9204/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:504 errors:0 dropped:0 overruns:0 frame:0
TX packets:415 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:455750 (445.0 KiB) TX bytes:46772 (45.6 KiB)
Interrupt:21 Memory:c0204000-c0206000


Also: Es kann daran auch nicht liegen.

ABER: Was macht denn Kano's Installation-Skript, wenn mehr als ein Broadcom Chipsatz physisch vorhanden ist, also 1x Broadcom Ethernet, plus 1x Broadcom WLAN? Installiert die Skript dann auch für das WLAN einen zweiten Treiber?

Dirk

N.M: Dazwischen habe ich, immer noch bei meinem Vater zu Gast, Mittag gegessen, ohne Beschwerden von ihm.


Zuletzt bearbeitet von dirkmitt am 26.10.2010, 12:33 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.10.2010, 12:31 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Du schnallst es einfach nicht: du sollst nicht ndiswrapper nehmen sondern wl! Bei dir ist wohl noch ein konfigfile auf ndiswrapper geforced, also mach mal

rm -f /etc/modprobe.d/ndiswrapper*

modprobe wl

wär wohl eher was du testen solltest. Ich frag mich echt warum du immer wieder damit anfängst und nicht wl verwendest. Willst mich extra nerven oder wie?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 26.10.2010, 13:12 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Hier war jetzt das Ergebnis:


Aphrodite:/home/dirk# /etc/init.d/networking stop
Deconfiguring network interfaces...There is already a pid file /var/run/dhclient.wlan0.pid with pid 3462
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:14:a4:4f:92:04
Sending on LPF/wlan0/00:14:a4:4f:92:04
Sending on Socket/fallback
DHCPRELEASE on wlan0 to 192.168.1.1 port 67
done.
Aphrodite:/home/dirk# modprobe -r ndiswrapper
Aphrodite:/home/dirk# modprobe wl
Aphrodite:/home/dirk# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0a:e4:ea:11:6f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:132 errors:0 dropped:0 overruns:0 frame:0
TX packets:132 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8576 (8.3 KiB) TX bytes:8576 (8.3 KiB)

vboxnet0 Link encap:Ethernet HWaddr 0a:00:27:00:00:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Aphrodite:/home/dirk# /etc/init.d/networking start
Configuring network interfaces...done.
Aphrodite:/home/dirk# ifup wlan0
Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; No such device.
ioctl[SIOCGIFFLAGS]: No such device
Could not get interface 'wlan0' flags
ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
Could not configure driver to use managed mode
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWENCODEEXT]: No such device
ioctl[SIOCSIWENCODE]: No such device
ioctl[SIOCSIWAP]: No such device
ioctl[SIOCGIFFLAGS]: No such device
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up wlan0.


Aber Sie glauben mir das wohl einfach nicht.
Ohne 'ndiswrapper' wieder einzuschalten, käme ich einfach nicht mehr auf's Internet, wie auch auf das Kanotix-Forum, um irgendwas fragen zu können oder vorweisen zu können... Und, bevor ich einfach sämtliche Ordner lösche, schaue ich mir die auch schon mal an, um zu wissen was die beinhalten. Der Grund ist nämlich die Möglichkeit, dass Sie den 'ndiswrapper' gerade nicht verwendet haben, in welchem Fall bei Ihnen auch nichts anderes Zugriff zu den Ordnern verlangt. Winken Es zeigt sich dass ausschließlich der 'ndiswrapper' selber den Inhalt verwendet, in diesem einen Fall, wenn der auch läuft. Wonach ich aber die ganze Zeit suche, ist der Möglichkeit dass die Skript von Ihnen, bei Ihnen auch funktioniert, aber bei mir nicht. Und ich gehe davon aus, dass Sie auch so tief darüber nachdenken:


Aphrodite:/home/dirk# ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4318) present (alternate driver: ssb)
fwlan : driver installed
Aphrodite:/home/dirk# cd /etc/ndiswrapper
Aphrodite:/etc/ndiswrapper# ls
bcmwl5 fwlan
Aphrodite:/etc/ndiswrapper# ls -l
total 8
drwxr-xr-x 2 root root 4096 2010-10-23 07:24 bcmwl5
drwxr-xr-x 2 root root 4096 2009-01-08 20:17 fwlan
Aphrodite:/etc/ndiswrapper#


Dort speichert 'ndiswrapper' die Windows-Treiber hin. Würden solche denn direkt unter Linux laufen, ohne 'ndiswrapper'? Der richtige Weg diese zu löschen, wäre mit

ndiswrapper -r bcmwl5

usw., was ich auch schon mal ausprobierte, wovon ich auf diesem Forum schon mal schrieb, wozu Sie aber keine Stellung nahmen.

Ich sehe nur, dass es zumindest möglich ist, dass manche Computer zwei solche Chipsätze von Broadcom haben, wie immer auch selten, und dann sollte Ihre Skript den Fall auch verarbeiten können. Wenn das auch so sei, bräuchten Sie das ja nur spezifisch bestätigen, obwohl Sie das in dem Fall schwierig fänden auch zu testen, es sei den Sie hätten einen solchen auch vor Sich.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.10.2010, 17:26 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Interessanterweise hat ssb ja eine unterstützte id, könntest genauso gut

apt-get install b43-fwcutter
dpkg --purge broadcom-wl-dkms
rm -f /etc/modprobe.d/ndiswrapper /etc/modprobe.d/broadcom-wl.conf /etc/udev/rules.d/70-persistent-*
update-initramfs -u
reboot

probieren. Brauchst wohl nichtmal wl.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 26.10.2010, 21:36 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Kano hat folgendes geschrieben::
Vermutlich wegen Kanal 12 oder 13.

echo options cfg80211 ieee80211_regdom=EU > /etc/modprobe.d/wlan.conf
update-initramfs -u

Danke! Würdest du erklären, was diese Optionen bedeuten?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.10.2010, 21:58 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Wenns funktioniert hat: in der EU ist halt noch kanal 12+13 erlaubt (in Japan wär es bis 14 möglich) und in den US und woanders halt nur 1 bis 11. Deswegen ist es nicht ganz so ideal den Router auf 12/13 zustellen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Felis
Titel:   BeitragVerfasst am: 27.10.2010, 07:38 Uhr



Anmeldung: 18. Okt 2007
Beiträge: 393

Konnte es noch nicht versuchen, im Augenblick ist scheint sein Router aus. Allerdings fällt mir ein, dass der Netgear eine englische Bedienung hat. Vielleicht hat er ihn von woanders. Aber was haben die Kanäle mit dem "Problem" zu tun. Schaffen nicht Windows- und Linuxtreiber alle Kanäle? Bin schwer von Begriff.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 27.10.2010, 09:16 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16219

Es ist ein Problem der Voreinstellung. Das ist einfach ein Softwarelock.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel:   BeitragVerfasst am: 27.10.2010, 21:54 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Kano hat folgendes geschrieben::
Interessanterweise hat ssb ja eine unterstützte id, könntest genauso gut

apt-get install b43-fwcutter
dpkg --purge broadcom-wl-dkms
rm -f /etc/modprobe.d/ndiswrapper /etc/modprobe.d/broadcom-wl.conf /etc/udev/rules.d/70-persistent-*
update-initramfs -u
reboot

probieren. Brauchst wohl nichtmal wl.


Ich entschuldige mich zunächst mal über die Tatsache dass es mich jetzt schon wieder so lange gedauert hat Ihren Ratschlag auch einzuführen. Das liegt daran, dass ich heute den ganzen Tag lang im Flieger war, auf dem Weg von Frankfurt zu mir nach Hause in Montreal zurück. Der Flug lief für mich aber wie geregelt, obwohl es eben auf zumindest meinem Flieger kein Internet-Zugang gab. Lachen

Jetzt habe ich aber mal genau das getan, was Sie mir hier vorgeschlagen haben, und der 'fwcutter'-derivierte Treiber läuft scheinbar Ast-rein. Daher bedanke ich mich bei Ihnen letztendlich, ein Mal weil Sie sich doch die Zeit genommen haben meine lange Postings zu lesen, zweitens weil Ihnen das mit dem SSB-Dingsbums aufgefallen war, aus meinen Fehlermeldungen heraus, und drittens weil Sie mir daraufhin eine Lösung empfohlen haben, die einfach voll läuft.

Ich bin jetzt also von 'ndiswrapper' völlig runter, 'wlan0' wird korrekt ohne erkannt, und ich bin wieder voll am Netz.

dirk@Aphrodite:~$ lsmod | grep ndis
dirk@Aphrodite:~$

Sehr glücklich Sehr glücklich

Das war aber eine Schwergeburt!

Jetzt komme ich nun mal zum nächsten Thema, dass ich '/etc/network/interfaces' wie geübt zurück gesetzt habe, also auf Ihre zwei-Zeilige, aber das 'wicd'-Icon bei mir immer noch die WiFi-Möglichkeiten nicht entdeckt.

Ich meine jedoch, dass das jetzt nicht mehr daran liegen kann, dass 'ndiswrapper' irgendwo blacklistet sei, sondern dass wir hier in Nordamerika Kanal 11 verwenden, der Laptop Hardware-mäßig Deutschland zugerichtet ist, ich aber bisher den Default-Kanal durch eine etwas ausgebaute '/etc/network/interfaces' normalerweise überstimmen kann, weil die Hardware dazu immerhin fähig ist.

Es wäre jetzt doch auch schön, wenn ich das GUI, wie Sie schon sagten, auch einmal zum laufen bekäme.

[Edit: Eine Zugabe an jeden gerichtet...]

Jetzt habe ich mich mal umbeschaut und etwas dazu gelernt. Damit das Drahtlos von 'wicd' auch funktioniert, muss man jeden möglichen Zugangspunkt durch eine Stanza für sich in der Datei '/etc/wicd/wireless-settings.conf' einrichten. Das Icon in der Benachrichtigungsleiste zeigt einem also vorweg nur an, welche von den schon-konfigurierten Zugangspunkten es auffinden kann. Es ging also nie darum, dass man mit dem System auch automatisch 'Roaming' hätte.

Jedoch gäbe es für mich zwei erhebliche Vorteile für das Drahtlos doch 'wicd' zu verwenden:

1) Die spezifische Angaben wie Kennwort usw., sind in einer Datei versperrt, der man ohne root-Kennwort keinen Zugang erhält.

2) Nach der richtigen Einrichtung kann man sich ein WLAN aussuchen und aktivieren, ohne das root-Kennwort schon wieder eintippen zu müssen.

Ich werde mich also irgendwann mal tiefer damit befassen, die Stanzas für Drahtlos auch vollständig einzurichten, ab welchem Punk mir auch das mit 'wicd' gelingen dürfte.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
15 Titel:   BeitragVerfasst am: 28.10.2010, 20:25 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

GELÖST!

Was ich mal wieder unerfahren nicht verstand, ist das ich nicht nur '/etc/wicd/wirless-settings.conf' bearbeiten musste, sondern außerdem '/etc/wicd/manager-settings.conf'. Das hat mich bis zum Ende blockiert. Wo man aber in 'manager-settings.conf' als erste Zeile verwenden darf 'wireless_interface = wlan0' , anstatt "None", funktioniert jetzt bei mir endlich auch das Icon in der Benachrichtigungsleiste voll!

Ich komme jetzt also endlich über 'wicd' und über die GUI auf mein WLAN und kann meine ungesicherte Kennwort-beladene Alternativen zu der '/etc/network/interfaces' Datei löschen. Sehr glücklich Sehr glücklich

Jetzt läuft's voll!

Dirk

[Vermerk:]

Sie könnten mich jetzt für richtig doof alten. Aber obwohl ich schon oft auf dem Icon rechts-geklickt habe, ist es mir bis vor kurzem noch nie eingefallen, auf dem Icon mal links zu klicken. Verlegen

Aber wer sagt's denn, zumindest bin ich durch dieses Projekt jetzt doch dazu gekommen, auf einen viel besseren WLAN Treiber als mit 'ndiswrapper' umzusteigen, und den Weg dazu auch zu finden (dank Kano). Und so hat sich bei mir der Eindruck zuletzt wieder-errichtet, dass man mit 'wicd' doch Roaming erreichen kann. Smilie

Mein stolpern mit 'wicd' lag also ausschließlich daran, dass es mir nicht aufgefallen war, man kann das 'wicd-client' Icon auch links-klicken, wovon ich erwartete das selbe Menü zu erhalten, wie mit einem rechts-Klick. Aber stattdessen bekommt man ein ganzes Fenster mit Einstellungen zu sehen, und einer Liste der WLANs, für die 'wicd' die Profile für sich in die Datei speichert.

Ich habe gar keine Erfahrung mit WiFi, außer mit einem uralten Celeron-basierten Laptop, der einem Pentium-2 Äquivalent war, wo ich es jedoch geschafft hatte Kanotix 2006-RC4 zu installieren. Und dort war das WiFi nur zu erhalten indem man eine PCMCIA-Karte einsteckte. Die hatte ich dann damals in '/etc/network/interfaces' mit 'hotplug' eingerichtet, so dass sich durch das einstecken der Karte entschied, ob ich auf's WLAN gelangen wollte.

Und so weit ist der Fortschritt dann schon gelaufen, mit 'Roaming' unter Linux. Das gefällt mir sehr!
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
23 Titel:   BeitragVerfasst am: 01.01.2011, 19:40 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 134

Was ich doch noch schreiben wollte, ist dass ich in den letzten Monaten die Gelegenheit bekam, Kanotix ganz neu zu installieren (auf diesem Laptop). Und in diesem Fall wurde auch echt ein Dual-Boot System daraus.

Was ich jetzt also tat, war einfach dem Wissen zu folgen, der mir auf dieser Web-Seite hier angeboten wurde, und niemals erst zu versuchen den WiFi-Adapter mit 'ndiswrapper' zu installieren. Und das lief dann auch tatsächlich! Es fanden also während der Zeit meines ersten Posting zweierlei statt:

1) Ich hatte nicht die richtige Befehlszeile gefunden, um zu testen ob 'wlan0' überhaupt schon besteht.

2) Es war wohl doch so viel vom 'ndiswrapper' installiert geblieben, obwohl ich meinte den gelöscht zu haben, dass dadurch 'wlan0' durch einheimische Treiber nicht mehr entstand, als 'ndiswarpper' wieder einfach ausgeschaltet war.

Also hatte Kano Recht.

Ein Ratschlag der mir bloß während meines Deutschland-Besuches nicht geholfen hätte, wäre gewesen, 'Linux neu installieren'. Und der Grund war einfach die Tatsache, dass es unter den Umständen nicht praktisch war.

Es wurde dann aber später wieder praktisch, als ich bei mir wieder zu Hause Zeit zum basteln hatte, und war dann sogar vorteilhaft.

Wovor ich jetzt aber Angst habe, ist dass inzwischen vielleicht 100 Versuche gemacht wurden, festzustellen wieso das einheimische Kernelmodul nicht geladen sei, das für meinen WiFi-Adapter ausreichen sollte. Wegen meinem Problem hier.

Es reicht dann doch einwandfrei aus.

Und 'wicd' einzurichten, klappte dann bei der nächsten Installation auch einfach per GUI, weil ich ja jetzt wusste, wo ich (im Fenster) 'wlan0' eintragen musste.

Entschuldigung dass ich zu diesem Ergebnis nicht schneller gekommen war.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.