25.10.2014, 15:59 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
zippy
Titel: Bildschirm schwarz mit fglrx  BeitragVerfasst am: 16.12.2010, 17:15 Uhr



Anmeldung: 15. Jun 2009
Beiträge: 7

Ich muß für meine passiv gekühlte HD4670 (RV730XT) den ATI-Treiber benutzen, sonst ist sie ständig heiß.
Jetzt habe ich die neue Hellfire-Iso 32Bit frisch installiert und war erstmal begeistert vom neuen Design.
Nach install-fglrx-debian.sh war dann leider der Bildschirm schwarz. Bin jetzt ohne die erstellte xorg.conf wieder mit heißer Karte dabei... echt schade, ging doch sonst so gut.
Habt ihr eine Idee? Vielleicht einen älteren Treiber probieren?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Bildschirm schwarz mit fglrx  BeitragVerfasst am: 16.12.2010, 19:09 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Das scipt ist scho das richtige, aber es MUSS abstürzen beim ersten aufruf, man kanns gleich mit -z option nutzen und dann rebooten. Das entladen von radeon mit kms kann ich zwar (ist nicht aktiv) aber würde nie gehen. -z killt kein X, sondern erfordert neustart.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
zippy
Titel: Bildschirm schwarz mit fglrx  BeitragVerfasst am: 16.12.2010, 22:02 Uhr



Anmeldung: 15. Jun 2009
Beiträge: 7

Ich habe das Script nochmal mit -z laufen lassen. Aber nach dem reboot komme ich nicht mehr in den Desktop, ist wieder schwarz.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Bildschirm schwarz mit fglrx  BeitragVerfasst am: 16.12.2010, 23:00 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Komm mal in den Chat.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
krishan1
Titel:   BeitragVerfasst am: 18.12.2010, 13:12 Uhr



Anmeldung: 22. Jul 2005
Beiträge: 227

Hier das gleiche Problem. Mit fglrx-Treiber bleibt der Bildschirm nach dem Starten von kdm schwarz. Da hilft nur ein Hard-Reset. Mit dem löschen der xorg.conf per chroot oder von einem anderen System aus startet KDE zwar wieder, aber sobald mit "aticonfig --initial" eine neue fglrx-xorg.conf angelegt wird ist das Problem wieder vorhanden.

Ursächlich scheint mir der Kernel 2.6.32-5 zu sein. Mit dem 2.6.34-4-generic von Excalibur gibt es diese Probleme nicht.

_________________
Subjektivität ("Ich bin") ist ein Parasit auf dem Erleben. Nanavira Thera | Notizen zu Dhamma
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 18.12.2010, 13:44 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Das Problem ist nicht der Kernel, hat wohl was mit nem Fehler von live-build zu tun. Dieser muss neu sein, früher gabs das nicht, dass die md5summe von der /boot/initrd* nicht zur Summe in /var/lib/initramfs-tools passt. Ein

update-initramfs -utk all

Sollte hierbei helfen. Dazu muss man noch sagen, dass dkms bei squeeze schlechter funktioniert als noch bei lenny, ein init trigger fehlt neuerdings - warum auch immer... jedenfalls kann man am bequemsten alle module für nen bestimmten kernel manuell erstellen lassen mit

/usr/lib/dkms/dkms_autoinstaller start 2.6.32-5-686-bigmem

bzw.

/usr/lib/dkms/dkms_autoinstaller start 2.6.32-5-amd64

Sollte es für den anderen Kernel erzeugt werden, der noch da ist. Der Trigger wird nur noch beim Installieren von nem Kernel aber nicht mehr beim Booten aufgerufen. Ich werd mir nen Hotfix für mein fglrx script einfallen lassen...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
krishan1
Titel:   BeitragVerfasst am: 18.12.2010, 14:53 Uhr



Anmeldung: 22. Jul 2005
Beiträge: 227

Danke Kano.

Mit dem 2.6.34-4-generic klappt es erst einmal. Ein Hotfix wäre für die Zukunft natürlich ideal. Smilie

_________________
Subjektivität ("Ich bin") ist ein Parasit auf dem Erleben. Nanavira Thera | Notizen zu Dhamma
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel:   BeitragVerfasst am: 19.12.2010, 02:23 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

aber bitte nicht vergessen, diese Fehler jeweils Upstream zu reporten, falls dass noch der Fall sein sollte
ein Workaround nur für Kanotix kann ja wohl nicht die Lösung sein Winken

Zu dem live-build Bug finde ich bisher nix, aber durchaus nochmal selber nachschauen.
Zu dem dkms Bug klingt dieser Report sehr passend dkms: does not build modules for all installed kernels. Allerdings steht der leider nur als Wishlist drin.

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
fourfahrt
Titel:   BeitragVerfasst am: 05.03.2011, 13:50 Uhr



Anmeldung: 05. Mar 2011
Beiträge: 55

Hallo,

ich nutze seit gestern Hellfire. Jetzt habe ich nach der Installation des nVidia Treibers das gleiche Problem:
schwarzer Desktop und auch beim eMail Programm Icedove sehe ich nur den Rahmen mit schwarzem Inhalt.
Ich habe zwar immer wieder die verschiedenen Kanotix-Versionen ausprobiert,
bin aber eigentlich noch Neuling.
Wäre schön, wenn mir jemand helfen könnte.

ciao, Benedikt
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
fourfahrt
25 Titel:   BeitragVerfasst am: 05.03.2011, 15:42 Uhr



Anmeldung: 05. Mar 2011
Beiträge: 55

Hallo,
der Desktop ist wieder da, nachdem ich die Arbeitsflächen-Effekte deaktiviert habe.
ciao ,Benedikt Auf den Arm nehmen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.