22.09.2014, 06:02 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
trio3b
Titel: cannot set time in Hellfire  BeitragVerfasst am: 31.03.2011, 08:28 Uhr



Anmeldung: 28. Nov 2006
Beiträge: 9

Cannot set time in taskbar. Tried adjusting in BIOS but KDE keeps changing my BIOS clock (how does it do that?)


error:" Could not authenticate"

Have tried from control center as well - no luck.

Any help
Thanks
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: cannot set time in Hellfire  BeitragVerfasst am: 31.03.2011, 09:17 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

First of all check if you use utc or not in /etc/default/rcS - win defaults to UTC=no, osx to UTC=yes. For win you could use a reghack to force UTC. After all installed systems use the same setting for the bios clock select the correct timezone:

dpkg-reconfigure tzdata

then use ntp to correct the current time:

fix-time

and everything should be perfect. I would not use any kde gui to do that - did not verify where this would write the config (usally /etc/timezone).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
trio3b
Titel: cannot set time in Hellfire  BeitragVerfasst am: 02.04.2011, 07:25 Uhr



Anmeldung: 28. Nov 2006
Beiträge: 9

UTC is yes in rcS

Your solution seems to have worked (at least in LiveCD). Now I will try on installed system.

Thank you Kano
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
gap
Titel: Re: cannot set time in Hellfire  BeitragVerfasst am: 25.05.2011, 11:01 Uhr



Anmeldung: 25. Mai 2011
Beiträge: 18
Wohnort: France
Kano hat folgendes geschrieben::
First of all check if you use utc or not in /etc/default/rcS - win defaults to UTC=no, osx to UTC=yes. For win you could use a reghack to force UTC. After all installed systems use the same setting for the bios clock select the correct timezone:
dpkg-reconfigure tzdata
then use ntp to correct the current time:
fix-time

and everything should be perfect. I would not use any kde gui to do that - did not verify where this would write the config (usally /etc/timezone).


I have the same problem, and cannot modify the file rcS when logged as not root.
Can you tell me as clearly as possible how to do: I am a very beginner and do not understand all, this for example:
""for the bios clock select the correct timezone:
dpkg-reconfigure tzdata
then use ntp to correct the current time:
fix-time""

Thanks
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Re: cannot set time in Hellfire  BeitragVerfasst am: 25.05.2011, 11:09 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

As root you can do:

sed -i 's/\(^UTC\)=.*/\1=no/' /etc/default/rcS
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel: Re: cannot set time in Hellfire  BeitragVerfasst am: 25.05.2011, 18:20 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

Hi gap,

welcome to Kanotix forum. All the magic lines Kano posted here are shell commands. Just open a shell/console (the black icon in panel). To become root just type the command
Code:
su
It will ask you for your root password. Then you can copy and paste these lines (avoids typos). In general most commands can be executed with user priviliges, but change time require root priviliges, thereforce the su before Winken

If you have more questions, don't hesitate to ask here or in IRC.

Regards, TheOne

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
gap
Titel: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 26.05.2011, 12:56 Uhr



Anmeldung: 25. Mai 2011
Beiträge: 18
Wohnort: France
Thanks for your replies, guys.
I did:
su
password
sed -i 's/\(^UTC\)=.*/\1=no/' /etc/default/rcS

But I still cannot change Time zone, nor activate "Set date and time automatically" option. I have an error message: Unable to authenticate/execute the action: 4,

what to do next? Thanks!
gap

_________________
PC -- AMD Athlon 64 3200+ 1,99GHz -- RAM 1GB -- NVIDIA Geforce 6200 -- kanotix64 Hellfire 2.6.38-7


Zuletzt bearbeitet von gap am 27.05.2011, 10:19 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 26.05.2011, 21:05 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

You should use

dpkg-reconfigure tzdata

then

fix-time

do NOT use the gui!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
gap
Titel: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 27.05.2011, 09:47 Uhr



Anmeldung: 25. Mai 2011
Beiträge: 18
Wohnort: France
Time is OK now, thank you. But it would be easier to change it as root in Date & Time - System Settings where all the possibilities are displayed but one cannot use it. Now I would like to activate there Set date and time automatically...

_________________
PC -- AMD Athlon 64 3200+ 1,99GHz -- RAM 1GB -- NVIDIA Geforce 6200 -- kanotix64 Hellfire 2.6.38-7
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 27.05.2011, 10:54 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

The fix-time script sets the time using a ntp server. Usually it is enough to call it sometimes.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 21.06.2011, 20:03 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
Systemsettings/the gui actually works. It says 'could not authenticate action' when trying to change settings
with kdesu Systemsettings but if you make the changes, click apply and then use the back arrow after getting the error message it applies the changes successfully.
I'll use the command line if I get more probs with this.
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
theblackpig
Titel: Re: RE: Re: cannot set time in Hellfire  BeitragVerfasst am: 24.09.2011, 09:47 Uhr



Anmeldung: 22. Sep 2011
Beiträge: 26
Wohnort: Oldham nr Manchester UK
Kano hat folgendes geschrieben::
You should use

dpkg-reconfigure tzdata

then

fix-time

do NOT use the gui!

Had the same problem - sorted -thanks Auf den Arm nehmen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.