19.04.2014, 06:57 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
MadMax
Titel: Geforce-Treiber 8600M GT in Acer-Laptop installieren  BeitragVerfasst am: 07.10.2011, 12:11 Uhr



Anmeldung: 18. Jan 2005
Beiträge: 162

Hi,
hab schon zweimal versucht über Kano´s Scripte den nvidia Treiber
für meine Geforce 8600M GT Karte zu installieren.
Beide male konnte danach KDE nicht starten (Bildschirm bleibt schwarz) egal
ob mit install-nvidia-debian.sh oder screen install-nvidia-debian.sh
An was kann das liegen?
Ob der nvidia Treiber läuft wär mir eigentlich egal, ich kann aber die Auflösung
nicht höher einstellen als 800x600, brauchen würde ich 1280x800
Hier mal die infobash:
CPU[Dual Intel Core2 Duo T7300 @ clocked at Min:1600.000Mhz Max:2001.000Mhz] Kernel[Linux 3.1.0-0301rc9-generic i686] Up[-14min-] Mem[-214.7/2012.6MB-] HDD[-160GB(2%used)-] Procs[-117-] Client[Shell]

infobash -v
Host/Kernel/OS "Laptop" running Linux 3.1.0-0301rc9-generic i686 [ Kanotix Hellfire 20110511-14:43 ]
CPU Info (1) Intel Core2 Duo T7300 @ clocked at [ 2001.000 MHz ]
(2) Intel Core2 Duo T7300 @ clocked at [ 800.000 MHz ]
Videocard nVidia G84 [GeForce 8600M GT] X.Org 1.7.7 [ 800x600 @61hz ]
Processes 117 | Uptime 15min | Memory 214.7/2012.6MB | HDD Size 160GB (2%used) | GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v2.67.2
Danke schon mal für eure Hilfe,
gruss
MadMax
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Geforce-Treiber 8600M GT in Acer-Laptop installieren  BeitragVerfasst am: 07.10.2011, 12:55 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Also es gibt da ne methode, die geht immer, auch wenns mit screen nicht geht:
Code:
rm $(/sbin/modinfo -F filename nouveau)
wget -qNP /tmp http://kanotix.com/files/fix/purge-other-kernels.sh;sh /tmp/purge-other-kernels.sh
update-initramfs -ut
sed -i 's/\(^GRUB_CMDLINE_LINUX_DEFAULT=\).*/\1"quiet"/;s/\(^GRUB_CMDLINE_LINUX=\).*/\1""/' /etc/default/grub
update-grub
reboot

In dem falle wird einfach nouveau gelöscht und alle nicht benützten kernel, weil das gibt auch teilweise probleme, wenn man zuviele drauf hat, wo kein nv aktiv war. Würde man den kernel neu installieren hätte man das modul wieder, aber braucht man ja nicht, das script blacklistet es normal eh. Bringt aber nix, wenns der xserver beim hochfahren lädt, halt bisserl später. Also weg damit... Danach sollte vt1 (ctrl+alt+f1) gehen, und dort
Code:
update-scripts-kanotix.sh
install-nvidia-debian.sh -d

Das "-d" ist praktisch bei laptops, man braucht es nicht, wenn man nur 1 monitor besitzt. Aber laptops haben ja meist nen externen port.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
MadMax
Titel:   BeitragVerfasst am: 12.10.2011, 10:55 Uhr



Anmeldung: 18. Jan 2005
Beiträge: 162

Hi Kano,
hat leider nicht funktionert, hab deine Befehle als root
in der Konsole der Reihe nach eingegeben, lief auch alles durch
doch beim reboot ist nach dem grub Ende, ein blinkender Cursor
auf schwarzer Oberfläche ist alles was nach Grub noch kommt.
Egal ob mit dem Kernel 3.1 oder mit Kernel 3.1 Wiederherstellungsmodus.
Was nun?
danke schon mal für die Hilfe
gruss
MadMax
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 12.10.2011, 15:21 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Das ist mir neu, lad dir mal ein trial iso und boote es mit "gfx on".
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
MadMax
Titel:   BeitragVerfasst am: 13.10.2011, 18:31 Uhr



Anmeldung: 18. Jan 2005
Beiträge: 162

Hi Kano,
hab`s jetzt mal mit hellfire-iso von der homepage versucht gfx-on gewählt und kein kde startet. lediglich die konsolen-oberfläche startet.
gruss
MadMax
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 13.10.2011, 19:16 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Dann müsste man /var/log/Xorg.0.log überprüfen. Ist schon etwas seltsam, hast auch mal 64 bit getestet?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
MadMax
Titel:   BeitragVerfasst am: 14.10.2011, 14:00 Uhr



Anmeldung: 18. Jan 2005
Beiträge: 162

Hi Kano,
hab jetzt die 64bit Version mit gfx on am laufen, nvidia Treiber wird geladen,
alles funzt, super!
Danke für deine Hilfe
gruss
MadMax
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
pintcat
Titel:   BeitragVerfasst am: 19.01.2013, 08:13 Uhr



Anmeldung: 10. Okt 2004
Beiträge: 59

Ähnliches Problem bei mir... Das Bild bleibt zwar nicht schwarz, aber sobald der NVIDIA-Treiber installiert ist, startet X nicht mehr. Habe Kano's Tip weiter oben schon probiert, mit dem selben Ergebnis. Hier mein Xorg.log:

http://pastebin.com/Ly1kZAeT

...und die infobash Ausgabe:
Code:
Host/Kernel/OS "KanotixBox" running Linux 3.2.0-24-generic x86_64 [ Kanotix Hellfire 2012-05 64bit ]
CPU Info        (1) Intel Core i5-3210M @ clocked at 1200.000 MHz
                (2) Intel Core i5-3210M @ clocked at 1200.000 MHz
Videocard       Intel 3rd Gen Core processor Graphics Controller
                NVIDIA GK107 [GeForce GT 640M]
Processes 110 | Uptime 2min | Memory 162.1/7768.3MB | HDD Size 1024GB (4%used) | Client Shell | Infobash v2.67.2


Es ist ein Samsung 700z5c Laptop und wie man sieht, hat er 2 Grafikkarten (unter Windows kann man je nach Anwendung frei wählen). Könnte das die Ursache für das Problem sein?

_________________
Linux 3.13.0-20-generic i686 (Kanotix Dragonfire32 2014-04)
CPU Info: Intel Core2 Quad Q8200 @2.33GHz
Videocard: nVidia G96 GeForce 9500 GT; X.Org 1.15.0 (1280x1024@60hz)
Memory: 4035.6MB; HDD Size: 500GB; GLX Renderer: GeForce 9500 GT/PCIe/SSE2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 19.01.2013, 09:03 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Das ist mit Hellfire unmöglich. Du brauchst den neusten Trialshot:

http://kanotix.acritox.com/

und dann:

http://suwako.nomanga.net/
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
pintcat
Titel:   BeitragVerfasst am: 19.01.2013, 18:40 Uhr



Anmeldung: 10. Okt 2004
Beiträge: 59

Danke, scheint geklappt zu haben. optirun infobash -v sagt:
Code:
Host/Kernel/OS  "nostromo" running Linux 3.5.0-17-generic x86_64 [ Kanotix acritox-TrialShot Dragonfire64 20121015-06:52 ]
CPU Info        (1) Intel Core i5-3210M @ clocked at [ 2501.000 MHz ]
                (2) Intel Core i5-3210M @ clocked at [ 2501.000 MHz ]
Videocard       Intel 3rd Gen Core processor Graphics Controller  X.Org 1.12.3.902  [ 1600x900 ]
                NVIDIA GK107 [GeForce GT 640M]
Processes 136 | Uptime 5min | Memory 524.1/7768.0MB | HDD Size 1008GB (4%used) | GLX Renderer GeForce GT 640M/PCIe/SSE2 | GLX Version 4.2.0 NVIDIA 304.64 | Client Shell | Infobash v2.67.2

Sehe ich das richtig, daß der NVIDIA-Treiber jetzt über das bumblebee-Paket installiert wurde?

_________________
Linux 3.13.0-20-generic i686 (Kanotix Dragonfire32 2014-04)
CPU Info: Intel Core2 Quad Q8200 @2.33GHz
Videocard: nVidia G96 GeForce 9500 GT; X.Org 1.15.0 (1280x1024@60hz)
Memory: 4035.6MB; HDD Size: 500GB; GLX Renderer: GeForce 9500 GT/PCIe/SSE2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 19.01.2013, 20:23 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Ja, genauso soll es sein.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.