16.04.2014, 20:18 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
treasoner
Titel: kdesu startet nicht  BeitragVerfasst am: 06.05.2012, 13:51 Uhr



Anmeldung: 05. Apr 2008
Beiträge: 351
Wohnort: Ruhrgebiet
Hallo Wissende,

ich möchte folgendes installieren:

file:///home/treasoner/Downloads/libmot ... 4_i386.deb

Wenn ich das Paket anklicke, öffnet sich kdesu, bleibt aber nach Eingabe des Root-Pw stehen und kann erst nach längerer Zeit wieder entfert werden.

Wie bekomme ich die Installation gebacken?

Gruß

treasoner
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
krishan1
Titel:   BeitragVerfasst am: 06.05.2012, 14:08 Uhr



Anmeldung: 22. Jul 2005
Beiträge: 225

Als root:
Code:
cd /home/treasoner/Downloads && dpkg -i libmotif3_2.2.3-4_i386.deb

_________________
Subjektivität ("Ich bin") ist ein Parasit auf dem Erleben. Nanavira Thera | Notizen zu Dhamma
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
treasoner
Titel:   BeitragVerfasst am: 06.05.2012, 15:08 Uhr



Anmeldung: 05. Apr 2008
Beiträge: 351
Wohnort: Ruhrgebiet
@ krishan 1

Danke, Hat funktioniert. Leider aber nicht das gewünschte Ergebnis, da für mtt (Teletext) noch mehr Abhängigkeiten bestehen.

Gruß

treasoner
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
krishan1
Titel:   BeitragVerfasst am: 06.05.2012, 16:08 Uhr



Anmeldung: 22. Jul 2005
Beiträge: 225

Wenn die Abhängigkeiten in den Repos sind sollte folgendes helfen:
Code:
apt-get -f install


Wenn nicht musst Du sie irgendwo suchen und alle manuell installieren.

_________________
Subjektivität ("Ich bin") ist ein Parasit auf dem Erleben. Nanavira Thera | Notizen zu Dhamma
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 06.05.2012, 16:54 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16174

Im IRC unter !kdesu oder einfach:

kwriteconfig --file kdesurc --group super-user-command --key super-user-command su
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
treasoner
Titel:   BeitragVerfasst am: 07.05.2012, 09:16 Uhr



Anmeldung: 05. Apr 2008
Beiträge: 351
Wohnort: Ruhrgebiet
Hallo,

ein herzliches Dankeschön an alle, die hier geholfen haben.

Zu meinem Problem "mtt" möchte ich aber noch mitteilen, daß ich "mtt" letztendlich installiert bekommen habe, ich aber nicht genau weiß warum!

Nachdem ich "file:///home/treasoner/Downloads/libmot ... 4_i386.deb "
installiert hatte, kam der Hinweis, daß nun eine andere "libmot" noch installiert werden müsse. Nach Installation wieder der Hinweis auf eine noch zu installierende "libmot" usw.

Dann habe ich aufgegeben und wollte den installierten Mist mit "apt-get remove" wieder entfernen. Das Rödeln begann und am Ende kam ein Hinweis auf "apt-get -f install".

Dieses Kommando habe ich dann eingegeben und die Installation von "mtt" lief durch und ich kann es jetzt problemlos benutzen.

Fazit: Praxis ist, wenn alles funktioniert, und keiner weiß warum!

Gruß

treasoner
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
TheOne
Titel:   BeitragVerfasst am: 07.05.2012, 18:32 Uhr



Anmeldung: 15. Mar 2008
Beiträge: 610

Hallo treasoner,

dass ist doch aber genau das was dir krishan1 gesagt hat, ein "apt-get -f install" wird es richten, solange die fehlenden Abhängigkeiten in den eingetragenen Repositories vorliegen.
Was dieser apt-get Befehl bewirkt ist auch kein Geheimnis. Die Option -f steht für fix-broken und versucht beschädigte Abhängigkeiten zu korrigieren (weiteres in der Manpage "man apt-get").

Gruß TheOne

_________________
Lenovo ThinkPad X220 | Core i7-2640M 16GB | Hellfire 3.6
FSC Tablet T4220 | Core2 Duo T7250 2GHz 3GB | Intel GMA X3100 | Hellfire 3.6
Clevo M570U | Core2 T7200 2GHz 2GB | Geforce Go 7950gtx | Hellfire 3.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
treasoner
Titel:   BeitragVerfasst am: 07.05.2012, 19:39 Uhr



Anmeldung: 05. Apr 2008
Beiträge: 351
Wohnort: Ruhrgebiet
@ TheOne

Hallo,

schon klar. Ich hätte vielleicht deutlicher zum Ausdruck bringen sollen, daß ich das ganze Procedere durchgezogen habe, bevor hier die weiterführenden Hinweise standen. Mit "danke, funktioniert"war die Angelegenheit eigentlich für mich abgeschlossen, dann habe ich aber doch noch etwas weitergefummelt.

Das apt-get -f hat die Maschine dann alleine ausgespuckt und ich habe es einfach gemacht.

Aber durch Deine Erklärung weiß ich jetzt auch, was ich eigentlich gemacht habe. Schön, wieder etwas gelernt.

Gruß

treasoner
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.