17.04.2014, 14:33 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
totschka
Titel: Dragonfire: Initialisierung WinTV PVR-150 schlägt fehl  BeitragVerfasst am: 24.05.2012, 14:06 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 398

Hab mit
Code:
rmmod ivtv -f
modprobe ivtv
dmesg | grep ivtv


das Modul neu geladen und überprüft:

Code:
[ 4250.936989] ivtv: Start initialization, version 1.4.3
[ 4250.937221] ivtv0: Initializing card 0
[ 4250.937228] ivtv0: Autodetected Hauppauge card (cx23416 based)
[ 4250.937514] ivtv 0000:01:08.0: PCI INT A -> Link[APC1] -> GSI 16 (level, low) -> IRQ 16
[ 4251.003414] ivtv0: Autodetected Hauppauge WinTV PVR-150
[ 4251.010173] cx25840 2-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)
[ 4251.055761] wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #0)
[ 4251.103250] ivtv0: Registered device video0 for encoder MPG (4096 kB)
[ 4251.103416] ivtv0: Registered device video32 for encoder YUV (2048 kB)
[ 4251.103487] ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
[ 4251.103554] ivtv0: Registered device video24 for encoder PCM (320 kB)
[ 4251.103620] ivtv0: Registered device radio0 for encoder radio
[ 4251.103626] ivtv0: Initialized card: Hauppauge WinTV PVR-150
[ 4251.103685] ivtv: End initialization
[ 4251.749484] ivtv0: Unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)
[ 4251.749491] ivtv0: Did you put the firmware in the hotplug firmware directory?
[ 4251.749497] ivtv0: Retry loading firmware
[ 4252.378181] ivtv0: Unable to open firmware v4l-cx2341x-enc.fw (must be 376836 bytes)
[ 4252.378189] ivtv0: Did you put the firmware in the hotplug firmware directory?
[ 4252.378196] ivtv0: Failed to initialize on device video32
[ 4252.378571] ivtv0: Failed to initialize on device video24
[ 4252.378926] ivtv0: Failed to initialize on device vbi0
[ 4252.379087] ivtv0: Failed to initialize on device radio0
[ 4252.382003] ivtv0: Failed to initialize on device video24
[ 4252.382075] ivtv0: Failed to initialize on device video32


Will ich TV schauen (analog), können weder VLC noch tvtime das entsprechende Gerät öffnen.
VLC meldet:
Zitat:
Ihre Eingabe konnte nicht geöffnet werden:
VLC kann die MRL 'pvr://' nicht öffnen. Sehen Sie für Details im Fehlerprotokoll nach.


In Hellfire mit Kernel 3.3.1 geht die Karte einwandfrei.

infobash:
Code:
Host/Kernel/OS  "KanotixBox" running Linux 3.2.0-24-generic x86_64
[ Kanotix acritox-TrialShot Dragonfire64+KDE48 20120518-14:32 ]
CPU Info        AMD Athlon 64 3500+ clocked at [ 2200.000 MHz ]
Videocard       NVIDIA GT218 [GeForce 210]  X.Org 1.12.1  [ 1920x1080 @50hz ]
Processes 130 | Uptime 1:34 | Memory 890.4/3954.4MB | HDD Size 1160GB (4%used)
GLX Renderer GeForce 210/PCIe/SSE2 | GLX Version 3.3.0
NVIDIA 295.49 | Client Shell | Infobash v2.67.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
totschka
15 Titel:   BeitragVerfasst am: 24.05.2012, 14:23 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 398

Hab die Lösung gefunden:

Code:
apt-get install firmware-ivtv
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
totschka
Titel:   BeitragVerfasst am: 05.06.2012, 13:35 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 398

Leider tritt beim neu installierten LinuxTag-Preview das gleiche Problem auf und lässt sich nicht mit apt-get install firmware-ivtv lösen. Es kommt dabei die Meldung

Code:
pkg: Fehler beim Bearbeiten von /var/cache/apt/archives/firmware-ivtv_0.35_all.deb (--unpack):
 Versuch, »/lib/firmware/v4l-pvrusb2-24xxx-01.fw« zu überschreiben, welches auch in Paket linux-firmware 1.80 ist
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/firmware-ivtv_0.35_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Deinstalliere ich das Paket linux-firmware, lässt sich firmware-ivtv zwar installieren, löst aber das Problem nicht.

Infobash
Code:
Host/Kernel/OS  "KanotixBox" running Linux 3.2.0-24-generic x86_64 [ Kanotix Dragonfire Preview 2012-05 64bit ]
CPU Info        AMD Athlon 64 3500+ clocked at [ 1000.000 MHz ]
Videocard       NVIDIA GT218 [GeForce 210]     [  ]
Processes 123 | Uptime 2:47 | Memory 930.8/3954.4MB | HDD Size 1160GB (3%used) | Client Shell | Infobash v2.67.2
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.