23.11.2017, 05:50 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
dirkmitt
15 Titel: Jetzt habe ich Spirfire, auf einem Ernsthaften Computer.  BeitragVerfasst am: 26.06.2015, 08:13 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Hallo.

Ich bin zu dem Ergebnis gekommen, daß ich Kanos Empfehlungen folgen sollte, und Spitfire auf einem ersnthaften Computer installieren.

Ich hatte einen uralten Computer, der mir als Web-Server diente, und das Bedenken gibt es ja doch, daß ein Web-Server irgendwann gehackt werden könnte, besonders wenn der nicht auf Aktuellstem Stand gehalten wird.

Also habe ich dessen Festplatte gelöscht, und wie gesagt Spitfire drauf installiert, 64-Bit.

Das heißt auch zunächst, daß meine Web-Seite verschwunden ist, weil ich ja den Computer erst mal wieder neu als Web-Server einrichten muss. Und, im falle Sie Bilder von mir begegnen, die auf meinem Server herausgegeben wurden, lassen die sich auch zunächst nicht besichtigen.

Weil nun mal die Installation bei mir immer ein umfangreiches Projekt ist, kann ich das nicht sofort und auf allen Computern tun. Aber hier habe ich mal weiter gemacht.

Dirk


Zuletzt bearbeitet von dirkmitt am 16.07.2015, 17:45 Uhr, insgesamt 12 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
Titel: Jetzt habe ich Spirfire, auf einem Ernsthaften Computer.  BeitragVerfasst am: 28.06.2015, 00:50 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Der wichtige Computer, auf dem ich den Ratschlag vom Kano gefolgt habe, die Festplatte zu löschen und dort Kanotix / Spitfire zu installieren, ist dadurch instabil geworden. Er friert jetzt sporadisch ein, und zeigt mir zwei Sekunden später einen Bildschirm von grafischem Durcheinander an.

Das scheint in 0.1% aller Fällen zu passieren, wenn ich ein Programm aus dem KDE-Quick-Launcher starte (egal welches Programm), und schient mit dem Grafik-Chip zu tun zu haben. Es passiert nicht wenn ich ihn 2 Tage lang im HIntergrund laufen lasse, mit allen Servern aktiv.

Ich habe den Kernel auf Version 3.18-generic Updated, aber er macht das selbe.

Bei der alten Version von Kanotix die stabil war, gab es mal einen ähnlichen, zeitweiligen Fehler, den ich damals gelöst habe indem ich in der xorg.conf -Datei Direkt-Rendering ('dri') ganz abgestellt hatte. Beim neuen habe ich keine Desktop-Effekte eingeschaltet, die sich auf OpenGL verlassen.

Der Grafik-Chip ist vermutlich ein nVidia 62xx auf der Mobo, aber KInfoCenter zeigt nicht an, welcher Chip das ist ( " Hardware Accelerator: Unknown " ) . Wenn ich versuche nvidia-xconfig auszuführen, entsteht eine xorg.conf , und auch eine Rückfallkopie die leer ist , aber danach startet X nicht mehr. Ich musste also schon mal im Textmodus die leere xorg.conf re-etablieren, wonach der X wieder gestartet ist.

Ich meine der beste, alternative Lösungsweg für mich, war jetzt den Befehl zu geben:

update-alternatives --config glx

Und dann die Option '0' , die auch 'nVidia / Automatik' heißen soll. Das führt bei mir nicht zu einem geladenen nVidia-Treiber, sondern zu einem Modus in dem ich gar keine GLX mehr habe, auch laut 'glxinfo' . Unter der vorherigen Mesa-Alternative hatte ich immer noch etwas an OpenGL.

Aber jetzt hoffe ich daß dieser Computer, der mir bisher nur als Server am dienen war, vielleicht stabil geworden ist. Smilie Und die Gefahr war schon reell, daß man diesen Server beim alten eventuell hätte hacken können.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel: Jetzt habe ich Spirfire, auf einem Ernsthaften Computer.  BeitragVerfasst am: 28.06.2015, 11:48 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Du hast die gabe Probleme auf dir dümmste mögliche Art zu reporten. Ohne Hardwareinfo kann man keine Tips geben. Wenn du Hilfe willst als User (nicht root!) erstmal
Code:
infobash -v

posten!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
22 Titel: Jetzt habe ich Spirfire, auf einem Ernsthaften Computer.  BeitragVerfasst am: 28.06.2015, 11:59 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Ach Ja,

Man kann ja doch feststellen, was man für einen alten Grafik-Chip hat!

Code:

dirk@Phoenix:~$ infobash -v
Host/Kernel/OS  "Phoenix" running Linux 3.18.0-14-generic x86_64 [ Kanotix Spitfire-nightly Spitfire64 150612a KDE-special ]
CPU Info        (1) AMD Athlon 64 X2 Dual Core 5000+ clocked at [ 1800.000 MHz ]
                (2) AMD Athlon 64 X2 Dual Core 5000+ clocked at [ 1800.000 MHz ]
Videocard       NVIDIA C61 [GeForce 6150SE nForce 430]  X.Org 1.16.4  [ 1600x1200 ]
Processes 193 | Uptime 5:21 | Memory 1265.5/1874.1MB | HDD Size 320GB (9%used) | Client Shell | Infobash v2.67.2
dirk@Phoenix:~$


Übrigens: So ganz ohne GLX scheint er im Moment stabil zu sein.

Code:

root@Phoenix:/home/dirk# update-alternatives --config glx
There are 4 choices for the alternative glx (providing /usr/lib/glx).

  Selection    Path                    Priority   Status
------------------------------------------------------------
* 0            /usr/lib/nvidia          100       auto mode
  1            /usr/lib/fglrx           99        manual mode
  2            /usr/lib/fglrx/igpu      90        manual mode
  3            /usr/lib/mesa-diverted   5         manual mode
  4            /usr/lib/nvidia          100       manual mode

Press enter to keep the current choice[*], or type selection number:
root@Phoenix:/home/dirk#


Von der Live DVD lief die 'gfx-detect' Boot-Option nicht (erzeugte einen vermasselten Bildschirm), also ließ ich ihn im Failsafe-Modus laufen, und ließ ich ihn auch aus der Failsafe-Live-Sitzung installieren. Einmal auf der Festplatte, war er oben im Modus '3' gelandet.

Alternatives-Option '0' erzeugt:

Code:

dirk@Phoenix:~$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
dirk@Phoenix:~$


Und...

Code:

dirk@Phoenix:/var/log$ cat Xorg.0.log
[    33.068]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[    33.068] X Protocol Version 11, Revision 0
[    33.068] Build Operating System: Linux 2.6.32.11+drm33.2-kanotix x86_64 Debian
[    33.068] Current Operating System: Linux Phoenix 3.18.0-14-generic #15kanotix1 SMP Wed Feb 18 20:11:30 UTC 2015 x86_64
[    33.068] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.18.0-14-generic root=UUID=651c467b-2836-4bbf-9e84-2f06073105f0 ro quiet splash
[    33.068] Build Date: 19 February 2015  08:33:58PM
[    33.068] xorg-server 2:1.16.4-1kanotix1 (http://www.debian.org/support)
[    33.068] Current version of pixman: 0.32.6
[    33.068]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    33.068] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    33.068] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jun 28 08:20:10 2015
[    33.174] (==) Using config file: "/etc/X11/xorg.conf"
[    33.174] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    33.449] (==) No Layout section.  Using the first Screen section.
[    33.449] (==) No screen section available. Using defaults.
[    33.449] (**) |-->Screen "Default Screen Section" (0)
[    33.449] (**) |   |-->Monitor "<default monitor>"
[    33.479] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    33.479] (==) Automatically adding devices
[    33.479] (==) Automatically enabling devices
[    33.479] (==) Automatically adding GPU devices
[    33.920] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    33.920]    Entry deleted from font path.
[    33.955] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    33.955]    Entry deleted from font path.
[    33.955] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[    33.955]    Entry deleted from font path.
[    33.955] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    33.955]    Entry deleted from font path.
[    33.955] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/100dpi,
        built-ins
[    33.955] (==) ModulePath set to "/usr/lib/xorg/modules"
[    33.955] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    34.024] (II) Loader magic: 0x7feed909ed80
[    34.024] (II) Module ABI versions:
[    34.024]    X.Org ANSI C Emulation: 0.4
[    34.024]    X.Org Video Driver: 18.0
[    34.024]    X.Org XInput driver : 21.0
[    34.024]    X.Org Server Extension : 8.0
[    34.025] (II) xfree86: Adding drm device (/dev/dri/card0)
[    34.026] (--) PCI:*(0:0:13:0) 10de:03d0:103c:2a61 rev 162, Mem @ 0xfb000000/16777216, 0xe0000000/268435456, 0xfc000000/16777216, BIOS @ 0x????????/131072
[    34.076] (II) LoadModule: "glx"
[    34.269] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    36.286] (II) Module glx: vendor="NVIDIA Corporation"
[    36.287]    compiled for 4.0.2, module version = 1.0.0
[    36.287]    Module class: X.Org Server Extension
[    36.369] (II) NVIDIA GLX Module  340.65  Tue Dec  2 09:10:06 PST 2014
[    36.369] (==) Matched nouveau as autoconfigured driver 0
[    36.369] (==) Matched nv as autoconfigured driver 1
[    36.369] (==) Matched nouveau as autoconfigured driver 2
[    36.369] (==) Matched nv as autoconfigured driver 3
[    36.369] (==) Matched modesetting as autoconfigured driver 4
[    36.369] (==) Matched fbdev as autoconfigured driver 5
[    36.369] (==) Matched vesa as autoconfigured driver 6
[    36.369] (==) Assigned the driver to the xf86ConfigLayout
[    36.369] (II) LoadModule: "nouveau"
[    36.424] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    36.702] (II) Module nouveau: vendor="X.Org Foundation"
[    36.702]    compiled for 1.16.0, module version = 1.0.11
[    36.702]    Module class: X.Org Video Driver
[    36.702]    ABI class: X.Org Video Driver, version 18.0
[    36.702] (II) LoadModule: "nv"
[    36.740] (WW) Warning, couldn't open module nv
[    36.740] (II) UnloadModule: "nv"
[    36.740] (II) Unloading nv
[    36.740] (EE) Failed to load module "nv" (module does not exist, 0)
[    36.740] (II) LoadModule: "modesetting"
[    36.741] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    36.846] (II) Module modesetting: vendor="X.Org Foundation"
[    36.846]    compiled for 1.15.99.904, module version = 0.9.0
[    36.846]    Module class: X.Org Video Driver
[    36.846]    ABI class: X.Org Video Driver, version 18.0
[    36.846] (II) LoadModule: "fbdev"
[    36.846] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    36.943] (II) Module fbdev: vendor="X.Org Foundation"
[    36.944]    compiled for 1.15.99.904, module version = 0.4.4
[    36.944]    Module class: X.Org Video Driver
[    36.944]    ABI class: X.Org Video Driver, version 18.0
[    36.944] (II) LoadModule: "vesa"
[    36.944] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    37.021] (II) Module vesa: vendor="X.Org Foundation"
[    37.021]    compiled for 1.15.99.904, module version = 2.3.3
[    37.021]    Module class: X.Org Video Driver
[    37.021]    ABI class: X.Org Video Driver, version 18.0
[    37.021] (II) NOUVEAU driver Date:   Thu Aug 28 03:57:48 2014 +0200
[    37.021] (II) NOUVEAU driver for NVIDIA chipset families :
[    37.021]    RIVA TNT        (NV04)
[    37.021]    RIVA TNT2       (NV05)
[    37.021]    GeForce 256     (NV10)
[    37.021]    GeForce 2       (NV11, NV15)
[    37.021]    GeForce 4MX     (NV17, NV18)
[    37.021]    GeForce 3       (NV20)
[    37.021]    GeForce 4Ti     (NV25, NV28)
[    37.021]    GeForce FX      (NV3x)
[    37.021]    GeForce 6       (NV4x)
[    37.022]    GeForce 7       (G7x)
[    37.022]    GeForce 8       (G8x)
[    37.022]    GeForce GTX 200 (NVA0)
[    37.022]    GeForce GTX 400 (NVC0)
[    37.022] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    37.022] (II) FBDEV: driver for framebuffer: fbdev
[    37.022] (II) VESA: driver for VESA chipsets: vesa
[    37.022] (++) using VT number 7

(...)



Frage:

Wenn ich jetzt einfach so die Befehle geben würde

init 4
apt-get install nvidia-legacy-304xx-driver
init 6

Würde mir das wegen Konflikt mit der Version 340.65 alles vermasseln? Müsste ich die Version 340.65 erst mal deinstallieren?


Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
19 Titel: Ich habe jetzt ein großes Problem!  BeitragVerfasst am: 28.06.2015, 15:47 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Ich habe versucht den Legacy-nVidia-Treiber zu installieren, indem ich die Befehle gab

apt-get purge nvidia-*
apt-get install nvidia-legacy-304xx-driver

Dieser Treiber ließ dann aber den X-Server gar nicht mehr starten. Also habe ich versucht meinen Fehler rückgängig zu machen, indem ich zunächst befohl

apt-get purge nvidia-*
apt-get install nvidia-driver

was 17 Pakete wieder-installieren ließ.

Jetzt startet der X-Server wieder, aber ich hatte zuerst nur eine Bildschirm-Auflösung von 1024x768 , obwohl mein Monitor 1600x1200 kann. Diese Eigenschaft scheint mit in das initramfs gebunden zu sein.

Wie kann ich diesen Fehler wieder beseitigen?

Antwort: Ich habe vorübergehend gegeben

cd /etc/default
cp grub grub.bak
edit text/*:grub

und dann

GRUB_GFXMODE=1600x1200,1280x1024,1024x768,800x600
GRUB_GFXPAYLOAD_LINUX=keep

update-grub

Nur um den Schaden wieder zu beseitigen. Es mag zwar nicht ganz korrekt so sein, aber es war schon nicht korrekt, daß die echte Auflösung von meinem Monitor nicht erkannt werden konnte, als ein update-initramfs von innerhalb einer Script ausgeführt wurde.

Wo ich jetzt die Config-Datei von dem initramfs , Kernel-Version 3.18 sehe, fällt mir auf:

#
# Frame buffer Devices
#
CONFIG_FB=y
CONFIG_FIRMWARE_EDID=y
CONFIG_FB_CMDLINE=y
CONFIG_FB_DDC=m
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
# CONFIG_FB_CFB_REV_PIXELS_IN_BYTE is not set
CONFIG_FB_SYS_FILLRECT=m
CONFIG_FB_SYS_COPYAREA=m
CONFIG_FB_SYS_IMAGEBLIT=m
# CONFIG_FB_FOREIGN_ENDIAN is not set
CONFIG_FB_SYS_FOPS=m
CONFIG_FB_DEFERRED_IO=y
CONFIG_FB_HECUBA=m
CONFIG_FB_SVGALIB=m
# CONFIG_FB_MACMODES is not set
CONFIG_FB_BACKLIGHT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_TILEBLITTING=y


Der Schlüssel ' CONFIG_FB_CMDLINE=y ' scheint in der Config-Datei, für initramfs , Kernel-Version 3.16 , nicht vorhanden zu sein.


Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
totschka
Titel: Ich habe jetzt ein großes Problem!  BeitragVerfasst am: 28.06.2015, 20:09 Uhr



Anmeldung: 27. Jun 2007
Beiträge: 409

Die Form der Beiträge ist meines Erachtens für eine Supportanfrage unpassend. Das passt eher in eine Roman.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel: Ich habe jetzt ein großes Problem!  BeitragVerfasst am: 28.06.2015, 22:58 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
du machst dir alles viel zu kompliziert.
die live-cd ohne gfx starten.
wenn dein alter computer nur als server dient, wozu brauchste dann die nvidia-treiber.
nimm doch wenn du nicht bescheid weisst die irc-befehle.
das ergebnis aus den irc-befehle im idealfall nur den befehl oder die befehle(getrennt durch ; ) komplett aus den chat in die konsole kopieren. chaten ist nicht notwendig.
installierte nvidia entfernen mit
!nvdebrm
anschliessend noch um alte config zu löschen.
Code:
apt-get autoremove --purge

rechner neu starten.
wenn du dann undedingt den nv brauchst, frag aber lieber nochmal ob es der richtige ist für deine grafikkarte.
!nv304deb
bedienung der irc-befehle hier.
http://kanotix.com/index.php?module=pnW ... IRCChannel
evtl. ist dieser beitrag für dich noch wichtig.
http://kanotix.com/PNphpBB2-viewtopic-t-27687.html
start mit nomodeset - siehe hier.
http://kanotix.com/index.php?module=pnW ... tParameter
für nvidia - nur bis kernel 3.18 - siehe hier
http://kanotix.com/PNphpBB2-viewtopic-t-27668.html
was ist ein ersnthaften Computer? Mit den Augen rollen

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel: Ich habe jetzt ein großes Problem!  BeitragVerfasst am: 29.06.2015, 00:03 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Niemand hat dir gesagt mit update-alternatives einzuspielen. Des ist Blödsinn bei der uralten onboard Nvidia. Ohne special ISO hätte

!nv304deb

Gelangt, mit musste vorher aber

!nvdebrm
!amddebrm
Code:
apt-get autoremove --purge


Den kernel updaten war auch nicht nötig. Erzählt keine Romane, sondern mach einfach was ich sage.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
15 Titel: Ich habe jetzt ein großes Problem!  BeitragVerfasst am: 29.06.2015, 01:44 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Kano,
Sie Sind Ein Genie!

Ich habe glatt getan was Sie gesagt haben, und es hat 100% geklappt! Der Legacy-nVidia-Treiber läuft bei mir jetzt.
Ich habe einfach getan was man aus dem IRC-Zimmer fand, als ich !nvdebrm und !nv304deb fragte. Und das hat funktioniert.
!amddebrm brauchte ich nicht mehr tun, weil es sich in meinen Versuchen schon entfernt hatte.

Ich konnte auf Sie im Moment nicht im IRC antworten, weil ich nicht zu hause war. Sie haben mir aber den Weg gezeigt, weil ich Sie um Hilfe gefragt hatte, und Sie haben mir genau damit geholfen, was ich vorhatte.

Danke Noch Mal!
Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
15 Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 01.07.2015, 22:46 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Ich bedanke mich bei Ihnen, wegen Ihrer geduldigen Hilfe.

Die Konfiguration von dem Computer, den ich 'Phoenix' nenne, ist nahezu perfekt, mit dem nVidia-Treiber 304.125 , und sehr stabil, wie es ja für einen Server sein sollte. Und, weil der Grafik-Chip jetzt eingerichtet ist, kann ich ihn auch als PC verwenden, was ja bei der alten Kanotix-Version nicht mehr möglich war.

Ich entschuldige mich, daß ich nicht sofort Ihren Ratschlägen gefolgt habe. Aber ich kann mir nicht in allen Fällen sicher sein, daß der andere so zuverlässig ist wie Sie. Ich habe es aber bei Ihnen jetzt begriffen.

Das einzige Problem das ich noch hatte, war daß die Liste von Start-Befehlen dort zu groß geschrieben stand, u.a. abhängig von dem 'initramfs' , das ja problemlos neu hergestellt wurde. Bei der Neuinstallation wurde diese Fortschritt-Liste auch in kleinen Buchstaben angezeigt, so daß man Fehler deutlicher bemerken konnte - die momentan nicht stattzufinden scheinen. Speziell möchte ich wissen, ob Dateisystem beim Mount sauber waren oder nicht, wegen abgebrochenen Sitzungen.

(Edit)

Was ich zu entziffern meine, ist daß seit dem älteren nVidia-Treiber "Plymouth" kaputt ist. Die GRUB-Option

GRUB_GFXMODE=1280x1024,1280x720,1024x768,1024x576,800x600

scheint zu funktionieren, indem sie die Auflösung von den GRUB-Menü selber bestimmt. Aber wenn ich mit der Option

GRUB_GFXPAYLOAD_LINUX=keep

versuche die Auflösung von Plymouth anzupassen, scheint der zu scheitern, und zwar so, daß dann auch von dem Text nur die ersten zwei (unbedeutsamen, verbosen) Zeilen angezeigt wurden.

Wenn ich diese zweite Option auskommentiere, läuft Plymouth zwar, aber nur in 640x480 und mit dem grafischem Text-Motiv, nicht mit dem Kanotix-Motiv. Und wenn ich Plymouth dabei abbreche, erscheinen die Text-Angaben zwar vollständig, aber auch zu groß geschrieben und zu-schnell- vorbei-raschend, daß man sie lesen könnte.

Aber, wenn X einmal startet, erkennt er endlich die echte Auflösungen von meinem Monitor, und verwendet er wieder eine 'normale' Auflösung - sprich 1600x1200 .

(Edit)

Mit !splash-off habe ich das Problem jetzt auch gelöst.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
besenmuckel
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 02.07.2015, 13:07 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
Zitat:
Text-Angaben zwar vollständig, aber auch zu groß geschrieben

ja das ist so richtig mit installierten nv. ob sich hier mal was ändert weiss ich nicht. Plymouth ist nicht kaputt. zuständig wäre nvidiafb.
hatte unter kanotix-hellfire mal mit uvesa probiert, um eigene plymouth-themen zu testen. auch um in der konsole eine höhere auflösung für links2(browser für konsole) zu haben, wenn x mal nicht laufen sollte. dies funktionierte auch. aber durch viele expiremente hatte ich irgendwann keine ausgabe mehr und ich musste blind tippen, das war schlimmer.
die boot-meldungen und andere logs findest du im verzeichnis /var/log/

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 02.07.2015, 22:10 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Gut. Dann habe ich jetzt wieder Ihrem Vorschlag gefolgt, und meine eigene Editierungen von

GRUB_GFXMODE=

und

GRUB_GFXPAYLOAD_LINUX=

wieder auskommentiert, und das vorgeschlagene aus dem IRC-Zimmer, das man unter !splash-on findet, ausgeführt. Nur damit ich nicht in das Risiko stoße, mir irgendwann etwas zu vermasseln. Smilie

Zuletzt ist mir dazu aufgefallen, daß bei dem vorgeschlagenen !splash Befehl, gleich der Befehl

plymouth-set-default-theme -R kanotix-logo

mit drinnen war. Und auch ist ein update-initramfs mit drinnen. Das habe ich jetzt auch getan. Aber er zeigt mir bei der Auflösung von 640x480, nach einem Neustart, nach wie vor das Text-Thema an, und nicht das Kanotix-Thema...

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 03.07.2015, 01:43 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Der Befehl ist für die nachträgliche Aktivierung gedacht gewesen - als wir von Splashy zu Plymouth gewechselt haben. Ist seit Jahren default - ausser du hast den Splash geändert. Der Splash an sich wird nur angezeigt, wenn "spash" als Option vorkommt, das schaltet !splash-on bzw. !splash-off um. Es berücksichtigt aber nicht gfxdetect.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 04.07.2015, 14:58 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Kano,

Gehen Sie denn auch davon aus, das auf meinem Spitfire-Computer 'Phoenix' inzwischen 'gfxdetect' gar nicht mehr installiert ist? Es ist nicht mehr installiert, weil es das Zurück-Rollen von meinem nVidia-Treiber per 'apt-get' raus-geschmissen hat. Und, 'gfxdetecxt' hängt von zusätzlichen Grafik-Treibern ab, die für meinen Computer gar nicht zutreffend sind. Kann es denn sein, daß das Kanotix-Plymouth-Thema auf gfxdetect irgendeine ausdrückliche Abhängigkeit hat?

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 04.07.2015, 17:59 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Gfxdetect hat nur ne Abhängigkeit von nem neueren Nvidia Treiber. Normalerweise deaktiere ich aber den Splash, wenn gfxdetect aktiv ist.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 05.07.2015, 17:13 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Es kann sein daß mir etwas sehr dummes passiert ist. Das Plymouth-Thema könnte das korrekte (Kanotix-) sein, aber menschlich kann es mir dem Aussehen nach unrichtig vorkommen, besonders wo ich ja die Eigenschaft habe es beim booten sofort auszublenden.

Fehler habe ich keine gefunden.

Und, wo die Grafik ja jetzt 100% stabil zu sein scheint, stört mich auch der Splash nicht. Weil irgendein Splash startet, muss es sein daß Plymouth tatsächlich läuft - halt nur mit 640x480 .

Inzwischen habe ich ein OpenVPN erneut eingerichtet, und weil ich mich schon mit solchen Themen befasse, soll es nicht mehr richtig als irgendeine Supportanfrage zählen, sollte doch das falsche Splash erscheinen.

Aber danke noch mal, wegen der Hilfe.

Es war zu einem Zeitpunkt mit dieser Kiste "Phoenix / Spitfire" so, daß sie wegen den zwei GRUB-Zeilen - und wegen einem fehlgeschlagenen Versuch von mir den Treiber zurück zu rollen - zwar eine Auflösung von 1600x1200 angenommen hatte, aber mit einer Bildwiederholfrequenz von 77Hz . Das durfte am höchsten 60Hz sein, und in dem Modus erwies der Monitor, der nur analog per VGA angeschlossen ist, schon starke Beeinträchtigung der Bildqualität. Wahrscheinlich war es dann noch 16-Bit.

Aber dieser Zustand wurde andermal von dem X-Server so angenommen, ohne daß mir KDE irgendwelche erhältliche Auflösungen angezeigt hat.

Wo mir also Besenmuckel schon gesagt hat, es war ihm mal passiert daß er gar kein Bild mehr zu sehen bekam und blind tippen musste, wäre mir dieser Zustand irgendwann toll schief gegangen. Wo ich mal gefragt wurde, wieso es bei einem Server wichtig sei, daß auch die Grafik eingerichtet ist.

So wie es jetzt steht zeigt mir aber KDE wieder eine Reihe von erhältliche Bildschirmauflösungen an, und bei 60Hz, mit gutem Bild.

Sie haben mir also meinen Computer gerettet! Smilie

Code:

dirk@Phoenix:~$ glxinfo
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float,
    GLX_ARB_multisample, GLX_EXT_create_context_es2_profile,
    GLX_EXT_create_context_es_profile, GLX_EXT_swap_control,
    GLX_EXT_swap_control_tear, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_NV_float_buffer,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGI_swap_control,
    GLX_SGI_video_sync
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float,
    GLX_ARB_get_proc_address, GLX_ARB_multisample,
    GLX_EXT_create_context_es2_profile, GLX_EXT_fbconfig_packed_float,
    GLX_EXT_framebuffer_sRGB, GLX_EXT_import_context, GLX_EXT_swap_control,
    GLX_EXT_swap_control_tear, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_NV_copy_image,
    GLX_NV_float_buffer, GLX_NV_multisample_coverage, GLX_NV_present_video,
    GLX_NV_swap_group, GLX_NV_video_capture, GLX_NV_video_out,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGI_swap_control,
    GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float,
    GLX_ARB_get_proc_address, GLX_ARB_multisample,
    GLX_EXT_create_context_es2_profile, GLX_EXT_swap_control,
    GLX_EXT_swap_control_tear, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_NV_float_buffer,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGI_swap_control,
    GLX_SGI_video_sync
OpenGL vendor string: NVIDIA Corporation                                       
OpenGL renderer string: GeForce 6150SE nForce 430/integrated/SSE2               
OpenGL version string: 2.1.2 NVIDIA 304.125                                     
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler             
OpenGL extensions:                                                             
    GL_ARB_ES2_compatibility, GL_ARB_color_buffer_float,                       

(...)


Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
dirkmitt
22 Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 12.07.2015, 17:23 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Was ich inzwischen gelernt habe, ist daß ich eine Datei habe die sich

/etc/initramfs-tools/modules

nennt, wo ich die Module 'drm' und 'nvidiafb' angeben müsste, damit das Problem mit Plymouth echt gelöst wäre. Dort stehen nämlich im Moment gar keine Module geschrieben.

Ich nehme mal an, daß die Befehle den aktuellen nVidia-Treiber zu deinstallieren, bevor ich die Befehle verwendet habe um den Legacy-Treiber zu installieren, irgendwann diese Datei ausgeräumt haben.

Weil mir aber Besenmuckel spezifisch geraten hat, damit sehr vorsichtig zu sein, lasse ich es lieber so, mit

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

in /etc/default/grub

Mir viel es übrigens auf, während zuletzt die Kanotix-Pakete libfglrx und die DKMS-Kernelmodule für FGLRX von Kanotix einen Update bekamen, daß diese Pakete bei mir noch installiert waren. Also hatte ich jetzt die Wahl, denen entweder einen Update geben zu lassen, oder sie ganz zu löschen, wo ich ja ausschließlich den nVidia-Chip habe. Bei einem Update kommt dazu, daß die Konfiguration nach-gearbeitet wird, und die Gefahr, daß deswegen vielleicht FGLRX bei mir aktualisiert werden könnte. Also entschied ich mich dieses Modul zu löschen, anstatt den Update auszuführen.

Dabei gab mir Synaptic aber die Meldung, daß das Modul geladen war, bevor ich es gelöscht habe, und führte die Nachbearbeitung einen 'depmode' -Befehl, scheinbar erfolgreich aus.

Ich nehme mal sehr hoffnungsvoll an, daß mir das Nichtvorhandensein dieses Moduls zukünftig keine Probleme macht. Das Modul könnte ganz einfach geladen gewesen sein, aber ohne viel zu bewirken, weil ja bei mir der Legacy-nVidia-Treiber herrscht.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 12.07.2015, 18:28 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Das kommt davon, wenn man immer alles besser wissen will! drm brauchst garantiert nicht!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 12.07.2015, 19:23 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Was kommt denn davon? Scheinbar habe ich versagt zu tun:

!amddebrm

Bis jetzt scheint diese Fahrlässigkeit von mir aber noch keine Konsequenzen gehabt zu haben. Und wenn ich den Befehl jetzt ausführen würde, würde mir der nur noch 'xorg.conf' löschen, was durch !nv304deb prima eingerichtet wurde.

Hier noch mal:

Code:

dirk@Phoenix:~$ lsmod | grep nvidia
nvidia              11364411  44
drm                   317577  2 nvidia
dirk@Phoenix:~$ locate nvidiafb
/lib/modules/3.18.0-14-generic/kernel/drivers/video/fbdev/nvidia/nvidiafb.ko
dirk@Phoenix:~$


Daraus geht hervor, daß 'nvidiafb' nicht geladen ist. Bevor ich aber versuchen würde, das Modul in die initramfs -Konfiguration einzubinden, könnte ich mal naiv probieren

modprobe nvidiafb

Sollte das irgendwelche Probleme verursachen, stört es mir höchstens eine Sitzung. Ansonsten dürfte sich das Modul laden lassen.

Im Moment möchte ich mich aber nicht darum kümmern, weil ich Plymouth bestimmt nicht brauche.

Und was 'drm' angeht, laufen auf dieser Maschine die Desktop-Effekte, in den KDE-Einstellungen "mit OpenGL 2" gewählt, bestens und stabil...

Meinten Sie, ich brauch 'drm' nicht in die Datei

/etc/initramfs-tools/modules

einbinden? Na ja, wenn ich irgendwann den Befehl

modprobe nvidiafb

ausprobiert habe, und die Sitzung noch stabil sein sollte, kann ich ja noch mal

lsmod | grep nvidia

ausprobieren, und dann sehe ich schon, ob 'nvidiafb' irgendwelche Abhängigkeit auf 'drm' hat oder nicht.

Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 12.07.2015, 22:24 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

Normalerweise ändert sich die initrd eh nicht, wenn du die Datei ändert. Wie willst du die aktualisieren?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel: Es gibt nur noch eine Kleinigkeit in der Konfiguration...  BeitragVerfasst am: 12.07.2015, 22:56 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
zu nvidiafb siehe hier.
https://wiki.ubuntuusers.de/Konsolen-Aufl%C3%B6sung
wenn du eine höhere auflösung für die konsole willst und plymouth nicht brauchst - schaue dir diese anleitung an.
http://forums.debian.net/viewtopic.php?f=5&t=59149
meine auflösung mit installierten nvidia-treibern in der konsole ist jetzt 1280x1024(bei mir max. mögliche mit uvesafb), das reicht mir die grosse schrift hat mich auch gestört. unter kde habe ich 1920x1080.

_________________
probieren geht über studieren
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
dirkmitt
15 Titel:   BeitragVerfasst am: 13.07.2015, 15:30 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

Ich bedanke mich wegen der Hilfe.

Übrigens: Ich würde niemals meinen, diese Sachen noch besser zu verstehen wie Sie.

Kano: Das initrd wurde aktualisiert, als Teil der Befehle !nvdebrm und !nv304deb . Und ich verstehe auch, daß ich es aktualisieren sollte, wenn ich an dem Boot-Vorgang etwas ändere, was nach dem GRUB kommt, und kommt bevor X gestartet wird. Was ich nie getan habe.

So wie es jetzt aber steht, habe ich nur noch mal geprüft daß sich mein Spitfire-PC wieder booten lässt, wegen dem verspätet-gelöschtem 'fglrx' Zeug. Und er startet normal, zeigt mir einen vollständigen Arbeitsplatz an, und zeigt ihn mir gleichbleibend mit OpenGL 2 Effekten an.

Das ist für mich schon ein Erfolg.

Wegen 'uvesafb' habe ich mich nicht weiter bemüht, weil mir das alles zu gefährlich vorkommt. Es kann ja schließlich zu einem Computer führen, der gar nicht mehr startet, wenn man das alles nicht genau richtig macht. Und im Moment habe ich schon so viel in diese Installation investiert - an Mühe und Zeit - was ich alles nicht mehr verlieren will, wenn ich ihn noch mal komplett installieren müsste.

Im Moment scheint bei mir Plymouth aus einem Grund oder dem anderen nicht zu laufen, aber das ist mir dann doch nicht wichtig.


Was mich an der jetzigen Lage von Plymouth stört - wobei ich mir vieles einbilden kann - ist daß er doch nur in der Lage ist das Text-Thema anzuzeigen, nicht das Kanotix-Thema, und ich habe die Eigenschaft schnell auf <Esc> zu drücken, um Plymouth auszublenden. Ob er mir danach Text-Messages anzeigt oder nicht, scheint davon abzuhängen, wie spät ich bei der Animierung der drei Rechtecke auf <Esc> gedrückt habe. Wenn also z.B. das dritte Rechteck schon heller geworden ist, bevor ich auf <Esc> gedrückt habe, zeigt er mir Text an. Wenn das 2. Rechteck noch nicht heller geworden ist, zeigt er mir keinen Text an. Wenn danach X ein mal startet, kann ich aber immer noch mit <Strg>+<Alt>+<F1> ein Konsol-Bildschirm bekommen, mit den großen Buchstaben...

Ich habe den Verdacht, das könnte irgendwas damit zu tun gehabt haben, wie der Befehl !nvdebrm das initrd aktualisiert hat.


Ich weiß nicht , ob die folgende Information über mein 'initramfs' in Ordnung ist oder nicht. Ich entschuldige mich, daß ich das nicht weiß. Und ich wüsste auch nicht, wie es so geworden ist, im Falle es so nicht stimmt, weil ich sehr wenig auf der Level des Betriebssystems konfiguriert habe:

Code:

dirk@Phoenix:~$ cd /etc/initramfs-tools
dirk@Phoenix:/etc/initramfs-tools$ ls
conf.d  initramfs.conf  scripts                update-initramfs.conf.bak
hooks   modules         update-initramfs.conf
dirk@Phoenix:/etc/initramfs-tools$ cat modules
# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
dirk@Phoenix:/etc/initramfs-tools$ find scripts
scripts
scripts/init-bottom
scripts/init-premount
scripts/init-top
scripts/local-bottom
scripts/local-premount
scripts/local-top
scripts/nfs-bottom
scripts/nfs-premount
scripts/nfs-top
dirk@Phoenix:/etc/initramfs-tools$ find conf.d
conf.d
dirk@Phoenix:/etc/initramfs-tools$ find hooks
hooks
dirk@Phoenix:/etc/initramfs-tools$



Hat das denn seine Richtigkeit?


Danke noch mal,
Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
besenmuckel
Titel:   BeitragVerfasst am: 13.07.2015, 23:35 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1035
Wohnort: Wolfenbuettel
du kannst die meldungen vom boot auch nachträglich anschauen mit
Code:
su
cat /var/log/messages

in dieser ausgabe steht mehr als man beim boot normal sieht. die ausgabe kann man weiterleiten an grep und hier mit suchbegriff mount werden nur die zeilen mit den suchbegriff angezeigt. bei suchbegriff mit leerzeichen - suchbegriff in anführungszeichen setzen. bei einem wort nicht erforderlich.
Code:
su
cat /var/log/messages | grep "mount"

das gleiche hier an beispiel mit dmesg
Code:
dmesg | grep mount

p.s. durch kanos hinweis less durch cat ersetzt.

_________________
probieren geht über studieren


Zuletzt bearbeitet von besenmuckel am 14.07.2015, 12:11 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 14.07.2015, 10:24 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16583

less/grep kombiniert man nicht. man könnte cat/grep nehmen oder bei grep die datei gleich als option angeben. nebenbei: initrd änderungen, wie du sie vorhattest werden nur nach generierung einer neuen initrd aktiv. nvidiafb wäre aber total hinrissig, weil des ist eh blacklisted (drm eh, des ist nur ne depend für oss treiber). ich frag mich echt, woher du immer den ganzen unfung herhast, also ich habs dir nicht gesagt. es ist immer wieder toll, dass du meine befehle nicht komplett ausführst sondern denkst, dass was du alleine herausgefunden hast ist die bessere lösung. du kannst davon ausgehen, dass ich das system in und auswendig kenne. was denkst, warum es so heisst, wie es heisst? Bei systemd basierten systemen (also ab Spitfire) hast übrigens noch: journalctl - es ist definitiv NICHT nötig einen splash zu deaktivieren.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
dirkmitt
23 Titel: Re: Es gibt nur noch eine Kleinigkeit in der Konfiguration..  BeitragVerfasst am: 14.07.2015, 19:10 Uhr



Anmeldung: 18. Okt 2006
Beiträge: 184

besenmuckel hat folgendes geschrieben::
zu nvidiafb siehe hier.
https://wiki.ubuntuusers.de/Konsolen-Aufl%C3%B6sung
wenn du eine höhere auflösung für die konsole willst und plymouth nicht brauchst - schaue dir diese anleitung an.
http://forums.debian.net/viewtopic.php?f=5&t=59149
meine auflösung mit installierten nvidia-treibern in der konsole ist jetzt 1280x1024(bei mir max. mögliche mit uvesafb), das reicht mir die grosse schrift hat mich auch gestört. unter kde habe ich 1920x1080.


Hallo,

Ich habe mich jetzt mal dafür interessiert, den uvesafb-Treiber einzurichten, weswegen ich den Anleitungen in den Artikel, der vorgeschlagen wurde, sehr genau gefolgt habe:

https://wiki.ubuntuusers.de/Konsolen-Aufl%C3%B6sung

Es steht ja, man darf eigentlich ~nvidiafb~ nicht mit den Propietären Treibern verwenden. nvidiafb ist auf der Black-Liste, aber 'uvesafb' ist es nicht.

Ich habe also die Pakete installiert, das Kernelmodul in

/etc/initramfs-tools/modules

eingetragen, und update-initramfs -u noch mal ausgeführt.

Dazu habe ich aber den Vorschlägen auch gefolgt, die Option erst mal durch die Editierung von dem Boot-Menü auszuprobieren, bevor ich sie in

/etc/default/grub

fest einbinde, und dann noch mal

update-grub

befehle.

Was sich dadurch aber herauszustellen scheint, ist daß das uvesafb -Kernelmodul zwar geladen wird, aber nicht verwendet wird. Im Verzeichnis /dev gibt es jetzt ein Framebuffer-Device namens ' /dev/fb0 ' , das vorher nicht vorhanden war. Aber mit dmesg erhalte ich folgendes:

Code:

dirk@Phoenix:~$ dmesg | grep uvesa
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.18.0-14-generic root=UUID=651c467b-2836-4bbf-9e84-2f06073105f0 ro quiet splash video=uvesafb:mode_option=1280x1024
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.18.0-14-generic root=UUID=651c467b-2836-4bbf-9e84-2f06073105f0 ro quiet splash video=uvesafb:mode_option=1280x1024
[    4.179670] uvesafb: NVIDIA Corporation, MCP61 - mcp61-80, Chip Rev   , OEM: NVIDIA, VBE v3.0
[    4.266037] uvesafb: VBIOS/hardware doesn't support DDC transfers
[    4.266039] uvesafb: no monitor limits have been set, default refresh rate will be used
[    4.266732] uvesafb: scrolling: redraw
[    4.337472] uvesafb: framebuffer at 0xe0000000, mapped to 0xffffc90004800000, using 24576k, total 131072k
dirk@Phoenix:~$


D.h., die Auflösung der Konsol-Bildschirme, durch <Strg>+<Alt>+<F1> usw haben sich nicht geändert, es wird immer noch kein Splash angezeigt, und die Optionen 12800x1024 wie auch 1280x1024-24 werden ignoriert. Es wird aber durch

hwinfo --framebuffer

angezeigt, daß 1280x1024-24 erhältlich sein sollte:

Code:

root@Phoenix:/home/dirk# hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.jdKLir8C32D
  Hardware Class: framebuffer
  Model: "NVIDIA MCP61 - mcp61-80"
  Vendor: "NVIDIA Corporation"
  Device: "MCP61 - mcp61-80"
  SubVendor: "NVIDIA"
  SubDevice:
  Revision: "Chip Rev"
  Memory Size: 128 MB
  Memory Range: 0xe0000000-0xe7ffffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits                                         
  Mode 0x0317: 1024x768 (+2048), 16 bits                                       
  Mode 0x0318: 1024x768 (+4096), 24 bits                                       
  Mode 0x031a: 1280x1024 (+2560), 16 bits                                       
  Mode 0x031b: 1280x1024 (+5120), 24 bits                                       
  Mode 0x0330: 320x200 (+320), 8 bits                                           
  Mode 0x0331: 320x400 (+320), 8 bits                                           
  Mode 0x0332: 320x400 (+640), 16 bits                                         
  Mode 0x0333: 320x400 (+1280), 24 bits                                         
  Mode 0x0334: 320x240 (+320), 8 bits                                           
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Mode 0x0345: 1600x1200 (+1600), 8 bits
  Mode 0x0346: 1600x1200 (+3200), 16 bits
  Mode 0x0347: 1400x1050 (+1400), 8 bits
  Mode 0x0348: 1400x1050 (+2800), 16 bits
  Mode 0x0352: 2048x1536 (+8192), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown
root@Phoenix:/home/dirk#


Im Konsol-Bildschirm bekomme ich von links nach rechts 64 Buchstaben in eine Zeile.

Wahrscheinlich habe ich die Optionen von diesem Kernelmodul nicht richtig durchgegeben.

Könnte mir jemand bitteschön Rat geben, wie ich die Optionen richtig formatieren muss, bevor ich sie falsch-formatiert in /etc/default/grub eintrage?

Code:

dirk@Phoenix:~$ dmesg | grep fb0
[    0.195167] pci 0000:00:0d.0: reg 0x10: [mem 0xfb000000-0xfbffffff]
[    4.337473] fb0: VESA VGA frame buffer device
dirk@Phoenix:~$



Dirk
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.