26.09.2018, 03:57 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
voigf
Titel: gelöst --- Fehlermeldung nach Installation Steelfire  BeitragVerfasst am: 06.06.2018, 16:22 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Text gelöscht!


Zuletzt bearbeitet von voigf am 11.06.2018, 19:04 Uhr, insgesamt 3 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Antonius
23 Titel:   BeitragVerfasst am: 06.06.2018, 22:37 Uhr



Anmeldung: 20. Jul 2010
Beiträge: 85

Schau mal hier:
https://kanotix.com/PNphpBB2-viewtopic-t-27896.html

P.S.: Hast du zum Installieren ein aktuelles ISO (nightly) genommen?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 07.06.2018, 17:57 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Hallo Antonius,
vergiss meinen Beitrag. Habe einen Fehler bei den Installationsschritten gemacht! Verlegen
Asche auf mein Haupt!!
Der Beitrag weist einige Unsauberkeiten auf. So sind die Fehlermeldungen NICHT während der Systeminstallation aufgetreten (was man aus meinem Text schließen kann), sondern bei der anschließenden Installation der Upgrade-Packages.
Nochmals Entschuldigung für diesen übereilten Beitrag!! (Panik) Am liebsten würde ich ihn löschen!!! Ist das machbar??
Aber vielen Dank für deinen Tipp und deine Unterstützung.

Gruß, voigf

P.S. Richte gerade ein neu installiertes Steelfire ein. Bisher fehlerfrei. Sollte etwas passieren, melde ich mich. Mit den Augen rollen
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
conchy
Titel:   BeitragVerfasst am: 07.06.2018, 19:26 Uhr



Anmeldung: 23. Jun 2005
Beiträge: 345
Wohnort: El Coronil (Sevilla)
Ja, nur Du selber kannst löschen
Rechts unten "edit" kannst Du löschen, bei Deinen Eintrag


Zuletzt bearbeitet von conchy am 07.06.2018, 22:59 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 07.06.2018, 19:32 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Bei der Installation 'apt-get install firmware-linux-free' zeigte sich folgende Fehlermeldung:
Zitat:
Vormals nicht ausgewähltes Paket firmware-linux-free wird gewählt.
(Lese Datenbank ... 175040 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../firmware-linux-free_3.4_all.deb ...
Entpacken von firmware-linux-free (3.4) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/firmware-linux-free_3.4_all.deb (--unpack):
Versuch, »/lib/firmware/usbduxsigma_firmware.bin« zu überschreiben, welches auch in Paket linux-firmware 1.174 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/firmware-linux-free_3.4_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ignorieren? Oder hat jemand einen Tipp?????
OS: Steelfire 64
Danke im Voraus.
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
retabell
Titel:   BeitragVerfasst am: 08.06.2018, 04:29 Uhr



Anmeldung: 04. Sep 2006
Beiträge: 188

voigf hat folgendes geschrieben::
Bei der Installation 'apt-get install firmware-linux-free' zeigte sich folgende Fehlermeldung:

Du kannst dieses Paket nicht installieren, warum auch
bei Kanotix ist
Code:
apt-get install  linux-firmware

installiert.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 08.06.2018, 16:41 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Ich wusste nicht, dass linux-firmware die Versionen -free und nonfree beinhaltet. Verlegen
-nonfree wird auch als installiert angezeigt. Habe mal geschlussfolgert Mit den Augen rollen

Danke für den Hinweis.
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 08.06.2018, 16:52 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

conchy hat folgendes geschrieben::
Ja, nur Du selber kannst löschen
Rechts unten "edit" kannst Du löschen, bei Deinen Eintrag


Danke für den Hiweis.
Gruß nach Sevilla. Ist eine wunderschöne Stadt. Habe beste Erinnerungen!!
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 08.06.2018, 23:05 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Stoße während der Einrichtung von Programmen des (OS 'Steelfire') auf folgende Fehlermeldung:
Zitat:
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
libxmu6 : Beschädigt: libxmu6:i386 (!= 2:1.1.2-2) aber 2:1.1.2-1 ist installiert
libxmu6:i386 : Beschädigt: libxmu6 (!= 2:1.1.2-1) aber 2:1.1.2-2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).


root@KanotixBox:/var/cache/apt/archives# apt --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
The following additional packages will be installed:
libxmu6:i386
Die folgenden Pakete werden aktualisiert (Upgrade):
libxmu6:i386
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 62,6 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 22,5 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 175572 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libxmu6_2%3a1.1.2-2_i386.deb ...
Entpacken von libxmu6:i386 (2:1.1.2-2) über (2:1.1.2-1) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libxmu6_2%3a1.1.2-2_i386.deb (--unpack):
Versuch, gemeinsam benutztes »/usr/share/doc/libxmu6/changelog.Debian.gz« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libxmu6:i386 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libxmu6_2%3a1.1.2-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@KanotixBox:/var/cache/apt/archives#

Wie muss ich vorgehen, um die Fehler zu eliminieren? Weiß jemand Rat??
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 09.06.2018, 07:27 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16631

Woher hast du die Version 1.1.2-1 von dem Paket?!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 10:34 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Dummerweise aus dem I-Net (Debian-Softwares).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 10:35 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Sollte ich vielleicht noch einmal Steelfire neu installieren?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 09.06.2018, 11:40 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16631

Das ist jetzt nicht nötig aber man sollte sowas nicht manuell installieren, bei multiarch Systemen muss die 32 und 64 bit Version gleich sein. Im Repo gibt es nur die neuere. Wennst unbedingt willst lad dir beide als deb und installiere die gleichzeitig. Über apt-get wäre das mit Stable eigentlich gar nicht möglich dieses Problem zu haben. Es wäre klug mal zu erklaren, was du eigentlich machen wolltest...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 12:08 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Habe das .deb-Programm runtergeladen und dann per dpkg installiert!
Deinen Vorschlag der gleichzeitigen Installation werde ich versuchen.
Ich melde mich wieder!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 12:55 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Zitat:
Im Repo gibt es nur die neuere. Wennst unbedingt willst lad dir beide als deb und installiere die gleichzeitig.

Wie sollte ich vorgehen, um mir die .deb-Dateien runterladen?
Apt-get-Installation endet in Fehlermeldung:
Zitat:
root@KanotixBox:/home/gvoigt/Downloads/Knoppix# apt-get install libxmu6 libxmu6:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libxmu6 ist schon die neueste Version (2:1.1.2-2).
Die folgenden NEUEN Pakete werden installiert:
libxmu6:i386
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 6 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 62,6 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 141 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Vormals nicht ausgewähltes Paket libxmu6:i386 wird gewählt.
(Lese Datenbank ... 175570 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../libxmu6_2%3a1.1.2-2_i386.deb ...
Entpacken von libxmu6:i386 (2:1.1.2-2) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libxmu6_2%3a1.1.2-2_i386.deb (--unpack):
Versuch, gemeinsam benutztes »/usr/share/doc/libxmu6/changelog.Debian.gz« zu überschreiben, welches verschieden von anderen Instanzen des Paketes libxmu6:i386 ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libxmu6_2%3a1.1.2-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Das oben angezeigte Paket hatte ich mit dpkg -p entfernt. Jetzt will ich nichts verschlimmbessern. Darum die Frage, wie gehe ich weiter vor.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 19:21 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Hallo Kano,
weil mir die Zeit etwas wegläuft, habe ich Steelfire noch einmal installiert.

Beim 1. Bootvorgang nach der Installation erhalte ich folgende Fehlermeldung:
Zitat:
error: file '/boot/grub/i386-pc/normal.mod' not found.
Entering rescue mode...
grub rescue>


Was muss ich machen, um den Rechner wieder ans Laufen zu bringen???
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 09.06.2018, 21:32 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16631

Du hast mehr als eine HD und grub eher nicht auf die installiert, die du vorher benützt hast.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 21:45 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Kann sein. Werde neu installieren auf anderer Partition, HD ist die gleiche.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
retabell
Titel:   BeitragVerfasst am: 09.06.2018, 22:03 Uhr



Anmeldung: 04. Sep 2006
Beiträge: 188

Zitat:
error: file '/boot/grub/i386-pc/normal.mod' not found.
Entering rescue mode...
grub rescue>


Ich denke da ist bei der install was falsch gelaufen,
installier halt nochmal, funktioniert hat es ja wohl mal.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 09.06.2018, 22:56 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Hallo Kano, hallo retabell,
ich habe die Installation mit ehemals genutzten (in den Größen veränderten) Partitionen durchgeführt und ERFOLG!!!
Jetzt wird für mich das Fehlerbild auch etwas klarer, da ich Grub jedesmal in die Root-Partition schreiben ließ und dessen Partitionszuordnung keinerlei Beachtung schenkte. Bootaufrufe an Grub mussten somit ins Leere laufen.
Danke für den Tipp und eure Hilfe. Morgen geht' s wieder an das Installieren der Anwenderprogramme. Drückt mir die Daumen.
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 10.06.2018, 17:31 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Erneute Fehlermeldung bei Installation von Anwendersoftware.
Zitat:
/opt/officebib/officebib.bin: error while loading shared libraries: libXmu.so.6: cannot open shared object file: No such file or directory

Geladen sind überdie Installation Steelfire hinaus:
- libglu1-mesa:i386

dpkg --print-foreign-architectures meldet i386

Jetzt will ich nicht erneut was verkehrt machen.
Wie mache ich jetzt weiter?
voigf
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
besenmuckel
Titel:   BeitragVerfasst am: 10.06.2018, 19:18 Uhr



Anmeldung: 28. Mar 2004
Beiträge: 1052
Wohnort: Wolfenbuettel
voigf hat folgendes geschrieben::
Erneute Fehlermeldung bei Installation von Anwendersoftware.

Welche Anwendersoftware hast du installiert?
Deine Anwendersoftware die du installiert hast ist bestimmt ein fremdes Paket und nicht ein Paket mit apt installiert. Den Pfad der libXmu.so.6 siehste z. B. auch hier.
https://packages.debian.org/search?searchon=contents&keywords=libXmu.so.6&mode=filename&suite=stable&arch=any
Auch bei mir gibt es das Verzeichnis /opt/officebib/ nicht nur das Verzeichnis /opt/libreoffice6.0/. Auch finde ich kein Paket was diesen Pfad benutzt, du musst die Anwendersoftware wieder entfernen. Wenn als deb-Paket installiert dann entfernen mit
Code:
apt-get remove Anwendersoftware

entfernen mit Einstellungen
Code:
apt-get remove --purge Anwendersoftware

hast du das selber kompiliert und installiert z. B. mit make install, dann in das Verzeichnis gehen dort die uninstall o. ä. aufrufen um die Anwendersoftware zu entfernen.
Wenn es nur an den falschen Pfad der libXmu.so.6 liegt würde auch reichen einen Link zur Datei anlegen.
Fremde Pakete können dein System zerstören bzw. unbrauchbar machen!

_________________
probieren geht über studieren


Zuletzt bearbeitet von besenmuckel am 10.06.2018, 20:59 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 10.06.2018, 20:58 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16631

Ne, er braucht das Paket mit :i386 über apt-get. Falls es tatsächlich ein deb Paket (Duden?) wäre, dann würde
Code:
apt-get install -f

auslangen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
voigf
Titel:   BeitragVerfasst am: 10.06.2018, 22:55 Uhr



Anmeldung: 21. Dez 2017
Beiträge: 37

Nein, keine .deb-Datei. Habe tar.gz-Datei entpackt und per dpkg installiert.

Der Versuch libXmu.so.6 per Softlink nach /opt/officebib zu legen scheiterte.
Zitat:
root@KanotixBox:/home/gvoigt# officebib
/opt/officebib/officebib.bin: error while loading shared libraries: libXmu.so.6: wrong ELF class: ELFCLASS64

Sollte ich jetzt die i386-Version aus
https://packages.debian.org/stretch/libxmu6
holen, installieren und nach /opt/officebib softlinken??
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 11.06.2018, 18:03 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16631

einfach:
Code:
apt-get install libxmu6:i386
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.