25.10.2014, 11:28 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
eagle
Titel: scsi-dvdlaufwerk und dma  BeitragVerfasst am: 17.05.2006, 15:24 Uhr



Anmeldung: 02. Jun 2004
Beiträge: 29

Hallo,

bei meinem scsi-dvdlaufwerk ist dma nicht aktiviert, mit der folge, dass das abspielen von dvds ruckelt.

hdparm -d1 /dev/hdc sagt: funktion not permitted...

Im bios kann ich nichts weiter einstellen. "dma" beim grub-aufruf bringt auch nichts.
Als treiber wird ata_piix angegeben.

Was kann ich da machen?

Danke und Gruß

Jens

_________________
Acer 5670, ATI X1400, ipw3945, KUbuntu, Kanotix-20xx
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel: scsi-dvdlaufwerk und dma  BeitragVerfasst am: 17.05.2006, 15:54 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Frage ist den DVD nun SCSI oder ATA(IDE)?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mork
Titel:   BeitragVerfasst am: 17.05.2006, 16:37 Uhr



Anmeldung: 01. Apr 2005
Beiträge: 67

Hi!

Ich habe mit meinem Notebook (Dell Latitude D810) dasselbe (?) Problem.

Google findet dazu u.a. dies:
Zitat:
Several drives are available with this laptop. They are attached to an Intel ICH6M SATA controller running in "combined mode", which means that they can either be accessed through a standard IDE driver or through the ata_piix SATA driver. The latter is very much recommended, as the standard IDE driver has no way to enable DMA on the CD/DVD interface.

To do that, you must use a proper recent kernel (mine is 2.6.14) and add this to your boot command line in grub.conf:

ide1=noprobe libata.atapi_enabled=1

The corresponding device will be /dev/sr0, you may need to add the appropriate link in /dev:

ln -s /dev/sr0 /dev/cdrom


--> http://gentoo-wiki.com/HARDWARE_Dell_Latitude_D800
--> http://www.debianforum.de/forum/viewtopic.php?p=395775&

Hoffentlich liege ich nicht vollkommen daneben...Verlegen
Ich habe erst nächste Woche wieder Zeit zu basteln, eventuelle Erfolge melde ich dann...Misserfolge auch!

Gruß,
mork
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 17.05.2006, 17:08 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Deshalb kam ja meine Frage nach SCSI oder IDE oder SATA, einfach zu wenige infos zur berwbndeten HW sondern zuviel(überflüssig) zum Fehler selbst.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eagle
Titel:   BeitragVerfasst am: 17.05.2006, 19:47 Uhr



Anmeldung: 02. Jun 2004
Beiträge: 29

Also, danke für die Unterstützung.

Wenn ich das richtig sehe, wird das LW normal über ide eingebunden und ist dann als hdc ansprechbar, aber nicht mit hdparm.

Wenn ich ide1 ausschalte, wird es als scsi eingebunden und ist dann als scd0 ansprechbar, aber auch nicht mit hdparm und nach wie vor ohne dma.
dmesg:
ata2: dev 0 ATAPI, max UDMA/33
ata2(0): applying bridge limits
ata_acpi_push_id: skipping for PATA mode
ata2: dev 0 configured for UDMA/33
pata_get_dev_handle: ENTER: dev->bus_id='0000:00:1f.2'
pata_get_dev_handle: dev_handle: 0xdffe1960, parent_handle: 0xdffea9e0
pata_get_dev_handle: for dev=0x1f.2, addr=0x1f0002, parent=0xdff5a400, *handle=0xdffe1960
do_drive_get_GTF: drive w/ adr=0: v: 0xdffe0420
scsi1 : ata_piix
Vendor: MATSHITA Model: DVD-RAM UJ-845S Rev: D201
Type: CD-ROM ANSI SCSI revision: 05
1:0:0:0: Attached scsi generic sg1 type 5
pata_get_dev_handle: ENTER: dev->bus_id='0000:00:1f.2'
pata_get_dev_handle: dev_handle: 0xdffe1960, parent_handle: 0xdffea9e0
pata_get_dev_handle: for dev=0x1f.2, addr=0x1f0002, parent=0xdff5a400, *handle=0xdffe1960
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI: CPU1 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Processor [CPU1] (supports 8 throttling states)
ACPI: Thermal Zone [THRM] (54 C)
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda caddy
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0
ReiserFS: sda7: found reiserfs format "3.6" with standard journal

Was nun, hat einer eine Idee?

Gruß Jens

_________________
Acer 5670, ATI X1400, ipw3945, KUbuntu, Kanotix-20xx
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 17.05.2006, 21:07 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Ja dein DVD ist zwar ein IDE-gerät aber der Falsche Treiber für IDE. Und dazu noch das alte 40Polige Kabel.
Wenn du das Tauschst, geht DMA zu 90%
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eagle
Titel:   BeitragVerfasst am: 17.05.2006, 22:03 Uhr



Anmeldung: 02. Jun 2004
Beiträge: 29

Evtl. auch ein Problem mit dem im Kernel 2.6 verwendeten libata-Treiber!?

(Unter Win läuft das geht dma)

_________________
Acer 5670, ATI X1400, ipw3945, KUbuntu, Kanotix-20xx
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 17.05.2006, 22:53 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

ja doch. win macht persee eben doch kein DMA. Selbst wenn es im Bios eingestellt ist.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 20.05.2006, 13:40 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
Ich klnk mich auch mal hier ein!

Hab das selbe Problem, unter Win geht DMA unter Linux nicht...häng also nicht an irgendwelchen Kabeln!!!!

Mein Notebook: Acer Aspire 5652

dmesg:
Code:
8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 100000K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide0: I/O resource 0x1F0-0x1F7 not free.
ide0: ports already in use, skipping probe
Probing IDE interface ide1...
hdc: MATSHITADVD-RAM UJ-845S, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hdc: ATAPI 24X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
3ware Storage Controller device driver for Linux v1.26.02.001.
3ware 9000 Storage Controller device driver for Linux v2.26.02.007.
libata version 1.20 loaded.
ata_piix 0000:00:1f.2: version 1.05
ACPI: PCI Interrupt 0000:00:1f.2[B] -> GSI 19 (level, low) -> IRQ 193
ata: 0x170 IDE port busy
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0x18B0 irq 14



als root ...

hdparm -i /dev/hdc
Code:
/dev/hdc:

 Model=MATSHITADVD-RAM UJ-845S, FwRev=D201, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2
 AdvancedPM=no
 Drive conforms to: Unspecified:  ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6

 * signifies the current active mode



hdparm -d1 /dev/hdc
Code:

/dev/hdc:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)



Ist schon irgendeiner in der Sache weiter gekommen?[/code]
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 20.05.2006, 15:25 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

@udatt, bei dir ist es kein Wunder, du hast ein MagnetoOptical drive, und keine saubere ATAPI-Implementation im LW. Neue Frimware für MATSHITADVD-RAM UJ-845S fällig.

Danke auch für die ausf. HWinfos
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 21.05.2006, 00:16 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
@schnorrer

Und wo bekomm ich die her?
Hab heute mal ne Stunde gegooglet aber nix brauchbares gefunden aus das die Firma ne OEM-Firma von Panasonic sein soll
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 21.05.2006, 11:45 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

panasonic ist die Tochtergesellschaft von Matsushita . bekommst du die Firmware nicht dort, link nach *** und dort mal nachsehen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 21.05.2006, 14:32 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
@schnorrer

Bei Panosonic finde ich auf anhieb nichts und auf der angebenen Seite finde ich nur die D100 und D101 Firmware, wo ich weder weiß ob ich die dafür benutzen kann und ich weis auch nicht wie das Laufwerk angeschloßen ist (Master/Slvae/Cable) Der Bios vom Lappi ist ja extrem bescheiden.

Will mir halt ungern das Laufwerk zerschießen
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 21.05.2006, 20:59 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Haha ein Lappi!? Hättest es gleich schreiben können, sieh bei **censored** mal nachob die ne neue Firmware haben, oder einen Link.

zecks firmware die auf dem LW ist. K3b hilft mit den Infos Einstellungen von K3b Geräte zeigt dir die passenden Dinge
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 21.05.2006, 21:27 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
@schnorrer

Eigentlich hab ich ja alles geschrieben!

1.
udatt hat folgendes geschrieben::
Mein Notebook: Acer Aspire 5652


2. Hab schon auf der Seite geguckt, für das LW UJ-845s gibt es nur die D100 oder die D101 für Toshiba OEMs
udatt hat folgendes geschrieben::

Bei Panosonic finde ich auf anhieb nichts und auf der angebenen Seite finde ich nur die D100 und D101 Firmware,


3. Die Firmware ist D201
udatt hat folgendes geschrieben::
Model=MATSHITADVD-RAM UJ-845S, FwRev=D201



Die Frage ist, ob ich das Laufwerk downgraden soll (auf D100), und ob es mit der Firmware läuft?
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 21.05.2006, 21:38 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

downgrade geht meist nicht! Hersteller verrigelt es bim FW-Update. Böse
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 21.05.2006, 21:58 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
Dann heißt es wohl warten, wie bei so vielen Hardwaresachen, bis die FW besser unterstütz wird, solange kann ich meine DVDs halt nur mit 1x beschreiben Traurig
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 21.05.2006, 23:17 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16275

Oder nen firewire dvd brenner nehmen - usb ginge auch. 8x ist damit meist drin.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 22.05.2006, 10:43 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Der orginalposter hat ein Optical-MO-Ram, das auch DVDs kann.

Kano hat Recht mit einem kauf eines DVD-Brenners.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
udatt
Titel:   BeitragVerfasst am: 22.05.2006, 11:11 Uhr



Anmeldung: 26. Apr 2005
Beiträge: 70
Wohnort: WW
Ne, werd mir jetzt nicht extra nen anderen Brenner holen, dann boote ich halt mal nach Win um wenns wirklich sein muss.
Ein externer wär mir eh nicht so lieb, das Zeug muss ich ja auch immer alles mit schleppen wenn ich unterwegs bin.

PS. Aber "eagle" hat laut seinem dmesg den selben Brenner in seinem Dell
 
 Benutzer-Profile anzeigen Private Nachricht senden ICQ-Nummer 
Antworten mit Zitat Nach oben
eagle
Titel:   BeitragVerfasst am: 22.05.2006, 14:57 Uhr



Anmeldung: 02. Jun 2004
Beiträge: 29

Da ich z. Zt. auch Suse 10.1 teste, wo der Fehler auch auftritt, habe ich das Problem dort mal als Bug gemeldet!

Mal sehen, ob denen was einfällt. Mit kernelpatch ist es einigen ja wohl gelungen, das Problem in den Griff zu bekommen.

Auf jeden Fall haben viele das Problem, wenn man mal so rumgooglet.

MfG Jens

_________________
Acer 5670, ATI X1400, ipw3945, KUbuntu, Kanotix-20xx
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mork
Titel:   BeitragVerfasst am: 23.05.2006, 13:12 Uhr



Anmeldung: 01. Apr 2005
Beiträge: 67

Hi,

ich bin nun mal oben genannter Anleitung gefolgt, und:
DVD's ruckeln nicht mehr!!!

hdpram funktioniert bei scsi-platten/laufwerken wohl nicht wirklich, scheint aber auch gar nicht notwendig zu sein.

Eine fehlerhafte DVD lief jetzt viel weiter als unter Windows...

gruß,
mork

edit:
bis jetzt muß ich das Laufwerk immer per Hand mounten und unmounten, aber das wird schon... vielleicht weiß ja wer einen AUsweg?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
schnorrer
Titel:   BeitragVerfasst am: 23.05.2006, 17:53 Uhr



Anmeldung: 09. Jan 2006
Beiträge: 1721

Trag das LW in die /etc/fstab ein und autmount geht bei eingelegter CD oder DVD

Ein MO ist was was man besser nicht benützen sollte, solange der Hersteller kein Treiber rausrückt.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.