23.07.2014, 11:36 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
sebstey
Titel: [keine Verbindung]W-LAN-Problem mit WPA (PSK-Modus)  BeitragVerfasst am: 27.05.2006, 09:45 Uhr



Anmeldung: 27. Mai 2006
Beiträge: 5

Hallo,

für nen erfolgreichen Einstieg in die Kanotix-Welt fehlt mir noch der w-lan Zugang an meinem Notebook (Toshiba Satellite M30X, Centrino).

Ich habe W-Lan per netcardconfig konfiguriert.
Dabei habe ich auch den WPA-Schlüssel des AccessPoints (im Router) angegeben.

Mein Problem ist jetzt folgendes:

Code:
iwlist wireless0 s

zeigt mir meinen AccessPoint an (die ESSID ist dabei kleingeschrieben).

Ein
Code:
pump -i wireless0

bleibt ohne Erfolg ("Operation failed.")

Nach meinem Verständnis ist das aber auch normal. Es wurde ja noch keine Verbindung zu dem AccessPoint hergestellt. Dann kann er ja vermutlich auch nicht den DHCP ansprechen.

Muss ich jetzt also erst irgendwie zu dem AccessPoint verbinden, bevor ich das Interface pumpen kann, oder liegt mein Problem nur beim WPA?

/etc/networking/interfaces
Zitat:

iface wireless0 inet dhcp
wireless-mode Managed
wireless-essid SEBSTEY
pre-up wpa_supplicant -Dwext -iwireless0 -c/etc/wpa_supplicant.conf -B


/etc/wpa_suppilcant.conf
Zitat:

ctrl_interface/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid="SEBSTEY"
#psk="schlüssel"
psk=schluessel(hex)
}


Danke!

Das ganze spielt sich übrigens auf kanotix-2005-04 ab.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
guido17
Titel:   BeitragVerfasst am: 28.05.2006, 08:33 Uhr



Anmeldung: 07. Jun 2005
Beiträge: 252

Hi,

wie hast Du den Schlüssel in hex erstellt?
Das musst Du mit wpa_passphrase machen. Weitere Infos man wpa_passphrase, oder nochmal expliziter fragen.
Bei netcardconfig erwartet er den Schlüssel im Klartext.


Gruss Guido

Schau auch mal ins Wiki
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
sebstey
Titel:   BeitragVerfasst am: 28.05.2006, 11:23 Uhr



Anmeldung: 27. Mai 2006
Beiträge: 5

Die wpa_supplicant.conf wurde von netcardconfig erstellt. Der Eintrag ist der selbe, wie wpa_passphrase ihn erstellt.

Beim booten gibts noch nen "Failed to bring up wireless0", nachdem er keine DHCPOFFERS kriegt.

"ifconfig" gibt mir nur lo als interface aus.
Erst wenn ich "ifconfig wireless0" ausführe, wird mir wireless0 auch angezeigt. Hat das was wichtiges zu bedeuten?

Wenn ich in wpa_cli arbeite, gibt "status" immer "wpa_state=SCANNING" aus. Außer wenn ich vorher explizit disconnecte. Nach einem "reassociate" gehts dann wieder in SCANNING.
Kann ich eine Ausgabe kriegen, weshalb er nur scanned und nicht verbinden kann?

"iwconfig wireless0" sagt unassociated und gibt als ESSID "SEBSTEY" an. Nur zur Sichert: die ESSID hier meint die vom AP, oder? Oder hält meine wlan-Karte sich selbst für das Gerät mit ESSID "SEBSTEY"?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
sebstey
Titel:   BeitragVerfasst am: 28.05.2006, 15:04 Uhr



Anmeldung: 27. Mai 2006
Beiträge: 5

Für alle, die es interessiert:

Das Problem lag nur daran, dass ich die ESSID in den Konfugartionsdateien groß geschrieben habe. Den wiki-Einträgen habe ich das so entnommen, aber unbedingt hilfreich scheint das nicht zu sein Winken

Jetzt sieht es hier sehr gut aus.
Scheint alles zu laufen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.