18.04.2014, 12:56 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
PaulchenPlump
Titel: ReinerSCT pinpad und die chipcard-tools  BeitragVerfasst am: 16.07.2006, 07:43 Uhr



Anmeldung: 24. Nov 2004
Beiträge: 95
Wohnort: Chemnitz
Hallo Kano-Jünger,

es scheint mir Zeit, meinen ReinerSCT cyberJack pinpad unter Kanotix in Betrieb zu nehmen. Nur geht dies wieder mal nicht ohne Probleme. Traurig
Installiert habe ich das ctapi-cyberjack_2.0.10-1_i386.deb von der Reiner-Webseite und das Gerät wird auch automatisch erkannt. Anschließend habe ich die chipcard-server und -client angepasst und den libchipcard2-tools per init.d gestartet.

Wenn ich nun auf zb. mit chipcard-tool check auf den Reader zugreifen möchte kommt folgende Meldung:
Code:
  Readers:
  - auto1-cyberjack (cyberjack, port 0, ): error
Event log:
08:20:24 Reader listing
08:20:27 Reader error (Unknown error code)

Und in der auto1-cyberjack.log steht:
Code:
5:2006/07/16 08-20-27:auto1-cyberjack(11547):driver.c: 1516: Init reader auto1-cyberjack
5:2006/07/16 08-20-27:auto1-cyberjack(11547):driverctapi.c:  796: Initializing CTAPI driver with 0, 1 (0001)
3:2006/07/16 08-20-27:auto1-cyberjack(11547):driverctapi.c:  803: Could not init reader "auto1-cyberjack" at port 1 : -127
3:2006/07/16 08-20-27:auto1-cyberjack(11547):driver.c: 1523: Could not connect reader auto1-cyberjack (-127: Unknown error code)
5:2006/07/16 08-20-27:auto1-cyberjack(11547):driver.c: 1561: Reader start handled
5:2006/07/16 08-20-58:auto1-cyberjack(11547):driverctapi.c:  842: Disconnecting reader auto1-cyberjack
5:2006/07/16 08-20-58:auto1-cyberjack(11547):driverctapi.c:  285: Calling dataFn
5:2006/07/16 08-20-58:auto1-cyberjack(11547):driverctapi.c:  293: Returned from dataFn (-1)
3:2006/07/16 08-20-58:auto1-cyberjack(11547):driverctapi.c:  296: CTAPI error on "CT_data": -1
3:2006/07/16 08-20-58:auto1-cyberjack(11547):driverctapi.c:  860: Could not deinit reader "auto1-cyberjack"
4:2006/07/16 08-20-58:auto1-cyberjack(11547):driver.c: 1979: Could not disconnect reader


Zusätzlich erscheint auf der Konsole noch folgende Meldung, bei der ich nicht mal weiß, ob sie etwas damit zu tun hat - und wenn ja was:
Code:
startXlib: connection to ":0.0" refused by server
Xlib: No protocol specified
Klingt als wollte irgendetwas ein Display öffnen, habe aber den Prozess in der Konsole mit sux gestartet...

Habe schon im Internet gesucht, aber noch nichts brauchbares gefunden - jetzt seit ihr meine Rettung. Vielleicht fällt euch was ein oder ihr hattet/habt das gleiche Problem?!

Ciao, PaulchenPlump

PS: Sollte eigentlich kein PS sein - Happy Birthday Kano, danke für dein Linux und dein unermüdliches Arbeiten daran!
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.