20.10.2017, 03:18 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
markb
Titel: vmware won't start today?  BeitragVerfasst am: 15.09.2006, 03:14 Uhr



Anmeldung: 09. Aug 2004
Beiträge: 121
Wohnort: Brisbane Australia
I'm running the latest kano kernel kernel-2.6.17.13-kanotix-2 and my system is up to date. As of recently(?), vmware workstation fails to start with nothing more than the messages:

% vmware
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
%

Running vmware-any-any-update104/runme.pl does not change this. That script normally fixes up vmware after I upgrade my kanotix kernel etc.

I'm not sure what broke vmware? I probably last used vmware only a week ago. Anybody else with an up-to-date kanotix system seeing (or not seeing) this problem?


Zuletzt bearbeitet von markb am 15.09.2006, 04:32 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
markb
Titel: RE: vmware won  BeitragVerfasst am: 15.09.2006, 04:04 Uhr



Anmeldung: 09. Aug 2004
Beiträge: 121
Wohnort: Brisbane Australia
After a bit of googling I found my own solution. So for the next jockey ....

Seems libdbus-1-3 was auto installed yesterday in parallel with libdbus-1-2 and vmware was having a problem with this (the messages above are a harmless other issue). I removed the libdbus-1-2 package and vmware started fine. There were a couple of apps on my system dependent on libdbus-1-2 (xchat and bluez-pin) but I didn't use either of them so let them be deleted as well.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Roughnecks
25 Titel: RE: vmware won  BeitragVerfasst am: 15.09.2006, 09:53 Uhr



Anmeldung: 13. Dez 2004
Beiträge: 730
Wohnort: Deutschland
Solution:

open /usr/lib/vmware/lib/wrapper-gtk24.sh as root.
search for the lines
Code:
 vm_run() {
    local exitCode;


add:

Code:
   # Fix for vmplayer pulling in libdbus-1.so.2 instead of .3
   export LD_PRELOAD=/usr/lib/libdbus-1.so.3:$LD_PRELOAD


so your new /usr/lib/vmware/lib/wrapper-gtk24.sh looks like this:

Code:
# Run "$binary" while watching its progress on its stderr.
vm_run() {
   local exitCode;

   # Fix for vmplayer pulling in libdbus-1.so.2 instead of .3
   export LD_PRELOAD=/usr/lib/libdbus-1.so.3:$LD_PRELOAD

   # Append any libraries that are still missing.
   if [ "$VMWARE_USE_SHIPPED_GTK" = 'force' ]; then


now you can have installed libdbus-1-2/3 at the same time and vmware will run, too.

_________________
Kanotix 2006-1 RC4 (daily dist-upgraded)
Deutsches Kanotix Wiki - English Kanotix Wiki
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
wegface
Titel:   BeitragVerfasst am: 15.09.2006, 12:49 Uhr



Anmeldung: 02. Nov 2005
Beiträge: 127

Works a treat- thank god for that! hehe
If anyones regged at vmware forum might want to post the solution there:
http://www.vmware.com/community/thread. ... p;tstart=0
(edit- i added the fix to the forum meself)
hehe they havnt figured it out yet i dont think....
Nice one roughnecks!

_________________
Linux user 403389 and Herbaholic Trichopath
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Cathbard
Titel:   BeitragVerfasst am: 16.09.2006, 17:32 Uhr
Artist
Artist


Anmeldung: 11. Aug 2005
Beiträge: 451
Wohnort: Australia
Thanks heaps Roughnecks, I had the same problem. All better now. Sehr glücklich

_________________
Cathbard.com
The real pirates by Courtney Love
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
eislon
Titel:   BeitragVerfasst am: 21.09.2006, 13:31 Uhr



Anmeldung: 18. Apr 2006
Beiträge: 17

Yes it works again now... I just get keep one message : /usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

but vmware console runs now... thanks.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen ICQ-Nummer 
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.