25.07.2014, 13:30 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
mab82
Titel: glut fehler?  BeitragVerfasst am: 27.10.2006, 07:57 Uhr



Anmeldung: 26. Okt 2006
Beiträge: 22

hi

wollte anfangen opengl unter meiner kanotix installation zu programmieren leider erfolglos.
er konnte keine GL/glut.h finden meint der compiler und deshalb konnte er das program nicht kompilieren.
Habe michdann auf die such gemacht bei debian.org nach denn packages.
habe versucht xlibmesa und libglut zu installieren leider erfolglos.
bei apt-get install xlibmesa3 bekam ich abhängigkeitsprobleme sowie bei libglut3.



aber ich will programmieren mit der opengl API aber wie?
ps: bin neuling in sachen linux etc.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
slh
Titel:   BeitragVerfasst am: 27.10.2006, 11:15 Uhr



Anmeldung: 16. Aug 2004
Beiträge: 1905

Code:
apt-get update
apt-get install build-essential freeglut3-dev
und vermutlich noch ein paar weitere Abhängigkeiten.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mab82
Titel:   BeitragVerfasst am: 27.10.2006, 18:48 Uhr



Anmeldung: 26. Okt 2006
Beiträge: 22

hi danke dür deine hilfe aber bin amverzweifeln.
ich will doch nur etwas installieren um die openGL API zu benutzen zu können, ich glaube ich bin zu blöd.

Das ist die Fehlermeldung:
test.c:1:21: error: GL/glut.h: Datei oder Verzeichnis nicht gefunden

Und wenn ich das mache was du geschrieben hast dann kam folgende meldung:
build-essential: Hängt ab: gcc (>= 4:4.1.1) aber 4:4.0.2-2 soll installiert werden
Hängt ab: g++ (>= 4:4.1.1) aber 4:4.0.2-2 soll installiert werden
freeglut3-dev: Hängt ab: freeglut3 (= 2.4.0-5) aber 2.4.0-4 soll installiert werden
Hängt ab: xlibmesa-gl-dev soll aber nicht installiert werden oder
mesag-dev oder
libgl-dev
Hängt ab: xlibmesa-glu-dev oder
libglu-dev
Hängt ab: libxt-dev soll aber nicht installiert werden
Hängt ab: libxext-dev soll aber nicht installiert werden


So wenn ich das eine installiere fehlt das andere keine ahnung was ich nocht machen soll
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
mab82
Titel:   BeitragVerfasst am: 28.10.2006, 12:20 Uhr



Anmeldung: 26. Okt 2006
Beiträge: 22

es kommt folgende fehlermeldung :

öchten Sie fortfahren [J/n]? j
WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!
xserver-xorg-core x11-common xbase-clients xfonts-encodings xfonts-utils xutils-dev xutils
isdnutils-base isdnutils-xtools xbitmaps xterm xserver-xorg libstdc++6 vncserver isdnvboxserver
isdnutils isdnlog-data isdnlog libcapi20-dev pppdcapiplugin libcapi20-3 capiutils isdnactivecards
libssl0.9.8 ipppd libglu1-xorg libglu1-mesa type-handling
Diese Pakete ohne Überprüfung installieren [j/N]? j
Preconfiguring packages ...
(Lese Datenbank ... 95813 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke xserver-xorg-core (aus .../xserver-xorg-core_2%3a1.1.1-10_i386.deb) ...
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/xserver-xorg-core_2%3a1.1.1-10_i386.deb (--unpack):
versuche »/etc/X11/xserver/SecurityPolicy« zu überschreiben, welches auch in Paket xserver-common ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/xserver-xorg-core_2%3a1.1.1-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.