18.12.2014, 04:54 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Daddy-G
Titel: Erfahrungen mit Kernel 2.6.30  BeitragVerfasst am: 02.05.2009, 13:20 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1413

Hat schon jemand den Kernel 2.6.30 getestet ?

Bis zum Kernel 2.6.29-1 ging bei mir alles einwandfrei.
Mit Kernel 2.6.30 tappe ich im dunkel, jedenfalls bei meinem Laptop, da wo der kdm-login kommen sollte bleibt es schwarz....

_________________
Kanotix-Hellfire on Medion Akoya
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
merlin
Titel: Erfahrungen mit Kernel 2.6.30  BeitragVerfasst am: 02.05.2009, 13:41 Uhr



Anmeldung: 28. Feb 2005
Beiträge: 1112
Wohnort: Camelot
Wenn du nvidia hast solltest du unbedingt vorher den Treiber updaten. Und ob es überhaupt mit fglrx will ????
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: Erfahrungen mit Kernel 2.6.30  BeitragVerfasst am: 02.05.2009, 13:55 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

fglrx hab ich nicht auf 2.6.30 angepasst. es geht effektiv nur onboard vga und nvidia ab geforce 6.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel:   BeitragVerfasst am: 02.05.2009, 14:27 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1413

A j a danke Winken
dann ist das klar, für mich und die anderen.
Dann können ja, diejenigen mit geforce 6 + mal testen

P.S 2.6.28-12 update geht einwandfrei
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
thebluesman
Titel:   BeitragVerfasst am: 02.05.2009, 19:25 Uhr



Anmeldung: 06. Okt 2007
Beiträge: 355
Wohnort: Leipzig
auf compaq Laptop alles iO
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 14.05.2009, 20:43 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Hallo

also auf meinem Laptop läuft dieser Kernel nur bedingt. WLAN funktioniert überhaupt nicht, obwohl die Module geladen sind. Beim herunterfahren bleibt er bei "acpid:existing" stehen und das wars.

Wicd hängt sich auf ebenso ifconfig, iwconfig usw. im Terminal

hier mal paar Daten

infobash -v3
Code:

Host/Kernel/OS  "excalibur-laptop" running Linux 2.6.30-4-generic i686 [ Kanotix Excalibur ]
CPU Info        (1) Intel Pentium Dual T3200 @ 1024 KB cache flags( sse sse2 lm pni ) clocked at [ 1995.194 MHz ]
                (2) Intel Pentium Dual T3200 @ 1024 KB cache flags( sse sse2 lm pni ) clocked at [ 1995.194 MHz ]
Videocard       nVidia GeForce 9200M GS  X.Org 1.4.2  [ 1280x800 @60hz ]
Network cards   Marvell 88E8055 PCI-E Gigabit Ethernet Controller, at port: 5000
                Atheros AR242x 802.11abg Wireless PCI Express Adapter
Processes 120 | Uptime 2min | Memory 119.8/3019.8MB |
HDD ATA Hitachi HTS54323 Size 320GB (24%used) |
 GLX Renderer GeForce 9200M GS/PCI/SSE2 |
GLX Version 3.0.0 NVIDIA 185.18.08 |
Client Shell | Infobash v2.67.1


lsmod

Code:

Module                  Size  Used by
nvidia               9519876  28
binfmt_misc             8148  1
ppdev                   7216  0
lp                      9092  0
parport                35244  2 ppdev,lp
dm_crypt               12944  0
coretemp                5900  0
snd_hda_codec_realtek   198544  1
joydev                 10592  0
snd_hda_intel          27400  4
snd_hda_codec          69836  2 snd_hda_codec_realtek,snd_hda_intel
arc4                    1580  2
ecb                     2444  2
snd_pcm_oss            40544  0
snd_mixer_oss          16492  1 snd_pcm_oss
snd_pcm                77328  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           2544  0
ath5k                 119920  0
snd_seq_oss            28480  0
mac80211              216656  1 ath5k
psmouse                56644  0
pcspkr                  2188  0
serio_raw               5328  0
led_class               4048  1 ath5k
snd_seq_midi            6304  0
snd_rawmidi            21600  1 snd_seq_midi
cfg80211               67724  2 ath5k,mac80211
uvcvideo               59448  0
snd_seq_midi_event      6796  2 snd_seq_oss,snd_seq_midi
snd_seq                48880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
videodev               38464  1 uvcvideo
v4l1_compat            14096  2 uvcvideo,videodev
snd_timer              22260  3 snd_pcm,snd_seq
snd_seq_device          6968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
iTCO_wdt               10960  0
iTCO_vendor_support     3696  1 iTCO_wdt
snd                    57796  17 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_pcm_oss
,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               7232  1 snd
snd_page_alloc          9012  2 snd_hda_intel,snd_pcm
intel_agp              26300  0
agpgart                36012  2 nvidia,intel_agp
usbhid                 38144  0
sky2                   46288  0


dmesg

Code:

[   22.598784] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   23.840324] sky2 eth0: enabling interface
[   23.840538] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   24.388937] apm: BIOS not found.
[   25.718817] apm: BIOS not found.
[   26.287048] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   27.622621] nvidia: module license 'NVIDIA' taints kernel.
[   27.622626] Disabling lock debugging due to kernel taint
[   27.876791] nvidia 0000:01:00.0: setting latency timer to 64
[   27.876967] NVRM: loading NVIDIA UNIX x86 Kernel Module  185.18.08  Thu Apr 30 17:01:40 PDT 2009
[   28.000088] NVRM: failed to register with the ACPI subsystem!
[   28.000225] IRQ 16/nvidia: IRQF_DISABLED is not guaranteed on shared IRQs
[   28.270125] wlan0: authenticate with AP 00:1c:4a:a4:3d:74
[   28.272654] wlan0: authenticated
[   28.272657] wlan0: associate with AP 00:1c:4a:a4:3d:74
[   28.276754] wlan0: RX AssocResp from 00:1c:4a:a4:3d:74 (capab=0x411 status=0 aid=1)
[   28.276756] wlan0: associated
[   28.276769] BUG: unable to handle kernel NULL pointer dereference at 00000010
[   28.276772] IP: [<f84537f6>] minstrel_alloc_sta+0x66/0x130 [mac80211]
[   28.276794] *pde = bf47a067
[   28.276796] Oops: 0000 [#1] SMP
[   28.276798] last sysfs file: /sys/devices/pci0000:00/0000:00:1c.3/0000:06:00.0/net/eth0/carrier
[   28.276801] Modules linked in: nvidia(P) binfmt_misc ppdev lp parport dm_crypt coretemp snd_hda_codec_realtek
joydev snd_hda_intel snd_hda_codec arc4 ecb snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy
ath5k snd_seq_oss mac80211 psmouse pcspkr serio_raw led_class snd_seq_midi snd_rawmidi cfg80211 uvcvideo
snd_seq_midi_event snd_seq videodev v4l1_compat snd_timer snd_seq_device
iTCO_wdt iTCO_vendor_support snd soundcore snd_page_alloc intel_agp agpgart usbhid sky2
[   28.276828]
[   28.276831] Pid: 2151, comm: phy0 Tainted: P           (2.6.30-4-generic #5) R510/P510
[   28.276834] EIP: 0060:[<f84537f6>] EFLAGS: 00010206 CPU: 1
[   28.276848] EIP is at minstrel_alloc_sta+0x66/0x130 [mac80211]
[   28.276851] EAX: 00000000 EBX: f6035060 ECX: 0000000c EDX: f6b98080
[   28.276853] ESI: f6b2bc00 EDI: 00008020 EBP: f71d7df4 ESP: f71d7dd0
[   28.276855]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[   28.276858] Process phy0 (pid: 2151, ti=f71d6000 task=f6b76ff0 task.ti=f71d6000)
[   28.276859] Stack:
[   28.276860]  00008020 00000224 00000060 00000020 f6b98180 f71dfa90 f8465c20 f6b2bc00
[   28.276865]  f6b2bc00 f71d7e14 f8434a05 00000020 f6abcd38 f6abcb80 00000000 f648906e
[   28.276870]  f71e94d0 f71d7f3c f843c3d0 f845888b f6abc800 f8458889 f648904a 00000411
[   28.276874] Call Trace:
[   28.276878]  [<f8434a05>] ? sta_info_alloc+0x85/0x140 [mac80211]
[   28.276892]  [<f843c3d0>] ? ieee80211_rx_mgmt_assoc_resp+0x780/0x7e0 [mac80211]
[   28.276908]  [<c0478ebd>] ? netlink_broadcast+0x22d/0x380
[   28.276914]  [<c02e343c>] ? nla_put+0x4c/0x60
[   28.276919]  [<f843cdb1>] ? ieee80211_sta_rx_queued_mgmt+0x71/0xd0 [mac80211]
[   28.276934]  [<f843ce79>] ? ieee80211_sta_work+0x69/0x1b0 [mac80211]
[   28.276948]  [<c05360f8>] ? __schedule+0x2c8/0x540
[   28.276952]  [<c014d18d>] ? run_workqueue+0x6d/0x130
[   28.276959]  [<f843ce10>] ? ieee80211_sta_work+0x0/0x1b0 [mac80211]
[   28.276973]  [<c014d859>] ? worker_thread+0x99/0xf0
[   28.276976]  [<c0150e90>] ? autoremove_wake_function+0x0/0x50
[   28.276980]  [<c014d7c0>] ? worker_thread+0x0/0xf0
[   28.276982]  [<c0150adc>] ? kthread+0x4c/0x80
[   28.276985]  [<c0150a90>] ? kthread+0x0/0x80
[   28.276988]  [<c0103c57>] ? kernel_thread_helper+0x7/0x10
[   28.276992] Code: a1 e4 4e 72 c0 85 c0 0f 85 9c 00 00 00 31 c0 85 db 74 51 8b 45 ec 8b 50 20 8b 42
1c 8b 48 10 89 c8 f7 d0 c1 f8 1f 21 c1 8b 42 20 <8b> 40 10 39 c8 7c 3a 8d 34 80 89 fa 8d 04 b0 c1 e0 02 e8 f3 fb
[   28.277015] EIP: [<f84537f6>] minstrel_alloc_sta+0x66/0x130 [mac80211] SS:ESP 0068:f71d7dd0
[   28.277033] CR2: 0000000000000010
[   28.277036] ---[ end trace e1f2930b0937d986 ]---


vielleicht hilft das ja

Gruß deppsche

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 14.05.2009, 21:55 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

Hier bringt das nix. Kannst den bugzilla auf kernel.org nehmen oder launchpad.net und dort gegen linux-image-2.6.30.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
DerangedGonzo
Titel:   BeitragVerfasst am: 15.05.2009, 08:55 Uhr



Anmeldung: 29. Jul 2007
Beiträge: 288

deppsche: das Problem mit Wlan und dem hängen bleiben habe ich ebenfalls
Hab ein Samsung NC10, auch mit Atheros Wlanchip.
Scheint wohl daran zu liegen. Müssen wir wohl beim alten Kernel bleiben,leider ...

_________________
Ich bin nur dafür verantwortlich was ich SAGE,
Nicht das was du verstehst.
 
 Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden  
Antworten mit Zitat Nach oben
Ernesto
Titel:   BeitragVerfasst am: 16.05.2009, 10:06 Uhr



Anmeldung: 24. Jan 2007
Beiträge: 47
Wohnort: Wien/Vienna
DerangedGonzo hat folgendes geschrieben::
deppsche: das Problem mit Wlan und dem hängen bleiben habe ich ebenfalls
Hab ein Samsung NC10, auch mit Atheros Wlanchip.
Scheint wohl daran zu liegen. Müssen wir wohl beim alten Kernel bleiben,leider ...


Kann mich ebenfalls anschliessen, bei mir ist es allerdings ein Ralink RT73. ich habe die Sache noch nicht wirklich analysiert, das DHCPdiscover wird anscheinend noch durchgeführt, dann geht nichts mehr weiter.

Zum Glück funktionieren die 2.6.28er hervorragend ...

Ciao - Ernesto
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel:   BeitragVerfasst am: 17.05.2009, 17:06 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1413

Auf dem Laptop hat es zumindest mit dem neuesten 2.6.30-5 Kernel bei einer Excalibur KDE4-Installation jetzt auch geklappt. Smilie 3D (fglrx) geht auch noch. Smilie

Ein 2. Versuch auf selbem Gerät mit KDE 3.5.10 klappte mit fglrx nicht. Aber 2.6.28-13 geht ja auch super.

_________________
Kanotix-Hellfire on Medion Akoya
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 17.05.2009, 19:28 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16309

Hast das fglrx script nicht aktualisiert.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.