23.09.2014, 07:28 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
coyotl
Titel: black screen after fglrx install solved  BeitragVerfasst am: 06.05.2011, 23:12 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
card HD4650, pciE desktop, crt monitor

AMD commercial drivers do not give refresh rates better than 60hz, free drivers the same and limited resolutions.

when installing fglrx this results in a black screen and a totally unresponsive system.

this is a bug that is known in ubuntu, the solution supposedly to install latest fglrx but i did this, no change. shipped drivers have been blamed, too old for latest kernel but this does not seem to make any difference.

I have the same problem on Squeeze, crunchbang, antiX with Mepis kernel.
In Lenny I could get this card working after some struggle but not now.


Zuletzt bearbeitet von coyotl am 12.06.2012, 01:11 Uhr, insgesamt 2 Male bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: black screen after fglrx install  BeitragVerfasst am: 06.05.2011, 23:31 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

You used my fglrx install script? You can try to uninstall the driver using:

http://kanotix.com/files/fix/oss-test/p ... -driver.sh

Sometimes it helps to update the oss drivers, follow:

http://kanotix.com/files/fix/oss-test/readme.txt

Best look into IRC after you purged the driver. Sometimes it works better when you use a dvi to vga adapter with another port.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 07.05.2011, 11:07 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
your script insists on using the 11.2 driver (last time i tried that)
i tried renaming the latest but that failed for some reason

i purged ati and radeon, so now I have no X because vesa fails with 'Modeline driver enabled refusing to load'
or some such gibberish

oh well this is just an old machine i have in the summer house. have to use xp now, usually gamin only

thanx for oss tip will try
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 07.05.2011, 12:48 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

Not it does not install 11-2, only when you forget to use

update-scripts-kanotix.sh

before launch! Why on earth did you purge radeon?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 08.05.2011, 00:15 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
Sorry, I have now read some other posts and know what to do. rtfm ..

Reinstalled, was fresh install anyway. Now do things by the book before asking.
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 08.05.2011, 22:08 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
Driver working.

Now the real problem: AMDCCLE refuses to let me use refresh rates higher than 60 hz. Monitor is a crt that can run 85 or 90hz in windows.
Have they simply stopped supporting analog monitors?

I put in a modeline for 1280x1024 and TargetRefresh=85

--now refresh at 85 appears in the amd control but when I try to set it
I get an error message about out of video memory or display not
available, some such utter crap. Can try without the modeline phaps..

Well, I will not be at this machine for some days (thank God) so I can try to find the answer to the riddle. Seems I get a new error message for each
new driver version.
The card is small, for mini desktop, only one port.
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 08.05.2011, 22:40 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

I would get rid of the crt. Maybe you have got more luck when you use a dvi->vga adapter with another port. Win allows refresh rates in override mode when ddc did not get the timing right. fglrx does not. Modelines are completely useless. Better replace vga cable. But tft are really cheap now... i wanted 100 hz refresh @ 1152x864, that never worked for fglrx (your 1280x1024 res a PURE tft res as a crt is 4:3 and your res is 5:4!).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 16.05.2011, 19:44 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
Right, may get a new screen.
I notice that the 85hz i get in Win XP gives some flicker so probably 'fake'.

But I did try the same monitor on an old pc I had in the attic running Libranet 2.8.1, a Win98 era pc with an old ATI card.
With the X config utility there I got 1280x1024 85hz without problems and with no flicker (ati driver).
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 17.05.2011, 08:26 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

You are still using a 5:4 res on a 4:3 crt. That's stupid if you want to see a correct circle...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 19.05.2011, 01:02 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
heh Smilie
but I like this resolution. could go higher perhaps.

I mostly work with text, incorrect circles have not bothered me yet.

will get a tft for my work pc eventually.
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 19.05.2011, 17:55 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
1280x960
Smilie

thats what I used to run. driver issues are the same.
On the Radeon card that is, on my work desktop with geforce 9600 passive I can set high resolutions+refresh rate on same model of monitor, compaq mv920, running 1400x1050 85hz now


Zuletzt bearbeitet von coyotl am 10.06.2012, 18:51 Uhr, insgesamt ein Mal bearbeitet
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 10.06.2012, 18:50 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
A driver update (latest AMD driver) messed up my setup so I had to fix it again, this time more successfully.
Last time I got 85 hz but with a black ribbon each side of the screen..

The hardware is not the problem. Even the AMD drivers are incapable of detecting and setting up a crt monitor automatically,
they just set them up as undetected and limit refresh rate to 60.

This time after some searching I got it set up with parameters and modelines in Monitor section, now it works perfectly.
So the crt stays..

code:
Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 120.0
ModeLine "1280x960_85.00" 149.0 1280 1376 1512 1744 960 961 964 1008 -hsync +vsync
Option "VendorName" "Compaq"
Option "ModelName" "MV920"
Option "PreferredMode" "1280x960"
Option "TargetRefresh" "85"
Option "DPMS" "true"
EndSection



here is the entire xorg.conf. Generated by Mepis 8 (that is antiX 8.5). Some modifications in Monitor section.


Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "ServerFlags"
Option "DontZap" "Off"
Option "AllowMouseOpenFail" "true"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
EndSection

Section "InputDevice"
Identifier "Touchpad"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "HorizScrollDelta" "0"
Option "MinSpeed" "0.09"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0015"
Option "SHMConfig" "on"
EndSection

Section "InputDevice"
Identifier "ALPS Touchpad"
Driver "synaptics"
Option "Device" "/dev/input/mouse0"
Option "Protocol" "event"
Option "LeftEdge" "130"
Option "RightEdge" "840"
Option "TopEdge" "130"
Option "BottomEdge" "640"
Option "FingerLow" "7"
Option "FingerHigh" "8"
Option "MaxTapTime" "180"
Option "MaxTapMove" "110"
Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "0"
Option "MinSpeed" "0.25"
Option "MaxSpeed" "0.50"
Option "AccelFactor" "0.030"
Option "EdgeMotionMinSpeed" "200"
Option "EdgeMotionMaxSpeed" "200"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "SHMConfig" "on"
EndSection

Section "InputDevice"
Identifier "Appletouch"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "100"
Option "RightEdge" "1120"
Option "TopEdge" "50"
Option "BottomEdge" "310"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapMove" "220"
Option "TapButton1" "1"
Option "TapButton2" "3"
Option "TapButton3" "2"
Option "MinSpeed" "0.79"
Option "MaxSpeed" "0.88"
Option "AccelFactor" "0.0015"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Compaq"
ModelName "MV920"
HorizSync 50.0 - 85.0
VertRefresh 50.0 - 120.0
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 120.0
ModeLine "1280x960_85.00" 149.0 1280 1376 1512 1744 960 961 964 1008 -hsync +vsync
Option "VendorName" "Compaq"
Option "ModelName" "MV920"
Option "PreferredMode" "1280x960"
Option "TargetRefresh" "85"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "0-CRT1"
HorizSync 50.0 - 85.0
VertRefresh 50.0 - 120.0
ModeLine "1280x960_85.00" 149.0 1280 1376 1512 1744 960 961 964 1008 -hsync +vsync
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "PreferredMode" "1280x960"
Option "TargetRefresh" "85"
Option "DPMS" "true"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
EndSection

Section "Device"

#Option "UseDisplayDevice" "dfp"
#Option "MonitorLayout" "crt,crt"
#BusID "PCI:1:0:0"
#Option "sw_cursor" # needed for some ati cards
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
#Option "NoUseBios"
#Option "BusType" "PCI"
Identifier "Card0"
Driver "fglrx"
BoardName "unknown"
Option "UseInternalAGPGART" "no"
Option "XAANoOffscreenPixmaps" "true"
#Option "AllowGLXWithComposite" "true"
EndSection

Section "Device"

#Option "MonitorLayout" "crt,crt"
#BusID "PCI:1:0:0"
Identifier "Card1"
Driver "fglrx"
BoardName "unknown"
Screen 1
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
Option "Monitor-CRT1" "0-CRT1"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Kano
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 10.06.2012, 22:53 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16253

Hmm you have got a pretty long xorg.conf. But forced settings for crts never worked for fglrx, that driver is very bad. Best: get rid of crt and only use tft.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
coyotl
Titel: RE: black screen after fglrx install  BeitragVerfasst am: 10.06.2012, 23:04 Uhr



Anmeldung: 05. Apr 2011
Beiträge: 59
Wohnort: Norway
long yes, have even cut out some stuff.

But it works now and sure did not work before I made this xorg.conf. Better not say too much, admit I'm surprised myself.
works better than in WinXp, only use that for gaming anyway. get a flicker.
fglrx sure seems very bad.

yes should get tft but these compaq monitors weigh a ton..i leave them as long as they give good picture
 
 Benutzer-Profile anzeigen Private Nachricht senden Yahoo Messenger MSN Messenger  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.