20.08.2014, 14:00 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Predpray
Titel: PPA hinzufügen  BeitragVerfasst am: 04.08.2012, 09:06 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Hallo Leute,

ich stoße gerade auf ein Problem beim hinzufügen eines PPA. Der Befehl

Code:
add-apt-repository


ist Kanotix nicht bekannt. Wie bitte füge ich ein PPA inklusive Key hinzu??? In meinem Fall handelt es sich um das ppa:mozillateam/ppa


Vielen Dank für Eure Hilfe
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: PPA hinzufügen  BeitragVerfasst am: 04.08.2012, 10:07 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Es gibt keine PPAs für Kanotix. Im Falle von Hellfire bekommst du automatisch die neusten Iceweasel (nur ein anderer Name für Firefox), bei Dragonfire kriegst du aktuell die Version 10 samt security updates. Der Unterschied is normal nicht so riesig, aber wennst auch da neuere Versionen willst guckst im IRC mal unter !exp und !iceweasel. Dies sollte man aber erst machen, wenn man ein Downgrade schon ausgeführt hat, mit experimental als extra repo funktioniert das nicht. Etwas dumm ist dann nur noch, dass man immer selbst das kommando ausführen muss um iceweasel aus experimental zu installieren. Ich wollte dafür ursprünglich nen preferences override dafür nutzen aber hatte auch damit unerfüllte depends, also macht mans halt manuell Winken
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Predpray
Titel:   BeitragVerfasst am: 04.08.2012, 10:22 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Hallo Kano,

genau mit diesem Iceweasel gibt es seit je her Probleme. Ständig ist er abgeschmiert. Irgendwann wurde er auch nicht mehr aktualisiert. Nach einem Upgrade sehe ich dann folgende Zeilen.

Code:
root@Notebook:/home/medienservice# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Die folgenden Pakete sind zurückgehalten worden:
  iceweasel iceweasel-l10n-de libnspr4-0d


Nun wollte ich genau aus diesem Grund den aktuellen Firefox installieren. Das gelingt mir aber nicht. Wie bewege ich denn nun das System, die zurückgehaltenen Programme zu aktualisieren?

Gruß Frank
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 04.08.2012, 10:32 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

infobash -v
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Predpray
Titel:   BeitragVerfasst am: 04.08.2012, 11:45 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Code:
root@Notebook:/home/medienservice# infobash -v
Host/Kernel/OS  "Notebook" running Linux 2.6.38-7-generic i686 [ Kanotix Hellfire 20110511-14:43 ]                                                                           
CPU Info        Mobile Intel Pentium 4 - M clocked at [ 2000.000 MHz ]                 
Videocard       Intel 82852/855GM Integrated Graphics Device     [  ]                 
Processes 146 | Uptime 3:08 | Memory 407.5/731.6MB | HDD Size 30GB (35%used) | Client Shell | Infobash v2.67.2
[/code]
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 04.08.2012, 12:04 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Das führt man nie als root aus, so kann ich nicht sehen welchen xserver du nimmst. Die install ist aber älter, du wirst

!sources

wohl nie durchgeführt haben, für wlan brauchst dann auch

!plasma

nach reboot (mit alt-f2 ne konsole öffnen und dann die befehle ausführen).
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Predpray
Titel:   BeitragVerfasst am: 04.08.2012, 12:22 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Achso?

Code:
medienservice@Notebook:~$ infobash -v
Host/Kernel/OS  "Notebook" running Linux 2.6.38-7-generic i686 [ Kanotix Hellfire 20110511-14:43 ]                                                                           
CPU Info        Mobile Intel Pentium 4 - M clocked at [ 2000.000 MHz ]                 
Videocard       Intel 82852/855GM Integrated Graphics Device  X.Org 1.7.7  [ 1024x768 @0hz ]                                                                                 
Processes 140 | Uptime 3:42 | Memory 342.5/731.6MB | HDD Size 30GB (35%used) | GLX Renderer Software Rasterizer | GLX Version Yes | Client Shell | Infobash v2.67.2   


Also dann mach ich mal einen Reboot und dann die Befehle "sources" & "plasma" in der Konsole ausführen? Schauen wir mal...

EDIT: Also Plasma läuft glaube ich. Und wenn ich den Befehl "sources" mittels Alt+F2 eingebe kommt ne Fehlermeldung zu Akonadi. Was ist das?
Ich hänge mal die Fehlermeldung mit an.



akonadi.txt.zip
 Beschreibung:

Download
 Dateiname:  akonadi.txt.zip
 Dateigröße:  3.01 KB
 Heruntergeladen:  86 mal

 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Predpray
Titel:   BeitragVerfasst am: 04.08.2012, 12:49 Uhr



Anmeldung: 30. Apr 2010
Beiträge: 13

Sorry, aber irgendetwas erschließt sich mir hier nicht. Wenn ich die veralteten bzw. zurückgehaltenen Pakete aktualisieren will, gibt es Abhängigkeitsprobleme. xulrunner-14.0 wird benötigt. Wenn ich ein apt-get install xulrunner-14.0 eingebe, tauche weitere Abhängigkeiten auf. Da belibt man dann doch lieber bei Chrome bevor man hier ne Woche rumfrickeln muss.

Code:
root@Notebook:/home/medienservice# apt-get install xulrunner-14.0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Statusinformationen werden eingelesen... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 xulrunner-14.0 : Hängt ab von: libnss3 (>= 2:3.13.4-2~) ist aber nicht installierbar oder
                                 libnss3-1d (>= 3.13.2) aber 3.12.11-4~trialshot+4 soll installiert werden
                  Hängt ab von: libvpx1 (>= 1.0.0) ist aber nicht installierbar
E: Beschädigte Pakete
root@Notebook:/home/medienservice#
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 04.08.2012, 13:57 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16234

Die !befehle stehen alle im IRC.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.