20.10.2020, 23:59 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Deppsche
Titel:   BeitragVerfasst am: 23.02.2007, 14:41 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Ich muss jetzt mal ganz dumm fragen.

Gibt es irgendwelche besonderen Hardware Anforderungen für diesen Kernel ?

Er will einfach nicht auf meinem Laptop laufen.

Zitat:
Graphic
Controller
SiS650 integrated 2D / 3D graphics accelerator
4XAGP architecture graphics capability, 3D Graphics
Supported
l Graphics Motion Compensation and IDCT Supported for Enhanced
DVD Playback
l Memory
Sharing
Share-memory architecture with up to 50% of the total
system memory and/or up to 64MB
l Other
Features
Direct3D compatible, DirectX compatible
VESA DDC1, DDC2B & DDC 3.0 supported.
Appendix A PRODUCT SPECIFICATION
A-3

Storage Capacity
Hard Disk 2.5-inch format (9.5mm height) hard disk drive
.
Audio
l Audio
Chipset
SiS961 with integrated audio controller
l Sound
Capability
64-voice Polyphony Wavetable Synthesizer
DirectSound 3D accelerator
SoundBlaster Pro/16 compatible
AC’97 V2.1 compatible
Full deplex and independent sample rate converter for
audio recording and playback

BIOS
l PnP Function AMI PnP BIOS
l Self Test Power On Self Test
l Auto
Detection
DRAM auto-detection, auto-sizing
L2 Cache auto-detection
Hard disk type auto-detection
l Power
Management
APM 1.2 (Advanced Power Management) &
ACPI 2.0 (Advanced Configuration Power Interface)
l Security Two Level Password Protection
l Other
Features
32bit access, Ultra DMA, PIO5 Mode support
Multi-boot capability

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.02.2007, 14:53 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Kannst du genauer spezifizieren, was nicht geht? Wenn du nen USB WLAN Stick hast: zieh ihn ab. Aktuell sind -9 Kernel in den noide Updatepacks.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 23.02.2007, 16:39 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Wenn ich zu Hause bin poste ich die genaue Meldung. Es kommt System call trace ....bla bla bla... dann ne udev-event Meldung und irgendwas mit /sbin/modprobe

aber wie gesagt, wenn ich zu Hause bin poste ich des mal.

Mit abgezogenem WLan-Stick und Maus hab ich probiert funzt trotzdem nicht.

Er geht immer auf "a minimal Shell (ash)" mit initramfs.

Der generic-7, den es mal gab, der lief. Allerdings war dann der Deskstop extrem langsam.

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 23.02.2007, 16:47 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Geht auf deinen anderen Rechner ner -9 kernel?
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 23.02.2007, 19:13 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Code:
Host/Kernel/OS  "Kiste" running Linux 2.6.20-9-kanotix i686 [ KANOTIX 2006-01 ]
CPU Info        (1) AMD Athlon 64 X2 Dual Core 4600+ 512 KB cache flags( nx lm ) clocked at [ 1000.000 MHz ]
                (2) AMD Athlon 64 X2 Dual Core 4600+ 512 KB cache flags( nx lm ) clocked at [ 1000.000 MHz ]
Videocard       nVidia G70 [GeForce 7600 GT]  X.Org 7.1.1  [ 1280x1024 @75hz ]
Network cards   2x nVidia MCP55 Ethernet, at ports: b080 b000
Processes 121 | Uptime 4min | Memory 596.07/3043.45MB | HDD ATA Maxtor 6L200M0,ATA Maxtor 7Y250M0 Size 454GB (43%used) | GLX Renderer GeForce 7600 GT/PCI/SSE2/3DNOW! | GLX Version 2.1.0 NVIDIA 97.46 | Client Shell | Infobash v2.50


da läuft er, probiere es auch nachher mal aufm Lappi

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 23.02.2007, 21:44 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Hier macht auch das neueste Kernel-Paket keine Probleme.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 23.02.2007, 22:44 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Also auf em Lappi wills einfach nicht.

Der hiermit (get-source-compile-git-generic-kernel.sh) erstellte generic-9 Kernel läuft nur ohne USB. Wenn ein USB-Gerät angeschlossen ist, bekomme ich ne Kernel panic und ohne fährt er hoch, aber sobald ich en USB-Gerät anschliesse (z.B. WLan) hängt sich die Kiste sofort auf.

So langsam fange ich an zu verzweifeln.

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.02.2007, 01:21 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Ja der würde schon gehen, wenn man die patch Files (aus dem source dir) mit in das Verzeichnis kopiert, wo du das script startest. Das hatte ich vergessen zu erwähnen. Der ndiswrapper patch ist wichtig für dich. Allerdings teste ich grad ndiswrapper svn, der scheint mir etwas stabilier zu sein. Hab allerdings noch keinen Patch dafür gemacht. Aber du kannst das auch selbst (ohne patch halt):
Code:
apt-get install subversion
rm /lib/modules/*/kernel/ubuntu/misc/ndiswrapper/ndiswrapper.ko
svn co https://svn.sourceforge.net/svnroot/ndiswrapper/trunk/ndiswrapper ndiswrapper
cd ndiswrapper/driver
make install

Dann sollte der USB WLan Stick gehen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 24.02.2007, 09:10 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Muss ich das aus einem bestimmten Verzeichnis ausführen ?

oder geht auch /home/eddi

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.02.2007, 11:13 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Belanglos, nachdem dus ausgeführt hast kannst das ndiswrapper verzeichnis auch scho wieder löschen.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 24.02.2007, 12:54 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
was soll ich sagen

Code:
eddi@Kanotix:~$ infobash -v3
Host/Kernel/OS  "Kanotix" running Linux 2.6.20-9-generic i686 [ KANOTIX 2006-01 ]
CPU Info        Intel Celeron 128 KB cache flags( - ) clocked at [ 1693.170 MHz ]
Videocard       Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter  X.Org 7.1.1  [ 1024x768 @75hz ]
Network cards   Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet, at port: cc00
Processes 89 | Uptime 2min | Memory 211.508/567.066MB | HDD SAMSUNG MP0804H Size 80GB (8%used) | Client Shell | Infobash v2.5



ABER

Code:
[   15.692000] parport: PnPBIOS parport detected.
[   15.696000] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[   15.760000] usb 1-1: reset full speed USB device using ohci_hcd and address 2
[   16.048000] ndiswrapper: driver netwg11t (NETGEAR,09/05/2005,1.5.0.2102) loaded
[   16.052000] ndiswrapper (ZwQueryValueKey:2569): not fully implemented (yet)
[   16.400000] intel8x0_measure_ac97_clock: measured 55378 usecs
[   16.404000] intel8x0: clocking to 48000
[   17.640000] wlan0: ethernet device 00:14:6c:3a:14:a0 using NDIS driver: netwg11t, version: 0x10005, NDIS version: 0x501, vendor: '', 1385:4251.F.conf
[   17.644000] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
[   17.648000] usbcore: registered new interface driver ndiswrapper


an dieser Stelle bleibt er beim hochfahren stehen und es dauert ewig bis es weiter geht mit "Aktivating Swap". Wenn ich ctrl+c drücke läuft er direkt weiter .

Naja zu mindest läuft er jetzt.

Gruß Eddi

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 24.02.2007, 14:51 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Das scheint mir eher mit einer verkorksten /etc/network/interfaces zu tun zu haben.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 24.02.2007, 18:26 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Es gibt offenbar doch ein Problem mit dem neuen Kernel (höchstwahrscheinlich egal ob -8 oder -9). Der WLAN-Stick (rt2570) geht zwar normal in Betrieb, aber ich bekomme keine Ad-Hoc-Verbindung zum Windows-Rechner, da die essid offenbar abgeschnitten wird. Von den 5 Buchstaben der ID werden nur 4 Buchstaben ausgewertet, also z.B. 'toas' statt 'toast'. Es ist dabei offenbar unerheblich, ob ich die essid bei iwconfig mit oder ohne Anführungsstriche angebe. Auch über das Kontrollzentrum (Drahtlosnetzwerk) ließ sich die Verbindung nicht aktivieren. Mit dem alten Kernel war alles in Ordnung.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Deppsche
Titel:   BeitragVerfasst am: 25.02.2007, 09:32 Uhr



Anmeldung: 19. Jun 2005
Beiträge: 398
Wohnort: Hessen/Geinsheim
Ich glaube nicht das an der Interfaces liegt, denn dann müsste es ja auch bei anderen Kernel an dieser Stelle hängen.

hier mal meine interfaces
Code:
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo  wlan0
iface lo inet loopback
iface wlan0 inet dhcp
 wireless-mode Managed
 pre-up KEY=$(cat /etc/network/wep.wlan0) && iwconfig wlan0 key $KEY
 wireless-essid home


kann es vielleicht was mit swap zu tun haben ? Denn nachdem ich strg+c drücke kommt "Activating swap"

Fstab

Code:
root@Kanotix:/home/eddi# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/hda5
UUID=874c1a34-4cbf-4ebc-b9e8-627a5eeab69e /home           reiserfs defaults        0       2
UUID=113ccc1b-b4d2-4aaa-a7f3-7c64d1b0aefd /media/hda6     ext3    defaults        0       0
# /dev/hda8
UUID=4979e52c-a86f-49d4-a9e6-4a3ccf2b7204 /media/hda8     ext3    noauto,users,exec 0       0
UUID=9d97f822-6ca7-413a-9004-2a752b1a6aae none            swap    sw              0       0
# /dev/hda1
UUID=6ddb289e-c475-41e0-976c-c463b013f267 /               reiserfs defaults        0       1


Auszug aus Syslog

Code:
Feb 25 10:12:07 Kanotix kernel: [   19.920000] wlan0: ethernet device 00:14:6c:3a:14:a0 using NDIS driver: netwg11t, version: 0x10005, NDIS version: 0x501, vendor: '', 1385:4251.F.conf
Feb 25 10:12:07 Kanotix kernel: [   19.924000] wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
Feb 25 10:12:07 Kanotix kernel: [   19.928000] usbcore: registered new interface driver ndiswrapper
Feb 25 10:12:07 Kanotix kernel: [   76.728000] fuse init (API version 7.8)
Feb 25 10:12:07 Kanotix kernel: [   91.860000] ReiserFS: hda5: found reiserfs format "3.6" with standard journal
Feb 25 10:12:07 Kanotix kernel: [   91.864000] ReiserFS: hda5: using ordered data mode
Feb 25 10:12:07 Kanotix kernel: [   91.896000] ReiserFS: hda5: journal params: device hda5, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30



lt. syslog kommt dann "fuse init" vielleicht hat es auch damit was zu tun

_________________
Samsung R510 4GB Ram GF9200GS M 1280x800 Win7 32bit
HP Mini 311 3 GB Ram Nvidia ION 1368x768 Linux Mint 10 KDE
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 25.02.2007, 09:46 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

auto wlan0

ist für nen usb stick falsch. da nimmt man

allow-hotplug wlan0

am besten kommst mal in den Chat.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Daddy-G
Titel:   BeitragVerfasst am: 26.02.2007, 08:16 Uhr



Anmeldung: 01. Mar 2005
Beiträge: 1488

Hi,
hab gesehen, dass der kernel-update-pack wieder bei Nr. 2.6.20-8 steht. Jetzt hab ich aber schon den 2.6.20-9 drauf.
Ist das ein Problem ?

_________________
Kanotix-Spitfire
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.02.2007, 08:21 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Nun ich hab testweise wieder2.6.20-8 paketiert, weil dort pata-sis ging, leider nicht für deppsche. Im source dir ist ein Script mit git im namen, das kopiliert immer den neusten Snapshot. Ich hab nu einen Patch für rt2570 eingebaut, den sollte man mal testen. Ndiswrapper ist aktuell ein svn snapshot.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 26.02.2007, 19:00 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Bei dem Problem mit der WLAN-Verbindung hat sich hier leider nichts geändert. Kernel installiert, dann nach Neustart m-a prepare und m-a a-i rt2570 (rt2570-source hatte ich vorsichtshalber auch nochmal neu installieren lassen). Leider wird der letzte der fünf Buchstaben der essid nachwievor abgeschnitten, somit keine Verbindung zum Windows-Rechner möglich.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.02.2007, 21:10 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Warum machst du das so? Besser mal alle 2.6.20 Kernel restlos purgen:

dpkg -l|awk /2.6.20/|apt-get remove --purge --yes

Nochmal /lib/modules kontrollieren, und wenn noch was da ist:

rm -rf /lib/modules/2.6.20*

dann ist das System clean zum testen.

Der Kernel enhält selbst das modul, nur madwifi, avm, ltmodem fehlen, da ich mit der Paketierung von restricted-modules noch nicht zurechtkomme.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 26.02.2007, 21:17 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
OK, kann ich ja nicht ohne weiteres wissen, das die Module jetzt intern dabei sind, zumal ich im gewohnten Verzeichnis eigentlich auch kein rt2570.ko oder ähnliches gesehen habe. Bei den alten Kerneln waren die Module ja als 'Beilage' dabei und man hat nachinstalliert, was man benötigte. Jetzt ist ja nur noch lirc extra.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.02.2007, 21:21 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Sag blos du hast das immer extern getestet? Weil wegen dir hab ich extra einen Patch eingebaut, der rt2570 ändert... Da macht man halt vorher mal modinfo rt2570, obs da ist oder nicht.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 26.02.2007, 21:40 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Bislang ja, gebe ich ganz offen zu. Zumal in dem Thread ja auch nirgendwo steht, welche der Module denn nun schon im Kernel integriert sind. Ob der Patch damit obsolet ist und für zukünftige Versionen wieder entfallen kann, weiß ich natürlich derzeit nicht. Mit modinfo hatte ich bislang noch nicht gearbeitet, bis eben kannte ich den Befehl nichtmal.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.02.2007, 21:46 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Der könnte sogar kontraproduktiv für dein Problem sein, sagen wirs so...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Crest
Titel:   BeitragVerfasst am: 26.02.2007, 22:39 Uhr



Anmeldung: 03. Okt 2006
Beiträge: 415
Wohnort: Berlin
Tja, ich habe den Kernel jetzt nochmal installiert, nachdem ich den zuvor installierten mitsamt des externen rt2570-Moduls und -source rausgeschmissen habe. Außerdem habe ich vor der Installation noch das Patch-File für rt2570 aus dem source-Verzeichnis der Kernel-Installation gelöscht (damit dürfte er ja wohl nicht mehr zur Anwendung gekommen sein). Ergebnis: Meine WLAN-Schnittstelle hat sich von eth1 auf rausb0 geändert (die entsprechenden Files habe ich dann auf die neue Schnittstelle hin angepaßt), aber die essid wird weiterhin nach dem 4. Buchstaben abgeschnitten. Jetzt kann ich die Installation nur nochmal *mit* dem Patch probieren.
 
 Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen  
Antworten mit Zitat Nach oben
Kano
Titel:   BeitragVerfasst am: 26.02.2007, 22:51 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16734

Vermutlich hätte es funktioniert, wennst nix gesagt hättest, naja ich jag den kernel nochmal ohne den rt2570 patch durch. Und dann korrekt testen...
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.